Microsoft Tech Community Live:  Microsoft Teams Edition
November 09, 2021, 08:00 AM - 12:00 PM (PST)

Teams profile photos replaced by placeholder?

%3CLINGO-SUB%20id%3D%22lingo-sub-1359301%22%20slang%3D%22en-US%22%3ETeams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1359301%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3CBR%20%2F%3E%3CBR%20%2F%3Estarting%20this%20past%20Friday%20we%20noticed%20that%20the%20Teams%20user%20profile%20photos%20started%20disappearing%20resp.%20being%20replaced%20by%20placeholder.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20aware%20of%20the%20unification%20Microsoft%20was%20about%20to%20carry%20out%20for%20Yammer%20profiles%20so%20that%20they%20would%20use%20M365%20profile%20pictures.%20However%2C%20that%20this%20was%20going%20to%20carry%20over%20to%20Teams%20surprised%20me.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESince%20we're%20not%20using%20Exchange%20Online%20there%20seems%20to%20be%20no%20way%20to%20provide%20profile%20photos%20for%20our%20users%20any%20longer.%20In%20the%20M365%20user%20profile%20of%20a%20user%20there's%20still%20the%20option%20of%20uploading%26nbsp%3Bphoto.%20However%2C%20it's%20not%20synched%20due%20to%20EXO%20missing.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20idea%20if%20there're%20workarounds%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1359301%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPlaceholder%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EProfile%20Photos%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETeams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1359715%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1359715%22%20slang%3D%22en-US%22%3EHmm%2C%20the%20only%20thing%20I%20can%20think%20of%20recently%20is%20that%20Teams%20began%20to%20honour%20the%20OWAMailboxPolicy%20with%20respect%20to%20profile%20pictures%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2FMicrosoftTeams%2Fexchange-teams-interact%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2FMicrosoftTeams%2Fexchange-teams-interact%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EI%20know%20you%20are%20not%20using%20EXO%2C%20but%20in%20the%20above%20article%20this%20suggests%20it%20can%20also%20be%20used%20in%20a%20hybrid%20scenario%20too.%20May%20be%20worth%20looking%20at%20the%20OWAMailboxPolicy%20as%20if%20this%20is%20set%20to%20false%20may%20explain%20why%20this%20is%20occurring%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1359754%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1359754%22%20slang%3D%22en-US%22%3EI%20have%20a%20customer%20seeing%20something%20similar%2C%20not%20affecting%20all%20users.%3CBR%20%2F%3E%3CBR%20%2F%3EAAD%20Connect%20is%20in%20place%20and%20has%20previously%20synced%20photos%2C%20which%20were%20showing%20in%20Azure%20AD%20Portal%2C%20SPO%2C%20Teams%2C%20etc.%20all%20as%20expected.%3CBR%20%2F%3E%3CBR%20%2F%3EReported%20by%20some%20users%20today%20(my%20own%20account%20included)%3A%3CBR%20%2F%3Ephoto%20missing%20in%20Teams%2C%20SPO%2C%20etc.%3CBR%20%2F%3E%3CBR%20%2F%3EPlaceholder%20is%20showing%20in%20Azure%20AD%20portal%20(but%20the%20correct%20photo%20for%20the%20user%20is%20found%20when%20using%20Get-AzureADUserThumbnailPhoto).%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20got%20a%20ticket%20open%2C%20and%20they%20are%20saying%20it%20might%20be%20related%20to%20a%20service%20incident%20-%20so%20watch%20this%20space.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1359758%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1359758%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F169605%22%20target%3D%22_blank%22%3E%40Christopher%20Hoard%3C%2FA%3E%2C%20thanks%20Chris%2C%20you're%20always%20providing%20valuable%20information.%20I%20had%20a%20look%20at%20the%20article%20and%20verified%20with%20PowerShell%20that%20the%20policy%20is%20not%20blocking%20users%20ability%20to%20change%20their%20profile%20pictures%20in%20outlook%20on%20the%20web%20and%20I%20can%20change%20it%20with%20a%20pure%20online%20user%20(%40onmicrosoft.com).%20Unfortunately%2C%20our%20users%20from%20our%20domain%20that%20is%20synched%20to%20AAD%20can't%20even%20get%20there%20as%20OWA%20access%20is%20also%20served%20from%20our%20on%20premises%20Exchange%20infrastructure.%20When%20a%20domain%20account%20attempts%20to%20start%20the%20outlook%20app%20(licence%20assigned)%20it%20will%20get%20redirected%20to%20our%20on-premises%20OWA.%20Man%2C%20that's%20a%20bummer.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1359760%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1359760%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%2C%20thanks%20rob.%20That%20info%20is%20helpful.%20Please%20do%20post%20an%20update%20here%20letting%20us%20know%20if%20it's%20related%20to%20a%20service%20incident.%20Much%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1359766%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1359766%22%20slang%3D%22en-US%22%3EHopefully%2C%20it's%20related%20to%20the%20service%20incident%20then%20as%20said%20by%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1359786%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1359786%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%26nbsp%3BThanks%20for%20info.%20We've%20been%20experiencing%20a%20similar%20behavior%20in%20my%20org.%20(only%20in%20Teams%20though).%20Fortunately%20all%20we%20had%20to%20do%20was%20a%20manual%20sign%20out%20%2F%20sign%20in%20to%20the%20Teams%20app%20to%20make%20the%20photo%20appear.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1359795%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1359795%22%20slang%3D%22en-US%22%3EMicrosoft%20have%20confirmed%20this%20is%20related%20to%20a%20service%20incident%2C%20and%20they%20are%20investigating%20internally.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1359889%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1359889%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%2C%20thanks%2C%20I'll%20be%20watching%20the%20admin%20center%20as%20well.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1361429%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1361429%22%20slang%3D%22en-US%22%3Esame%20here%2C%20I%20was%20analyzing%20and%20searching%20hole%20afternoon.%20AAD%20and%20Teams%20lost%20User%20pictures.%20I%20setup%20exchange%20hybrid%20last%20saturday%20and%20believed%20in%20some%20HMA%20problems%2C%20but%20did%20not%20find%20any%20root%20cause.%20I%20also%20hope%20this%20is%20a%20ms%20service%20problem.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1362412%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1362412%22%20slang%3D%22en-US%22%3E%3CP%3EUpdate%3A%20Profile%20photos%20starting%20to%20reappear.%20Approx%2020%25%20have%20them%20again%2C%20how%20about%20you%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1362501%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1362501%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F37813%22%20target%3D%22_blank%22%3E%40Florian%20Hein%3C%2FA%3E%26nbsp%3Byes%2C%20I%20can%20confirm%20some%20of%20them%20already%20reappeared.%20Others%20still%20have%20this%20icon%20in%20Azure%20Portal%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22bc1000_0-1588749803332.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F189413i93BB2C8B3E199D08%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22bc1000_0-1588749803332.png%22%20alt%3D%22bc1000_0-1588749803332.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1362518%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1362518%22%20slang%3D%22en-US%22%3Emy%20customer%20is%20seeing%20the%20same%20behaviour%20-%20some%20photos%20have%20come%20back%2C%20others%20have%20gone%2C%20etc.%20so%20it%20looks%20like%20things%20are%20still%20being%20worked%20on.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1366090%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1366090%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%2C%20so%20today%20nothing%20much%20has%20changed%20in%20terms%20of%20updates.%20Some%20users%20see%20their%20photo%2C%20many%20don't.%20Can%20you%20give%20me%20your%20incident%20ticket%20number%20so%20I%20can%20create%20my%20own%20and%20link%20the%20cases%20for%20MS%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1366220%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1366220%22%20slang%3D%22en-US%22%3EMy%20client%20is%20still%20seeing%20the%20same%20-%20our%20ref%20is%2019879894%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1368744%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1368744%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%2C%20Thanks%2C%20here's%20mine%20in%20case%20you%20want%20to%20forward%20it%20to%20MS.%26nbsp%3B%3CSPAN%3E19921140%E2%80%8E.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1369176%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1369176%22%20slang%3D%22en-US%22%3E%3CP%3Eabout%2010%25%20are%20missing%20on%20my%20site%2C%20others%20recovered.%20Teams%20with%20it%C2%B4s%20icon%20cache%20in%20desktop%20and%20mobile%20apps%20add%20some%20additional%20time.%20It%20is%20best%20to%20check%20in%20the%20web%20edition.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1369298%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1369298%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F656778%22%20target%3D%22_blank%22%3E%40bc1000%3C%2FA%3E%2C%20interesting.%20I%20can%20confirm%20that%20the%20web%20app%20shows%20more%20users%20but%20still%20also%20about%2010%25%20missing%20I%20would%20estimate.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EClearing%20the%20cache%20under%26nbsp%3B%25AppData%25%5CMicrosoft%5CTeams%5CCache%20made%20it%20so%20the%20client%20reflects%20the%20current%20state%20as%20well.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1369313%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1369313%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F37813%22%20target%3D%22_blank%22%3E%40Florian%20Hein%3C%2FA%3E%26nbsp%3BI%20checked%20again%20a%20few%20minutes%20ago%20and%20in%20the%20web%20app%2C%20it%C2%B4s%20even%20worse...%20%3A(%3C%2Fimg%3E%3C%2FP%3E%3CP%3EBut%20AAD%20looks%20better%2C%20but%20these%20are%20only%20AAD-synced%20thumbnails.%20Because%20we%20actually%20still%20have%20onprem-mailboxes%20(with%20exchange-hybrid%20running)%20I%20am%20not%20100%25%20sure%2C%20which%20source%20of%20pictures%20teams%20actually%20use.%20As%20I%20read%20teams%20use%20exchange%20online%20as%20source%20for%20pictures%20and%20with%20exchange%20hybrid%2C%20it%20should%20fetch%20pictures%20from%20onprem-mailboxes%20%2F%20onprem-exchange.%20HMA%20required.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1381734%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1381734%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F656778%22%20target%3D%22_blank%22%3E%40bc1000%3C%2FA%3E%2C%20same%20configuration%20on%20our%20side%2C%20still%20on-prem%20with%20Exchange%20but%20I%20if%20Exchange%20Online%20was%20a%20prerequisite%20for%20Teams%20profile%20photos%2C%20why%20are%20most%20showing%20at%20all%3F%20The%20logic%20seems%20broken%20somewhat.%20I%20still%20have%20the%20ticket%20open%20being%20told%20they're%20still%20working%20on%20it.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1382742%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1382742%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F37813%22%20target%3D%22_blank%22%3E%40Florian%20Hein%3C%2FA%3E%26nbsp%3BI%20can%20confirm%20all%20profile%20photos%20appeared%20again.%3C%2FP%3E%3CP%3EThe%20profile%20sync%20and%20workflow%20with%20all%20it%C2%B4s%20different%20circumstances%20is%20a%20desaster.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Finformation-about-profile-picture-synchronization-in-microsoft-365-20594d76-d054-4af4-a660-401133e3d48a%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Finformation-about-profile-picture-synchronization-in-microsoft-365-20594d76-d054-4af4-a660-401133e3d48a%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1385461%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1385461%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F656778%22%20target%3D%22_blank%22%3E%40bc1000%3C%2FA%3E%2C%20thanks%20for%20the%20update.%20Still%20ongoing%20in%20our%20tenant%20but%20I%20agree%20that%20it's%20a%20mess.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1404141%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1404141%22%20slang%3D%22en-US%22%3E%3CP%3EDoes%20anyone%20know%20if%20MS%20have%20published%20anything%20on%20this%3F%20I've%20been%20unable%20to%20find%20any%20comment%20from%20them.%20Thanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1404862%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20profile%20photos%20replaced%20by%20placeholder%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1404862%22%20slang%3D%22en-US%22%3EI've%20not%20seen%20anything%20published%20so%20far%2C%20but%20my%20ticket%20for%20my%20customer%20is%20still%20running%20-%20the%20photos%20are%20fine%20in%20Teams%20now%2C%20and%20AAD%2C%20but%20not%20consistently%20showing%20in%20Delve%20or%20SharePoint%20%2F%20OneDrive.%3C%2FLINGO-BODY%3E
Regular Contributor

Hi all,

starting this past Friday we noticed that the Teams user profile photos started disappearing resp. being replaced with the placeholder.

 

I'm aware of the unification Microsoft was about to carry out for Yammer profiles so that they would use M365 profile pictures. However, that this was going to carry over to Teams surprised me.

 

Since we're not using Exchange Online there seems to be no way to provide profile photos for our users any longer. In the M365 user profile of a user there's still the option of uploading photo. However, it's not synched due to EXO missing.

 

Any idea if there're workarounds?

 

Thanks.

27 Replies
Hmm, the only thing I can think of recently is that Teams began to honour the OWAMailboxPolicy with respect to profile pictures

https://docs.microsoft.com/en-us/MicrosoftTeams/exchange-teams-interact

I know you are not using EXO, but in the above article this suggests it can also be used in a hybrid scenario too. May be worth looking at the OWAMailboxPolicy as if this is set to false may explain why this is occurring

Best, Chris
I have a customer seeing something similar, not affecting all users.

AAD Connect is in place and has previously synced photos, which were showing in Azure AD Portal, SPO, Teams, etc. all as expected.

Reported by some users today (my own account included):
photo missing in Teams, SPO, etc.

Placeholder is showing in Azure AD portal (but the correct photo for the user is found when using Get-AzureADUserThumbnailPhoto).

I've got a ticket open, and they are saying it might be related to a service incident - so watch this space.

@Christopher Hoard, thanks Chris, you're always providing valuable information. I had a look at the article and verified with PowerShell that the policy is not blocking users ability to change their profile pictures in outlook on the web and I can change it with a pure online user (@onmicrosoft.com). Unfortunately, our users from our domain that is synched to AAD can't even get there as OWA access is also served from our on premises Exchange infrastructure. When a domain account attempts to start the outlook app (licence assigned) it will get redirected to our on-premises OWA. Man, that's a bummer.

@Rob Ellis, thanks rob. That info is helpful. Please do post an update here letting us know if it's related to a service incident. Much appreciated.

Hopefully, it's related to the service incident then as said by @Rob Ellis

Best, Chris

@Rob Ellis Thanks for info. We've been experiencing a similar behavior in my org. (only in Teams though). Fortunately all we had to do was a manual sign out / sign in to the Teams app to make the photo appear.

Microsoft have confirmed this is related to a service incident, and they are investigating internally.

@Rob Ellis, thanks, I'll be watching the admin center as well.

same here, I was analyzing and searching hole afternoon. AAD and Teams lost User pictures. I setup exchange hybrid last saturday and believed in some HMA problems, but did not find any root cause. I also hope this is a ms service problem.

Update: Profile photos starting to reappear. Approx 20% have them again, how about you?

@Florian Hein yes, I can confirm some of them already reappeared. Others still have this icon in Azure Portal  

 

bc1000_0-1588749803332.png

 

my customer is seeing the same behaviour - some photos have come back, others have gone, etc. so it looks like things are still being worked on.

@Rob Ellis, so today nothing much has changed in terms of updates. Some users see their photo, many don't. Can you give me your incident ticket number so I can create my own and link the cases for MS?

My client is still seeing the same - our ref is 19879894

@Rob Ellis, Thanks, here's mine in case you want to forward it to MS. 19921140‎.

about 10% are missing on my site, others recovered. Teams with it´s icon cache in desktop and mobile apps add some additional time. It is best to check in the web edition.

@bc1000, interesting. I can confirm that the web app shows more users but still also about 10% missing I would estimate.

 

Clearing the cache under %AppData%\Microsoft\Teams\Cache made it so the client reflects the current state as well.

@Florian Hein I checked again a few minutes ago and in the web app, it´s even worse... :(

But AAD looks better, but these are only AAD-synced thumbnails. Because we actually still have onprem-mailboxes (with exchange-hybrid running) I am not 100% sure, which source of pictures teams actually use. As I read teams use exchange online as source for pictures and with exchange hybrid, it should fetch pictures from onprem-mailboxes / onprem-exchange. HMA required.

@bc1000, same configuration on our side, still on-prem with Exchange but I if Exchange Online was a prerequisite for Teams profile photos, why are most showing at all? The logic seems broken somewhat. I still have the ticket open being told they're still working on it.