Teams on macOS only shows a blank white screen

Copper Contributor

Hi all,


for a few weeks now, my Teams app on macOS doesn't work anymore. When I open it, I just get a blank white window. No possibility to do anything. Closing and Re-Opening the Window doesn't help. Quitting the app takes unusually long (~10-15 seconds).


What I've tried:

  • Deleting and re-installing the app
  • Deleting caches and other "Application Data" (while re-installing the app)
  • Logging out and back in
  • Sweeping the entire app and any data associated with it using AppCleaner, then re-installing the app

Up until now, I could use an old installer to get an older version of Teams (v1.00.333671). This would then still run with almost no issues, only the "virtual background" feature in video calls was not working.

However, since Teams has Auto-Update always enabled and it's impossible to turn off, this only lasts a few days. Starting today, it stopped working altogether and now only shows a "please update to the latest version" banner. So now I'm stuck using the web app in the browser, which is far from great.


Hardware is a 13-inch MacBook Pro from 2018, running the latest macOS Monterey.

Needless to say that up until this problem showd up, everything was running perfectly. No problems with the teams app whatsoever, and all features worked as expected. So I guess it can't be a hardware issue. Software-wise there isn't much going on apart from the usual macOS updates.


I'd appreciate any tips on how I can resolve this.

23 Replies

Hi @jlubberger This issue has shown up a lot in this community - you might want to search here for related this one: Microsoft Teams for MacOS is Blank - Microsoft Tech Community

Thanks for the reply, I didn't mention that in my post: Of course I already did an extensive search on the topic and stumbled upon a couple of threads in this community. However, most of them boil down to other problems or, in the case of the thread You mention, were solved with a solution that didn't work for me (logging out via the dock context menu didn't work for me, and even logging out in the "old-but-still-running" version didn't help).
Hi. I'm having the same issue and can not find any solution to this problem.. Did you find any solution for it? What I also found is that I also cannot open teams on any browser and even in incognito.

@ghostrider98No, so far I couldn't find any solution. I'm stuck using the Browser version which sadly is restricted to chromium-based browsers by Microsoft. However, at least that works acceptably.

If even this does not work for you, it seems the problem might be more fundamental in Your case, and not specific to the (Mac) app.

@jlubberger Try the utility at and do a "Factory Reset" of Teams. It is the best option I know of for addressing unusual issues with Office apps. I make the reset packages offered at that site available to my entire fleet in Jamf Self Service and I probably run that reset on Teams on my own computer 2-3x a year.

@finlay I tried your solution with a Factory Reset with and I'm at least getting now a new window where it says that Microsoft Teams is loading. But now it is stuck on this :( 

@finlaySame for me as with ghostrider98, unfortunately: Using that tool (which looks quite promising, I must say), I got to the point where I was asked for my credentials to log in, but after that, I got stuck at the splash screen / loading banner. A "second round" of resetting also didn't help.

Edit: After a long time, the loading screen disappears and I get the same blank window as described in the original post.

@jlubberger If you right-click on the teams icon that is in the dock you can also open the loading banner (or at least it is for me like that) and the blank window is unfortunately still there..

Any luck with this issue? I have the same issue. Just wondering if you made any progress.


@liamf91Not really: A newer Version of Teams eventually solved the issue for me (I don't know which version it was specifically, it was some weeks after I posted the original question), so I still don't know the cause or a workaround for this strange error.

Ah fair enough. I will look into my users Macbook and see if an updates are required, normally it should auto update, unless he is still on an older OS version.

@liamf91 What worked for me is that my account got reseted by an admin and then I could use teams again

I'll keep that in mind. This seems to be isolated to a single user. When he joins a meeting it will show a white screen. He will then leave and rejoin, and its totally fine.

@liamf91  What anti virus is install on the computer if any?

What Anti Virus is installed if any?
Hello guys, in our company, i manage over 250+ Macbooks and this problems occurs only on Intel CPUs Macbooks others with M1-2 CPUs works fine. We tried everything, but even problem is solved for some time, it happens again, so its seems that this version has some problem on older Intel devices.
Has there been any response or guidance on this? It's still a daily issue and all the proposed solutions only work temporarily.
I had the same issue and searching web, I came here. However there was no concrete solution, however something I tried did work and hope it works for all those who hare having the same issue.

1.) Open Teams and if you see blank white screen. Right click on the Teams Icon in the Dock.
2.) From the PopUp menu, click Sign Out.

My screen refreshed and it took me to the Welcome to Teams! home screen.

Hope this works for you all!

Happy Computing!
After going through a lot of threads and trying a lot of things, what worked for me was:

1. Uninstall Teams.
2. Delete everything related to Teams in the user library...
2.1 Go to Macintosh HD > Users > [your_username] > Library | this is a hidden folder, to toggle
hidden folders visible: cmd+shift+period(.)
2.2 Delete anything related to Teams in Application Support folder. Be it any folder, like, subfolders under microsoft named teams, etc.
2.3 Delete anything related to Teams in Containers folder.
2.4 Delete anything related to Teams in Caches folder.
3. Reinstall Teams

I actually found a Teams folder (I don't remember the directory as I was just mad) that was about 2.9GB large, and after deleting it and reinstalling, Teams started working properly.

Hope this helps!!