Teams not using my account to join meetings, making me join as guest

Copper Contributor

According to everything I have been able to find online, if you are sent a meeting link for an MS Teams meeting and you click on it when you are signed into your Teams account, it should let you in as a guest using your personal Teams account.


It works for my colleague, but for some reason even though I am signed into Teams, it comes up with the guest box where you have to type in your name, which only has limited features when in meetings.  He is clicking on the meeting links that get emailed through to us, and it is using his Teams account to access the meeting but no matter what I do, it wont work for me.


I have had nothing but trouble joining this way, as sometimes when I join a meeting I am getting no camera input from the other members of the meeting (who I need to see to do my job), or they cant see me even though my camera is showing for me (likewise they need to see me), and Teams will from time to time close mid meeting (sentence) and then I have to restart and go into the meeting again. It is very disruptive and I am being viewed as unreliable.


Does anyone have any ideas why it would not be using my account to join meetings?  Have deleted and re-downloaded Teams, and been googling everything I can to try and fix this but no joy.  Please help....feel like am at risk of losing work if I cant fix this.


(P.S. I am using Apple devices)


9 Replies
Not sure what's going here. But Teams will try to use the domain-joined account whenever possible. There are a few things to check and keep in mind. Have a look at the computer account settings (if Mac have those) to see if there are multiple accounts added there. Make sure to be signed into Outlook desktop client with the same account as Teams desktop client. Verify that you're signed into the correct organization from the top right corner in Teams (the tenant/org switcher).

You can remove all info in the Teams cache location in your Mac. Navigate to ~/Library/Application Support/Microsoft. Right-click the Teams folder then select Move to Trash.

Thanks for your reply @ChristianJBergstrom, I recently removed 2 organisation from the Teams app so now it just has my personal account. I was having trouble removing one organisation from the list in the Teams app despite leaving the organisation through steps I found here, so spoke to tech support to get that resolved thinking that was blocking my access, as I haven't been able to switch between accounts. I only have my personal account listed in Teams now, but sadly the problem still exists. In the process of getting the organisation removed, the cache was cleared so there is nothing there now. I am the only one who uses this account and computer as it's for work. I don't have outlook linked to my Teams account and neither does my colleague so don't think that is the issue. The only difference between my colleague and myself is that I use gmail email address, he uses his apple email address, and I have an office 365 account but he doesn't, he has has also had one of the same organisations linked to his teams account, yet was still able to switch between accounts. Other than that, everything else is the same. I've also tried it on other devices with no luck. Any other ideas would be greatly appreciated. Do I need to see if I can contact Microsoft? When I spoke to the guy last week he suggested reaching out the community, which is why I posted here.


Update....I have been able to join using my personal account on my iPad using the mobile app, but not on my laptop or iMac desktop computer....Is it something to do with the the desktop app?  I wasn't even able to join on another device like I could when using organisation log in...but sadly iPad is too small to be able to work off.

Is your default web browser Chrome or Safari? If it is Safari, turn off the 'cross-web tracking' then try the link again, it should then prompt you to open the link in the app.

In Safari - Preferences > Privacy and uncheck the Prevent cross-site tracking setting.
Let’s see if the other suggestion works. I’m not a Mac person, never used it actually
Thanks for that @MBUWACR Just tried that and still not opening up in personal account. It wouldn't matter so much if the quality joining as a guest was better, but am having so many problems it's getting really frustrating. Was hoping someone else had had the problem and resolved it...fingers crossed.

Hi, did you ever figure this out? I am having the same issue (and a Mac user too). Teams launches fine on my phone, but not on my laptop. Even if I am logged into Teams with my Microsoft account, I can join calls only as a Guest. Feeling very frustrated. Would love to hear if there are any solutions already nearly one year from original post! Thanks in advance.

@Junisse I have exactly the same issue.  Very frustrating.  If I try to use the app, it tells me my personal account doesn't work and then I have to use the browser as a guest and is a much less professional experience.  Why have a personal account for teams if the app never works?  It also will not sync with y calendar to load Teams meetings, so I have to go to my email or send details from my mobile device to even get into the browser meeting.

@Microsoft_Teams_team Do you have any answers for this? Thanks.

Sorry for delayed reply, my account got a whole lot worse and wasn't even able to log into reply.

Sadly still no luck with working out what is wrong or why it's happening. I've spent about 20 hours in the online chats with Microsoft, on their advice, cancelled my subscription, waited 60 days and tried to set up a new account and it still didn't work. They promise you they will help you fix it but all that happens is you end up with a handful for case numbers and a whole lot of frustration and time in your life you will never get back. Just seem to go around in circles, they all have the same basic information, so each person you chat to will get you to do exactly the same thing and after 1-2 hours they say they'll escalate it, then that gets closed off with no resolution. Haven't been able to find a phone number to talk to anyone.

Honestly after all this time, it must be a problem with the app but they don't seem to care.