Teams membership after admin

New Contributor
Hi, Due to a company re-org I’ve recently needed to amend a bunch of memberships of Teams via Teams Admin for various users. This has worked. However, whenever I launch Teams now, I see the Teams that I updated for the other users now appearing in my Windows Teams app at sign in, and then they disappear after a few seconds. On my phone app they remain displayed , although I have no access to anything in the teams.
None of my own teams memberships were changed during the update. Myself and colleagues have checked and I’m not a member of these teams. If I try to leave the Teams via the phone app I get a ‘something went wrong’ error.

Hopefully this makes sense - does anybody know how I can stop these teams appearing for my account?
4 Replies
Have you tried logging out / in in both clients?

@Alfie-t I have this same problem. I've tried leaving the team from the smartphone app, Windows desktop, Mac desktop, and browser versions. I get the something went wrong error. I am not a member of those teams, but I'm an admin who has recently managed those teams' membership. I have signed out of these apps many times, deleted/reinstalled, with no change.

@sgreer5  OK, I don't feel quite so stupid now then!  If I find a solution i'll post it back here.

Did you ever figure this out? I have been having a similar problem for many months. . Some of the Teams are deleted long ago.
I have Tried Leaving the Team using the gear at the Join or Create Team UI.
I have tried clearing Teams cache.
Remove and re-install of the Desktop client
In the Office 365 portal I am not in any of the groups,
In the Teams admin portal I am not listed as a member (and some Teams are gone because they're deleted).