Teams Login issues: You can't get there from here (non domain jointed device)

New Contributor

This application contains sensitive information and can only be accessed from:

 

domain joined devices.Access from personal devices is not allowed.

 

What is weird that it works for random set of users, I have two personal devices and it works on 1 but not another and if does start working after 3 days it will bomb be out. Any clues as to why this is happening and why it works on some personal devices and not others.

4 Replies

You seem to have a Conditional access policy configured to require a compliant device for access. Talk to your admins and point them to this article: https://docs.microsoft.com/en-us/azure/active-directory/conditional-access/concept-conditional-acces...

@Vasil Michev 

 

Hi the strange thing is he works on random personal pcs, which does not make sense if there was a conditional policy. If there was a conditional policy then I would not be able to get in at all.

 

I have slightly managed to get fix for an hour but then teams  keeps logging me out.

 

So I remove all files in appdata\roaming\microsoft\teams 

then 

I will logon get error then again I will try again 

I logon get error 

and teams browser comes up but purple box appears which is like a authentication tunnel login and it works.

But all of sudden intermittent they are getting logged off at first it was 3-4 days but mine all of sudden on one of the pc's it every hour. 

There is no set rule for this so was wandering if there is anything I can fix in the background to try and resolve the issuse and what causes the purple box to appear?

 

Having the same issue. It worked fine till March 30th and had not change any Conditional Access policies.
Having the same issue. It worked fine till March 30th and had not change any Conditional Access policies. Microsoft has changed something as few other companies are experiencing the same behavior with Teams We, To Do and Yammer.