Teams Keeps Closing / Crashing on Mac

New Contributor

I haven't seen this particular issue addressed anywhere yet, so I hope I'm not repeating something. I run Teams on a MacBook Pro running Sierra 10.12.3. Teams launches and runs fine, but about 10 times a day I'll go to use Teams and it will be closed. I'm not getting errors — the app is just no longer running. When I click Teams in dock to open it (or, more often, use Alfred), the app seems to open, but the window doesn't appear. I need to click on Window from the menu bar and select an option that says something like "Teams is loading" (I can't recreate it now, so don't recall what it says exactly). I also get a message popup that says that I've installed all updates and that I'm running the most current version of Teams (again, I can't recreate right now, so don't recall the exact language).


Is there a known issue with Teams closing itself regularly on Macs? None of my Windows users (which is pretty much everyone else) are experiencing this issue. It's almost like the app times out if it's not used for a while and closes. It's annoying, though, because I'll get an update on my phone and then realize that the desktop app has stopped running again. Super annoying — please help!

60 Replies



I'm experiencing the same problem on MacBook Air running Sierra 10.12.3 too.


What I think is that Teams checks updates availability, and even if I have the last build (I think :, it seems that it finds it has a most recent update to do, so installs it and closes (and not restarting). But it has just installed the same build, again and again.

When I "check for updates" manually, it works in background and then says "update done ; please refresh". But after restart : still the same build.


Very annoying, I agree ! And I didn't find a way to deactivate automatic update.

After posting this yesterday, I tried uninstalling and reinstalling Teams and it seems to be stable now. I'm recommend giving that a shot to see if it fixes it for you. Not sure what destabilized the app, but hopefully having a fresh install of the latest version has fixed it.

Fact is, by downloading myself again the available package online (, and uninstall/reinstall, I'm now on
So automatic updates don't work...
I already experienced this few weeks ago, and it was stable after this. But came again few days ago.

I think the "check for updates" works, it sees there's a more recent build, but it fails to install the last one, and keeps stuck in the same "old" version. Looping the process (and never restarting, only closing).

I hope this new one will be better in this updating process.

I'm experiencing this on several 10.12.3 Macs, as well with a range of versions, most recently 0.00.75204, to which I updated manually last week.  The updater seems to want to relaunch Teams several times per day, but does not actually update.  Occasionally following the relaunch, Teams displays a "something went wrong" message, and has to be relaunched manually.


Further, in some cases, Teams places additional duplicate copies of the update package at ~/Libarary/Application Support/Microsoft/Teams/tmp/, and doesn't always clean them up.  Most Macs have several copies of the package accounting for 500-1500MB in this directory.  I found one Mac that had been running teams for a couple weeks with 257 copies of the package in this directory, accounting for ~20GB of disk space.


All of these Macs are logged-in to a single account most of the time.  It's a standard (non-admin) mobile AD account with a local home.  On at least one of these, Teams prompted for admin privileges at first run about 20 times, in what looked like an attempt at setting up an update helper daemon run by root (screenshot attached).  Other Macs never prompted for this, or only did once.  All of them run two procs called "Microsoft Teams Helper" under the standard user while Teams is running.


Something that is mostly a separate issue, but is exacerbated by the relaunch behavior, is that Teams has stored a credential in my login keychain (whether I tell it to or not), and seems capable of using it, but prompts for auth using a dialoge with the user/pass already populated.  So, it seems capable of automatically authenticating, but is asking me to click an additional "submit" button for no apparent reason fairly often.  Screenshot attached.

Thanks for adding this additional detail as it more accurately describes the problem I've been having. And yes, it's happening again, so it makes sense that it has to do with the updater. I'm probably going to uninstall/reinstall again to see if I can stabilize it again, but I'm sure the problem will surface again once an update is required. This is a major problem for Mac users.

Bump.  For me, this seems to be an ongoing problem on the Mac client in the releases following the GA announcement, on all Macs I've seen that primarily use standard accounts.  


For what it's worth, I've calmed the relaunching/crashing in my environment by borking permissions on a directory used by the squirrel update framework, which has made the Teams client more tolerable for Mac users.  This isn't desireable, increases manual update burden, and I don't expect it to help indefinitely, but it has made the Teams client a more stable and consistent experience for now.

Same observation here on macOS 10.12.4. Manual reinstall seems to fix it until there is a new version available. Very frustrating, as you miss out on important messages without any notification ...

Has anyone seen a patch or official fix from Microsoft. We are seeing this on 2 macs running Sierra and it did start after a new version was available.

We are experiencing the same issue over here in our org.
Oddly enough, it only seems to prevail on 50% of the macs while the other 50% seem to have no issue.
We run a standardized environment so all hardware and software is identical across the board - leaving this problem to seem like a user specific one. I originally guessed that it might be something that was caused due to these affected users installing some sort of software that conflicted with Teams but have not been able to find anything as of yet.

Thowing my name in the ring as someone who has had this since the client launch (currently on I will say, however, that it seemed pretty stable today and my build was updated today so maybe it was fixed?

Are you all running your Mac user account as "Standard" rather than Admin?  I am, and I have the problem.  My colleagues are not, and it works fine.


Here is what I think is happening:


Teams goes to look for a new version, downloads it, closes itself to auto-update, tries to but fails as it does not have admin privileges.  Thus it silently fails to update and re-open.  Usually applications that need admin privaleges pop up a dialog box to ask for it.  I suspect the update process for Teams is meant to be silent/background and hence has no UI interaction to pop it up.


Workaround - go to the MS website and manually download latest version.  Delete current version from Applications, install new version.  Sadly you have to do this manually everytime there is a new version until MS realises this and fixes it.


Chaz - yours will seem stable until there is a new version!


Sorry for the late reply but thanks for the investigation! Hopefully this will get fixed soon!

Terams on Mac os 10.11.6 keeps crashing. After restart - it "you have downloaed this from the internet in 2016."  



Then it is stuck on "checking your internet conneciton"

Yikes! Looks like someone pulled the plug on the internet.


Tried, trashing all teams preferences, and re-installing it from mulitple locations -same results if i restart the mac teams is kaput. 


** Frustating as this is rolling out compnay wide.

I also have a user that has the latest version of MS Teams. He reports that MS Teams on his Mac will close/shut down randomly with no error message or notification. He is using a MacBook 12' Retina Early 2015 with OSX Sierra 10.12.2.



I want to do a full removal of the program with the Library folder, but feat that the Chat history could be removed as well. Can someone confirm this?




MS Teams chat history resides with O35 in the cloud. You can wipe out everything on that local machine without a worry. I've, however, tried this method and it doesn't seem to be a permanent fix as the issue has reappeared on every user i've gone this route with.

I have this issue and every user experiencing it is a standard user. Giving administrative priv to users is out of the question unfortunately.

Thank you Seth for the quick reply and confirming the Chat history feature.


@David Behr The user reporting this to me also has Admin rights so I don't think this is a permission problem.

Regarding the admin/standard concern, I'm curious whether others see what I do running in the background.  Does anybody affected by this see process ownership by anything other than the currently-logged-in user account when running Activity Monitor, selecting 'View>All Processes' and filtering for 'teams' (while the Teams app is running)?