Teams IP Phone / Display Lenovo ThinkSmart View - no version info and update




I have a Lenovo ThinkSmart View and enrolled is successfully to my Teams environment, see the picture of the Teams Admin -> Devices -> IP Phones



The device is working ok and I can join Teams meetings etc.

But when I look at the details of the device, I don't see the 'Software Health' details (no software version etc.), it says ' We looked but no data is available yet',  see this screenshot:

I think this might be the reason Teams Admin Center does not give me any updates.

I don't get the update through this method on my Lenovo ThinkSmart:
Firmware CD-18781Y.200410.067,  No updates available ....
I'm still on 1449/ , so now new Teams Display interface.

I tried to enroll my Lenovo ThinkSmart View on 3 different Office 365 tenants, all the same result.
Multiple hard resets of my device with no luck....

Who can help me here to get my device updated ?

13 Replies

Hi @Marcel Alberts, can you give me some more details about the Teams Display? How long is the device connected to Teams? Is the device up and logged in with your account for a while? For one of my devices, it took up to 2 hours till the necessary info's popped up in the TAC and I could initiate the upgrade. On the first screen shot there is also an information visible that the TAC still gathers some configuration information. Did you configure any policies or configuration sets in your intune environment? Not that I'm an expert for intune or MDM, but when login into Teams, the devices registered in your enterprise portal and should be available in your intunes portal, I guess.   

@Thorsten Pickhan I connected the device for more than 8 hrs and made some successful meetings with the device. No Intune enrollment, only MFA .... I tried with and withtout policies; both no luck on the software version information ...

@Marcel Alberts, do you have Conditional Access enabled in your Tenant? Read some articles about missing configuration and software version information for MTR devices when CA is enabled.

I've enabled MFA for an account in my lab tenant and registered the Lenovo Display successfully with this account. I could update the display a few weeks ago, already. And it works like a charm, even with MFA enabled account. 

Thxs - can you point me to this articles?

@f course, found some people reporting this behaviour in the TechCommunity here:

One place to manage all your Teams devices - Microsoft Tech Community

Search for the user posts on 08/12/2020 from butters and C_Clark. They reported problems when CA is in place and verified it by putting the CA policy to "Report only"-mode.

@Thorsten Pickhan Guidance is spot on, thanks!


I added an CA policy in AAD and the firmware update was available. I used the article below as a guide to configured the policy for this issue. 


Enable Azure AD Multi-Factor Authentication | Microsoft Docs



Wow, that's good to hear @antfor . So, you created a dedicated CA policy for the user who is registering on the Teams Display. And this CA policy is in Report only mode. So, at the end, it will not prevent access to Office 365. And with this change the device can upgrade now? 


@Thorsten Pickhan 

Yes, it worked. I did it with my own O365 enterprise tenant in order to get the device running teams view. I then logged off and logged into another tenant (my work account) and have it running teams view, and didn't have to bother the IT guys. It’s an awesome device. 

@antfor and @Thorsten Pickhan


Thank-you very much for this discussion and solution. I had spent several weeks on and off bouncing round between it being a device issue or a licensing issue but the CA policy in Report only mode fixed it! Amazing. Thank-you both :)

Anybody have any insight on how to get this thing updated and converted?  Device shows up in TAC, shows firmware "null" and Healthy.  I am not using CA.  Device has been connected to tenant for a couple days now.  Very frustrating.  

Hi Marcel, did you ever get your device to update?
Hey @Thorsten When I try setting up a CA policy for enrollment by using the Intune Enrollment App and require MFA the L

@Tony McQueen 


I have the exact same problem with three of these devices.  No matter what I can't get the updates to show for these things.  I am not using conditional access either.  I moved it between my corporate tenant to my personal tenant as well with no changes detected.


Any progress on your end?