Teams Infinite Sign In Loop

Brass Contributor

Hi,

 

I'm working remotely from home, and have had to install teams on my computer.

 

When I sign in, I select my personal account attached to the email address, and type my password. Teams then presents me with a drop down to select my work ORG, I select this, and it tells me "We're switching to your other account". Then I just get in an infinite loop doing the same over and over again.

 

I have logged in online with the exact same credentials and it works perfectly.

 

Please can anyone urgently help me.

 

Thanks,

Dylan.

 

dylanlogan_0-1585131862355.png

 

28 Replies

This is gold. Thanks! @Christopher Hoard 

Hey,

I just wanted to let you guys know that I managed to get the Teams login back to work by resetting the IE settings.

kaot1986_0-1620731939970.png

 

Deeply frustrating to face this recurring problem on my Teams App on my work machine. It's sometimes Teams and Outlook and most often it's Teams; where it refuses to log me in!!

I am able to log in on my office machine via the browser with no problems. My home PC also has an installation of Outlook and Teams of my work account and again no problems! My Ipad, iPhone, etc. all have no issues logging into Teams and Outlook.

My Internal IT team in the organization is scratching their heads and this problem remains in play for over 3 months now!!!!!

Microsoft needs to fix this ASAP!!
@ITinterstate I can confirm this works.
thanks for your help

@dylanlogan 
Just adding my solution here in case anyone comes across this again in the future. 
I had the same issue on Samsung A70. I could log into teams through the PC app and in the browser but would get stuck in a login loop when doing it on my phone. 
My solution was to remove the account from within the android phone itself (settings/accounts & backup/Manage Accounts) and then remove the account from there.
Then, to be safe, I reinstalled teams & outlook. Then it worked! 

Yeah, we currently have a user that keeps running into this problem on a weekly, if not daily basis. Every time I have to clear Teams folders from appdata and reinstall. We've even tried deploying two new computers to this user in our efforts to blow the problem away. Very annoying and problematic, considering we use Teams as our primary means of communication.

The fact that this isn't fixed yet is ridiculous. You'd think a Microsoft program would work great on a Microsoft operating system, but no, that is not the case. In fact, we have the most problems with Microsoft software on our MICROSOFT Windows machines. 3rd party programs have far less issues.

Microsoft's QC and bug fix responsiveness has gone waaaay down over the last few years. I go through thread after thread looking for answers and find none on most issues I face. I guess providing proper support for their buggy software is beyond them. It's a shame they have such a lock on the market, or it wouldn't be hard for a superior quality company to overtake them.
That's their M.O. now days. It's sad, and extremely frustrating. You'd think Microsoft software running on Microsoft Windows would be a butter-smooth experience, but it's quite the opposite. I'd rather use any other software than Microsoft's at this point. Ever since they switched over to click-to-run installers from MSI installers, it's been a nightmare. Everything is incompatible with each other, configuring an installer requires you to now write up an XML config file instead of just making a few clicks within an installer, the bugs are non-stop, the programs run slower, and the layouts are clunkier. Microsoft is moving backwards, if you ask me. I'd really appreciate if they'd shape up, fix their stuff, and provide proper support and and documentation on common problems. Even better, just fix the darn bug that's causing the problem!

Nothing works for me trying to login n my android phone. I have decided to remove my spell at microsoft from my CV and replace it with a spell in jail because frankly it will be less bad! 

@ITinterstate   I had similar issue with 4 screens open to different areas, such as emails, azure etc  and found if I logged in with Teams Admin Centre first, then the others afterwards, no issue.  Was using Firefox as browser..