Teams Desktop App not see org

Copper Contributor

When logging in there is no option to select the org that I am a part of. Says to create a team or join by code. If I use the web application it finds the org and lets me see all users that are in the team. I have tried uninstalling and reinstalling teams. Clearing the teams cache locatio

13 Replies

Hi @bradriedell ,


If your account is associated with multiple Orgs, towards the top righthand corner of the client, do you not see a drop down allowing you to switch between orgs?





@HenryPhillipsNimbitech There is no drop down by the user icon in the upper right corner. 


Is the client definitely logged on with the right account, did it prompt you or just go straight in. Might be worth right clicking the Teams icon in the system tray, choosing sign out and then re enter creds when you launch it for the first time after the sign out.

So just to double check the web version that does work, let's you switch into the relevant Org which houses the Team you seek?

Or is this just one Org and you see the Team in the Web but not client. I believe it is the former but just want to be sure.

So if the former is that this Team, that exists in another Orgs tenant is available in the web. We are more questioning why the desktop version is not allowing you to switch from your home org to the other org?



It is the correct account as she has one. This whole issue started with the desktop app when the account was added to a different org as a guest. The account has since been removed as the guest and the original team no longer works on the the desktop app. The web app when signing in takes the account directly to the correct team. There is only one team that should show just like the web app does. I am not sure if there is some registry entries that need to be deleted after uninstalling or what but I feel like if I could completely clear the desktop app from the computer and then reinstall that this may resolve the issue. Just seems like some settings have gotten messed up in the background and uninstalling does not remove everything. I have attempted to delete everything in appdata local and roaming in an attempt to fully remove the app before reinstalling.

Hi @bradriedell 


Sorry to keep going over this and thank you for your last post as it has made things a lot clearer. However you say the Team does not work in the Desktop app but then mention it shows the one Team in the Web but not the desktop. So is it that it does not shown in the desktop app or that it shows and does not work. If shows and does not work what happens exactly when clicking on it.


The reason this is so odd, is that the Desktop app is essentially a wrapper around the web version and the Teams and what not are interfaced with by way of the client but not stored locally beyond any information caught in the caches as you have tried to clear.


I mean as part of the uninstall did you just gut out the whole of the app data location and then try again?


Could you also confirm what version of the app is being used please? 





I was able to figure out the issue. Thank you for your assistance on this.

@bradriedell hi, how did you resolve this. Having similar issue. 

@jasdeep How did you resolve the issue?  I am having the same problem.

@dcolville3  I found that in windows 10 in settings there is an account option. I removed the MS account from there and it started working.

I too have this problem... able to use teams and set appointment in a separate org... on iPad, but the Mac desktop app does not recognize the org nor let me try to find it... I am lost.


TEAMS is horrible clunky and cumbersome... no live help, constant upselling... what a waste. 



NO on the Mac desktop app and NO ABILITY IN DROP DOWN FOR ORGS


Thanks. I had to delete but recreate my account under setting->account->access work or school and then it loaded my organisation correctly
I found the solution. In the Microsoft Teams Mac desktop app > Preferences > Accounts > Manage > Click on "Sign out everywhere" (which is a link in small letters a bit below your name in the middle of the screen) > Proceed to sign out.
Then go back to Microsoft Teams Mac desktop app > Preferences > Accounts > Sign out.
Then try log in again in the desktop app with your organisation account and you should be able to see the your organisation team.