Teams custom app - PowerApp sign in issue

Occasional Contributor



I followed this tutorial to create an app for Teams from my PowerApp:


It has been configured only as a "personal" tab. After publishing and installing, it works fine from Teams within the browser, but when I try to open the App from Teams client, it prompts to sign in - "Sign in to start using PowerApps". After clicking the sign in button, it opens the following URL in the browser:

But nothing happens and the browser tab closes after a couple of seconds. 


My content URL:

I figured out the suggested content URLs in the article don't work at all.


Has anyone found a way to fix this? Thanks!

16 Replies
Are you using the website tab instead of the built in included PowerApps Tab?

@Chris WebbI am not using any of those - as mentioned it's a custom app created with App Studio and then published to store as a company app according to the article I have linked in the original post.

The purpose is to later push the app to users' left panel menu with app policy.

Below is how it looks in the client (and like I said, in the web app it works fine):



I just noticed that when I create an app in AppStudio and set a SharePoint online site as content, the behavior is similar. Works fine in the web app and shows a blank screen in Teams client. Is there anything that needs to be done authentication wise maybe? I am logged into the same work account in the client and in the browser.

@Chris Webb Hey Chris . Any update on this. I still get the issue. I'm using App Studio to embed PowerApps as a tab but it says "sing in to start using PowerApps"


Why can't it authorize the user from Teams client, instead of signing it again

Na, My tabs are asking for authentication as well, not sure why that is. I'll see If I can ask around if anyone knows what's going on.
Have you tried using the "Add to Teams" button they added to Powerapps? I doubt it will make a difference but it's worth a shot.


For me adding 'source=teamstab' to the Content URL did the job, i.e.}


I can see it is now also corrected in the documentation.

@Michal Sacewicz 

Adding this to my manifest worked like a charm! it loads the app without "Sign in to Powerapps" screen!


Let me know if this works for you



"webApplicationInfo": {
"id": "3e62f81e-590b-425b-9531-cad6683656cf",
"resource": ""

I have the same problem.
It must be Teams software related not app related. My app work on my computer as it should then it did not on my collegue. White background went semi transparent when login in and beeing sent to browser. Going back to teams desktop app it is complaining about ”use previous version of webplayer”. That is just weird. Any ideas?

I reinstalled my computer... now I have the same issue as my collegue..


@skaratela How can you modify the manifest JSON attributes?

@Apol VILLAMOR I think you should be able to do so in App-studio. You find that in Teams -> then the three dots where all apps are. Then search for it and install. once in App Studio go to Manifest Editor, click on your app, then App Manifest (preview) in the left hand menu.


You should now see the XML-schema

@skaratela Hi, it seems that this works for me even when i use your app ID you pasted in there. I tested with anther ID and it still works... just wondering what that ID is and how did you work this out / where did you find out about this being the solution? It seems this is the only post anywhere that solves the problem.

@ryanshane where can i edit the manifest? If i go into App Studio to app manifest i can't edit it, because it says it's read only.

Hi Michael,

my link looks not like yours ( Where do i have to put in the ´source=teamtab`?

@MatthiasRepy from my notes since it's been a while:

- Add power app as a custom tile on the left side

- Teams > App Studio -- used it to create a package with one tab pointing to the power app, then export to file

- The file is a zip containing JSON for the config

i do not understand, why the app runs at Teams Web Client, and on the Desktop Client there is always the Power App Sign In issue.