Teams Custom App Icon Not displaying sometimes

Iron Contributor

Hi everyone, having trouble with a custom teams app not displaying the app icon sometimes. Generally if you quit teams and re-open solves the issue, but this is not a good user experience.  


I have:

  1. Created a custom Teams personal app and set custom icon
  2. Automatically pinned these apps to Microsoft teams for all users


  1. App Icon shows as blank

  2. App Icon shows correctly


As stated restarting Microsoft teams usually fixes the issue. Any help appreciated.





16 Replies
Hi, I'm having this issue as well at several customer tenants. It gets really annoying when a customer has 5 custom apps and they all show the obnoxious blank square icon...

I have the same problem.

We have the same issue. Teams admin center says "you have to add a license for showing icon for this custom app"? I can't find anything about it and it worked earlier. Microsoft?



Same here. A statement from Microsoft would be great...

Same here. Also the app does not start. It works in browser mode. And after re-adding it from the app store. These are workarounds but unluckily not a solution.


Do you experience this problem after updating the app?

@M_Kha We have this same issue.  I've noticed that if I clear my teams cache the icons reappear, but if I switch between different Teams tenants (dev/test/prod) the dotted outline issue reoccurs.


I first noticed this issue after we updated the manifest after our initial release.


Has anyone heard of a resolution for this issue?

@NotAlex @Pernille-Eskebo I am experiencing this issue as well.  Is there no workaround for this?  Please let us know if this is even being worked on.

Same here, the Icon was working fine before and now it suddenly never works. Using Teams "App Studio" to create the zip with the manifest.

I have this exact problem with a client... We added two custom apps last week and the icons were showing. They contacted me today saying that they are those blank boxes. I have seen this problem before as well... They work in the browser version of Teams right now but not in the desktop app.

Can we please get some light on this issue :)



Hi everyone, I'l also facing this issue. Does anyome found a solution?


Thank you!

Hi everyone,
We are also facing this issue.
Any solution or workaround? @NotAlex

I'm also experiencing this issue. Has anyone found a solution?

Same here. Seems to be a tough one.

I have the same issue for all my apps but but the icons don't show any time! I had my own created icons but after changing for the system ones problem doesn't disappear...

we are having this same issue since last week. Any known fix?
Same issue here as well as clients. The icons sometime show in New Teams and sometimes do not. I can't ask clients to clear their cache or quit teams to fix this all of the time.