Teams collaboration bar hangs after some idle time

Copper Contributor

We are using a few Studio X type devices and are having the following issues with all of them.


We use all devices in Microsoft Teams Partner Mode and have the following problems with both firmwares the current one recommended by Microsoft in the Admin Center ( and the latest available one ( identically.


After some time (whether in standby or not) without interaction, a call can no longer be started from the device. If one clicks on "New meeting" and enters a name, it cannot be dialed. As soon as you are in this menu, clicking (via mouse or touchscreen) on "X" is also no longer possible. The device hangs in this state. Further functions can then only be called up again by plugging in a keyboard with "ESC" or by restarting.

In the same state it is also not possible to invite the device via Teams -> Add room. The device rings but the call cannot be accepted (the screen is missing). If you then wait and try again it works.

On a freshly launched device whithout any settings changed from reset (beside connection to O365 room) everything works, both dialing and adding the room via Teams. It only happens after some time in an idle state - 100% if it is idle over night.


All points are reproducible on all devices of type Poly Studio X (30/50) both in the corporate network and in the home office. We do not know if the functions ever worked properly but for sure the device is nearly unusable with this.


Anyone with the same? Any idea's?

10 Replies

@Pavel Yurevich do you maybe have some idea about this? As I saw you have news here:

@JONNYBLUE thanks for mentioning me. I am the right person to take a look at this issue. 


I am sorry that this is happening and I have not encountered this issue so far from customer conversations or from personal use. I have devices running 24 hours a day in my home office and every morning everything works. We also restart Teams app every 8 hours since inactivity to avoid some "stale" effects. Let's see what we can do to reproduce this on my end and get this resolved. 


Can you tell me more about your setup? Here is what I would be interested in:

  1. Just to confirm, this issue happens in this order: (1) Factory reset your Poly Studio device, (2) wait some time, e.g., overnight, and (3) cannot use "Meet now" or add a room through proximity. Correct? 
  2. Are you making any changes to the devices in Poly's WebUI? Have you tried disabling idle/standby settings? 
  3. Are you making any changes to the config profiles in Teams Admin Center? 
  4. Do you have a Teams account that is whitelisted for pre-production rings, like TAP? Reporting an issue from an account like that will give us more logs. 

@Pavel Yurevich 


Thanks for your reply. First of all I am happy that this is not an issue on your side - so it is not a general issue what means there is possibly a solution :)


1. Correct but after reset I change to "Teams mode" and I connect to a Room with Teams Rooms Standard licence. To reproduce I just click on New meeting, enter some letters and double click on a username (mouse or touchscreen attached). After that, system is stuck in that screen. Can still navigate but nothing happens.

2. No, no other changes are made. It does not matter if I change or not

3. Yes, the devices have config but I also removed them without any difference

4. No, unfortunately not.


Could it be that Conditional Access makes trouble here? Especially "Report Only" policies? They are giving a hint on showing certificates on android / iOS - never saw one but might that be an issue? (already testing by myself...)


Sometimes I see a purple line on the top of the device going from left to right (a little like Knight Rider K.I.T.T.), do you know what this means if this comes? It's not always, but often.




I can answer myself - it is not an issue about Conditional Access. Disabled all policies with "Report Only" and which where active before for this user, still same behaviour.

Do you maybe have room I can connect to for testing? So we can find out if it is about our Environment or the devices?

@JONNYBLUE Could you make a video of this experience? It probably would be the best way for us to clearly understand what is happening from your perspective. In the mean time, I'll get you a temporary pre-production account so you can collect some logs. I'll send it to you via IM sometime tomorrow. 

@Pavel Yurevich 


I could get a little further. I now played with "energy saving" options. Disabled the nightly out of office hours and set the sleep mode to 1 minute. After about 90 seconds with the 60 seconds sleep setting the effect happens reproducable 100%. Right after the monitor going to sleep (~5 seconds) it still works well but some seconds later (~25-30) it is broken like described. 


I sent you the video where you can see what is happening and also the "knight rider" thing at the end.

@JONNYBLUE thanks, I will look at it. In the meantime, I sent you some test credentials to collect logs. 


My X30 is currently used by someone else, but I will get it back early next week, so I can validate this issue.

@Pavel Yurevich 


I already sent Pavel some more details via PN.


Error can even more easy reproduced also when just turning off the screen and turn it on. Afterwards also when going to "New meeting" -> entering some letters the screen is stuck and there is now escape than restart or pressic "ESC" on a keyboard.

Full reporoduction:
Reset Poly X30 FULL -> Switch to Teams Mode -> don't change any other settings -> do above.



best response confirmed by ThereseSolimeno (Microsoft)

@JONNYBLUE Quick update, it seems that we have found a tentative root cause for this issue, but we need confirmation from Poly. It seems that the firmware changes DPI dynamically which causes Teams app to not respond correctly. You can see on the video you sent me that the size of the "New meeting" pop-up changes slightly. If we are right, a fix will come in the next update (late March). I'll update this thread as we learn more about this further. 

@Pavel Yurevich 
Hi Pavel,

is there any update? We have almost the same issue with Poly Studio x50, with firmware
At the moment we are running the update to
Kind regards,