Teams client not updating




Microsoft Teams client on Windows 7 endpoints (with ESU) - 32-bit client, and Windows 10 - 64-bit client are not updating via Avatar -> Info -> Check for Updates


Teams is installed on both endpoints in Machine-Wide mode with source=default


Checking storage.json in %AppData%\Microsoft\Teams\  the latest version (.nupkg) that it pulls down is


I can manually download from


Any idea on how to resolve?





20 Replies
Machine wide installs don’t auto update! You need to manually install a newer version every time


@adam deltinger 

Thanks for your reply. It's not the machine-wide installer that I'm worried about updating, it's the per user client that is installed by the machine-wide installer on logon. This is on PCs/laptops, installed as per the instructions with the MSI property  ALLUSERS=1 set. I'm aware that the VDI installation - installed with the MSI properties  ALLUSERS=1 ALLUSER=1 - needs uninstalling and then manually updating, but this is not the case with the regular PC version.


Until recently, checking for updates in the client would force the client to check on the Internet for a newer version (.nupkg) and update and then prompt for restart, but this is no longer happening.

There’s been a number of people saying the manual and auto update function isn’t working properly. It’s also raised with the Teams team! I recommend also giving feedback about this through the client ( Help -> Feedback)


@adam deltinger 

Ah, good to know. I will do. Thanks for your help!

Hi, I posted this yesterday as I’ve heard about issues as well. Perhaps a workaround if you’re only having problems with a few clients?

A lot of machines in our environment are stuck on version which dates back to November. Initiating check for updates in the client does not install a new version. Up until November, updating worked fine.


logs.txt tells me:


Fri Jan 22 2021 10:01:07 GMT+0100 (Central European Standard Time) <14096> -- info -- Checking for update from /package/desktopclient/update/ 
Fri Jan 22 2021 10:01:07 GMT+0100 (Central European Standard Time) <14096> -- info -- Downloading file from - 
Fri Jan 22 2021 10:01:07 GMT+0100 (Central European Standard Time) <14096> -- info -- Browser Window HTTP: Get Data HTTP with url: 
Fri Jan 22 2021 10:01:07 GMT+0100 (Central European Standard Time) <14096> -- info -- Browser Window HTTP: Push url in request queue: 
Fri Jan 22 2021 10:01:07 GMT+0100 (Central European Standard Time) <14096> -- info -- Browser Window HTTP: Download URL: 
Fri Jan 22 2021 10:01:07 GMT+0100 (Central European Standard Time) <14096> -- info -- Downloading Browser Window HTTP:x64.json 
Fri Jan 22 2021 10:01:08 GMT+0100 (Central European Standard Time) <14096> -- info -- Browser Window HTTP: Resolving. Download completed for:x64.json 
Fri Jan 22 2021 10:01:08 GMT+0100 (Central European Standard Time) <14096> -- info -- App up-to-date 



Any specific new setting or feature you’re missing? You don’t necessarily have to use a newer released version as most updates happen backend. In my case though I had to force a version update as I was missing them.

@ChristianBergstromI'm not missing any functionality but I find it strange that it doesn't update a version dating back to November. Even triggering the update process in the client does not update it.


Microsoft states that clients older than three months won't be able to access the service. But if the client which is supposed to update automatically doesn't update and thinks there is no update available, I might have a problem.

I don’t think you’re alone here. The updates are ”put on hold” or something similar. If we’re lucky they’re working on the infrastructure sorting things out. If you are worried though, open up a service request from the portal to get an official answer.

@ChristianBergstrom  Today my client updated to

Yay :)
Now stick on on my domain PC (Windows 7, Teams 32-bit). Again, I can manually download the nupkg for

Some pointers on diagnosing this would be appreciated


@jdseymour1978 Hi, you can read the conversation here to get updated Force Teams desktop client update - Microsoft Tech Community



Thank you for the link, but it is not practical to use this method to update hundreds of clients in an enterprise environment using this method. 

@jdseymour1978 Hello, that was not my point. Read the conversation as you'll see how the update flow works and why some versions differ. It's not necessary to all be on the same version as long as the users have the released features.



It will become necessary as users either receive the message that their version is out of date, or demand to use features in the newer versions. As others have commented in the link you provided, this feels like a 'consumer' product pushed into the corporate/enterprise space, without the deployment and management tools which that space really needs.


As a test, I uninstalled the per-user version of Microsoft Teams ( and cleaned up my %LocalAppData% folder. I then re-installed it, using the command which the Machine-Wide installer uses on logon:


"%ProgramFiles(x86)%\Teams Installer\Teams.exe" --checkInstall --source=default


This installed the same version as that of the Machine-Wide installer - 1.30.28779 - in my profile. I was then able to run a 'Check for Updates' within the Teams client, but this only downloaded & updated to the version I'd previously been running and got 'stuck' on -

@jdseymour1978 Hi, there's nothing wrong with the version you've got, Are you saying you're missing features?


As for the whole update process I'm only referring to what has been announced as how it works in Teams.



I just wanted to pop in here and share my findings, because I've had a lot of troubles updating Teams in our environment. Our users have started to see "Teams needs to be updated" whenever they open Teams and we have tried manual updates but it keeps coming back.

In our case, uninstall/reinstall, clearing cache, adding the user temporary as local admin to install update and a few other attempts didn't solve our issue, so I did some digging and here's what I found:

We opened Task Manager -> Processes tab, right clicked the top bar with all the headings and toggled process name and command line on. After that, expanding the Teams-app in the list revealed that the executable was actually run from the "Default"-user directory.

So I shut down teams, and then uninstalled Teams through control panel add/remove programs, and verified that it was also gone in the new Windows 10 Settings -> Apps window.

Then I changed the name of the following folder:

And finally reran the installation, and that appears to have solved our issue. Hopefully this will help some of you who experience the same.