Teams Card Action issues - action no longer available since this connector was removed

%3CLINGO-SUB%20id%3D%22lingo-sub-217275%22%20slang%3D%22en-US%22%3ETeams%20Card%20Action%20issues%20-%20action%20no%20longer%20available%20since%20this%20connector%20was%20removed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-217275%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20using%20actionable%20cards%20in%20Teams.%20I%20am%20posting%20the%20card%20via%20the%20team%20connector%20and%20have%20actions%20that%20are%20calling%20a%20web%20api%20endpoint%20in%20Azure.%20The%20card%20format%20I%20am%20using%20is%20the%20Message%20Card%20one%20(not%20the%20new%20adaptive%20card%20format).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEverything%20was%20working%20fine%20up%20to%20a%20couple%20of%20days%20ago.%20I%20am%20seeing%20the%20following%20error%20now%20when%20clicking%20on%20the%20actions%3A%3C%2FP%3E%3CDIV%20class%3D%22ts-o365-connector-card%20card-acc-border%22%3E%3CDIV%20class%3D%22card-border%22%3E%3CDIV%20class%3D%22card-see-more%20ts-see-more-disabled%22%3E%3CDIV%20class%3D%22card-see-more-viewport%22%3E%3CDIV%20class%3D%22card-see-more-content%22%3E%3CDIV%20class%3D%22ts-o365-connector-card-section%22%3E%3CDIV%20class%3D%22o365-action-error%20error-style%22%3E%3CDIV%20class%3D%22o365-action-error-top-row%22%3E%3CDIV%20class%3D%22error-indicator%22%3E%3CSTRONG%3E%3CSPAN%20class%3D%22error-text%22%3EFailed%20to%20send%3C%2FSPAN%3E%3C%2FSTRONG%3E%3C%2FDIV%3E%3CDIV%20class%3D%22icon%20icons-close%22%3E%3CSTRONG%3EThis%20action%20is%20no%20longer%20available%20since%20this%20connector%20was%20removed.%3C%2FSTRONG%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F37946i48C7985EC19B7843%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22teams%20action%20error.png%22%20title%3D%22teams%20action%20error.png%22%20%2F%3E%3C%2FSPAN%3ETracing%20the%20issue%20it%20does%20not%20seem%20to%20hit%20my%20web%20api%20endpoint%20(so%20not%20getting%20that%20far).%20Also%20the%20same%20card%20and%20actions%20work%20fine%20in%20Outlook%20if%20I%20send%20the%20card%20there.%20Just%20wondering%20if%20anyone%20has%20seen%20this%20and%20any%20idea's%20how%20to%20troubleshoot%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-217275%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-313902%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Card%20Action%20issues%20-%20action%20no%20longer%20available%20since%20this%20connector%20was%20removed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-313902%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20getting%20the%20error%20as%20above%20when%20attempting%20to%20make%20a%20HttpPOST%20Action%20from%20a%20MessageCard%20created%20using%20the%20Teams%20incoming%20Webhook%20connector.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnybody%20able%20to%20share%20any%20light%20on%26nbsp%3Bthis%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-224731%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Card%20Action%20issues%20-%20action%20no%20longer%20available%20since%20this%20connector%20was%20removed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-224731%22%20slang%3D%22en-US%22%3E%3CP%3Eit's%20working%20for%20us%20now%20too%20on%20any%20newly%20created%20actionable%20cards%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-224547%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Card%20Action%20issues%20-%20action%20no%20longer%20available%20since%20this%20connector%20was%20removed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-224547%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20has%20started%20working%20again.%20There%20are%20cards%20in%20the%20past%20with%20actions%20that%20still%20do%20not%20work%20and%20show%20the%20same%20error.%20But%20new%20cards%20created%20within%20the%20last%20couple%20of%20days%20are%20working%20again%2C%20that%20is%20the%20card%20actions%20work%20and%20do%20not%20get%20the%20error.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-220044%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Card%20Action%20issues%20-%20action%20no%20longer%20available%20since%20this%20connector%20was%20removed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-220044%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20exact%20issue%20with%20no%20workround%20found%20yet%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-218172%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Card%20Action%20issues%20-%20action%20no%20longer%20available%20since%20this%20connector%20was%20removed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-218172%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20has%20also%20happened%20to%20me.%20An%26nbsp%3B%3CSPAN%3Eactionable%20card%20that%20has%20been%20working%20fine%20for%20months%20is%20now%20getting%20this%20error%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%20class%3D%22error-indicator%22%3E%3CSTRONG%3E%3CSPAN%20class%3D%22error-text%22%3EFailed%20to%20send%3C%2FSPAN%3E%3C%2FSTRONG%3E%3C%2FDIV%3E%3CDIV%20class%3D%22icon%20icons-close%22%3E%3CSTRONG%3EThis%20action%20is%20no%20longer%20available%20since%20this%20connector%20was%20removed.%3C%2FSTRONG%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-217650%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Card%20Action%20issues%20-%20action%20no%20longer%20available%20since%20this%20connector%20was%20removed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-217650%22%20slang%3D%22en-US%22%3E%3CP%3ESee%20also%20%3CA%20href%3D%22https%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F555103-public%2Fsuggestions%2F34859035-this-action-is-no-longer-available-since-this-conn%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3EThis%20action%20is%20no%20longer%20available%20since%20this%20connector%20was%20removed%3C%2FA%3E%26nbsp%3Bin%20the%20Microsoft%20Teams%20%3CA%20href%3D%22https%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F555103-public%2Fsuggestions%2F18704830-windows-insider-like-teams-bug-reporting%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Efeedback%20category%20for%20bugs%3C%2FA%3E.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-217316%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20Card%20Action%20issues%20-%20action%20no%20longer%20available%20since%20this%20connector%20was%20removed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-217316%22%20slang%3D%22en-US%22%3E%3CP%3ELooking%20at%20developer%20tools%20I%20can%20see%20there%20is%20a%20javascript%20error%20for%20the%20makeHttpPOSTRequestForConnector%20method.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F37960i9FAA9966059CFBC2%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22javascript%20error.png%22%20title%3D%22javascript%20error.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%3EAnd%20looking%20at%20the%20script%20where%20this%20method%20is%20it%20looks%20like%20probably%20this%20condition%20where%20it%20fails%3A%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3Eif%20(!this.card.connectorSender.integrationId)%20%7B%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3Evar%20o%20%3D%20%22%5BO365ActionPaneController.makeHttpPOSTRequestForConnector()%5D%20perform%20actions%20on%20removed%20connectors%22%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I am using actionable cards in Teams. I am posting the card via the team connector and have actions that are calling a web api endpoint in Azure. The card format I am using is the Message Card one (not the new adaptive card format).

 

Everything was working fine up to a couple of days ago. I am seeing the following error now when clicking on the actions:

Failed to send
This action is no longer available since this connector was removed.

 

teams action error.pngTracing the issue it does not seem to hit my web api endpoint (so not getting that far). Also the same card and actions work fine in Outlook if I send the card there. Just wondering if anyone has seen this and any idea's how to troubleshoot?

7 Replies
Highlighted

Looking at developer tools I can see there is a javascript error for the makeHttpPOSTRequestForConnector method. 

javascript error.pngAnd looking at the script where this method is it looks like probably this condition where it fails:
if (!this.card.connectorSender.integrationId) {
var o = "[O365ActionPaneController.makeHttpPOSTRequestForConnector()] perform actions on removed connectors";

Highlighted
Highlighted

This has also happened to me. An actionable card that has been working fine for months is now getting this error

 

Failed to send
This action is no longer available since this connector was removed.
Highlighted

Same exact issue with no workround found yet

Highlighted

It has started working again. There are cards in the past with actions that still do not work and show the same error. But new cards created within the last couple of days are working again, that is the card actions work and do not get the error.

Highlighted

it's working for us now too on any newly created actionable cards

Highlighted

Hi 

 

I'm getting the error as above when attempting to make a HttpPOST Action from a MessageCard created using the Teams incoming Webhook connector.

 

Anybody able to share any light on this?