SOLVED

Teams Calling - Dial pad missing

Occasional Contributor

We have recently migrated all our users from SfB to Teams , and one of my users now is unable to dial out to external phone numbers?

He has a E3 licence, Phone system, Domestic calling plan, Communication credits licences applied, and had his phone number assigned, but he has no dial pad in Teams.

He is able to receive external calls to his Teams phone number? 

I have logged him onto another PC and signed into Teams but the same happens there is no dial pad.

The teams desktop app settings >Calls > has no call answering rules available as if there is no licence assigned.

Has anyone seen this before?

 

rayb no dial pad.png

91 Replies

@OmarVegaI wonder if setting EV to false then back to true again gives any difference in behaviour ?
Please bear in mind backend replication can take anywhere from a few mins to 24 hours to apply settings in Azure/O365
(i.e. submit/commit a setting change in Teams at the right time may show up in a teams client a few mins later....not sure what that "right time" is however! - I take a guess that MSFT queues its tenant changes at set intervals into different classes so another our setting change falls in to the higher class for replication or lower class for replication  - This is a total (attempted educated) guess however and could be totally wrong

@Mehmet_Kocak - Good idea; will try that now.   Yeah, I've noticed the same on changes...some take place very quickly and others overnight.   Not always convenient for users waiting on changes.  Hopefully MS will get better with replicating changes.

@OmarVega I have the same issue since two days in a direct routing scenario and nothing seems to get it fixed. User has no dial pad but can receive inbound PSTN calls! I guess it's time for a ticket to MS. Fortunately, we are not production with this system. It's so immature.

@Adrian Gularek I ended up opening a ticket with O365 support yesterday.  Of course, they wanted to do level-1 troubleshooting, which I've already done.  After they saw everything I did, they have escalated the ticket; I'm still waiting to hear from whomever on it.

 

It's definitely something with my account - what?  I don't know...    Looking at the Teams debug logs (CTRL-ALT-SHIFT-1), I see this very early on in the log (and repeated later):

 

call-contact-card: [updateAudioCallBtn] mri: "8:orgid:xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx", isPstnCallingAllowed: false, isAudioCallBtnVisible: true, isToggleOBOMenuBtnVisible: false

 

I don't know why all of a sudden Teams thinks that PSTN calling is not allowed for my account.  I have two test accounts...that are setup the same way as mine and PSTN calling is true.  Not sure what would have changed over last weekend...everything was working fine until I logged in Monday morning.

 

 

@OmarVega I would really appreciate it if you could share the update from Microsoft? Ive been researching for this fix as the recommended steps from microsoft is not working.

@OmarVegaI have also opened a ticket with MS and I can also see I have isPSTNCallingAllowed:false in the log.

@WilliamTan30  I'll definitely post up whatever is found.  Right now, they've been having me collect & send them logs, still no resolution from them.

@Adrian Gularek  They sent me a tool to collect a Fiddler trace...just sent them back the results; hopefully that will offer some insight for them.  Curious if the resolution is the same for all of us...

Have exactly the same issue on my testbed. I was testing with the Voice routing Policy, I removed the existing voice routing policy and assigned a new voice routing policy and then the Dialpad vanished.

 

Couldn't get the dialpad back since last 18 hours.

 

This is really not stable and reliable.

@Thangavel MudaliarToday around 12:00 CET my dialpad magically re-appeared (no configuration changes since Wednesday). If we had EV fully on Teams, would users be unable to call for 3 days ? That's scary.

@Adrian Gularek 

Hello Adrian,

 

I was able to resolve the issue over the weekend by disabling the EV and re-enabling for my test accounts.

Hi@Thangavel Mudaliar Thank you I suspected this may work as mentioned above, hopefully its the same case all others experiencing  this issue!

Interesting...

 

My Teams dialpad is back.  The only thing I did on Friday before leaving for the day was to change my TeamsUpdatePolicy from 'TeamsOnly' back to 'Islands' - as I was unable to make phone calls all week due to lack of dialpad.   When I logged in this morning, the dialpad is back in Teams.

 

Sometime last week, I tried disabling EV and re-enabling and that didn't work for me.

 

I'm going to report my findings to Microsoft, see if they have anything to say about it.

best response confirmed by Chris Cooper (Occasional Contributor)
Solution

I forwarded my findings to the MS case and the 'Case Ambassador' called me and said that he was told that the backend team did identify an issue and applied a 'Global fix'.  When I asked him to explain further, he could not, stating that he doesn't have access to what exactly was done other than something was done.   Seems fishy to me, but a 'global fix' being applied does seem to support what we've seen on this thread - several users having issues are now working again.

@OmarVega  Yes very fishy, all working again for my user too, so looks to be resolved, thanks to everyone's contributions to this issue.

Great result!!  Thanks.

Same issue here, checked all of the points raised above. The issue has been intermittent for me, mainly not working though. Team client on desktop the same error as you. Able to phone out on the Teams iPhone app OK.
I'm going to raise this with Microsoft.
>some take place very quickly and others overnight

Ahh sort of glad to read that. I've switched a subset of our users at one site (inc. my account) across this evening to Teams only after changing org-wide to SfB only (from Island) so that remaining SfB users can communicate with the Teams users. I've rebooted and currently both the ability to make calls or send IM is not visible in the teams client - either on my PC or phone. However, calls are coming into Teams on my PC.

Here is the current view of Teams: https://i.imgur.com/Ea4vFUS.png

I'm hoping, no praying, that it'll have sorted itself out by morning... I know that provisioning a Skype voice number can sometimes take several hours. I switched to Teams several hours ago. Didn't expect such a delay but I guess that's why I've tried with a handful of voice users first.

@Chris Cooper 

 

If you do not have dialer (or adjust anything in the Teams telephony) you need to check (adjust) the settings simply (if they are up to the ones MS recommends):
* Direct Route trunk

* User enable + DiD assigned

* Some sort of call routing is there (ONLINE Dial plan, Online Voice Pol, Online Usage, etc is there)

* Online Voice policy is granted 

THEN you need to wait.  Even though the power shell seems to be instant however, it can take anywhere between 5 minutes to 40 (80?) hours the settings to take into effect. (Eg. you can create and start the Online PSTN gateway in 2 minutes, but 30 minutes was not enough to pick up any modification such as port, options on off etc. )

What you need is confidence and a massive amount of patience with this MS service.

 

Was this issue resolved, for anyone in this thread.  I opened a ticket with Microsoft, Ticket # ‎14779431, on the 10th.  MS support has not made headway with this yet.  We are in the cloud, no on-premises servers.

 

I cycled the EV settings (True, False, True). I cycled the licenses (calling plan & Phone system, on/off/on).  I cycled the TEAMS UPDATE (Teams only, Islands, Teams only).  I gave the system time to ripple through when making these changes (2:45 hours on the licenses, 36 hours on the Teams Update, ok, only 10 minutes on the EV).  

I removed the licences, waited 24 hours, re added licences and waited a further 24 hours. It finally appeared!
I think it’s a provisioning bug that MS are not really bothered about fixing