Teams calendar not syncing with exchange on-prem calendar



I have a problem with the calendar sync between exchange online/Teams for a customer.

I configured Azure AD Connect with the hybrid option and users are synced to the cloud and licensed with O365 E3.

I setup exchange hybrid on an exchange server 2016 CU11 with the new version of the Hybrid Wizard, ending with the OAuth error after the first run. So I configured OAuth manually with the manual and calendar sync was working, for 1 day. At the next day it wasn't working and I couldn't get it running again since then, 3 weeks ago.


I checked all OAuth config elements, reastablished them individually, startet the Hybrid Wizrad several times, always ending with the OAuth error. I tested with teh test-oauthconnectivity cmdlet in both directions which ends always successfull, restarted the server and services several times, checked the availability service and with the remote connectivity analyzer for free/busy and everything was successful but sync is still not working again.


Can someone help me with this issue or has tipps to chekc further?


Kind Regards


13 Replies

@ChristianBergstromThx for the Link, I went through it an 2 things occured:

THe Inbound SMTP Mail test failed with error: 550 - Mailbox unavailable. The server response was: No RDNS entry for IP_ADDRESS

I think this is not problematic as this test fails too for a customer where sync is working.

Another issue is the used certificate which is configured only for the IIS service and not for SMTP. I tried to add SMTP via GUI and with exchange commandline but smtp service isn't added. I don't know this happens now as I'm logged in with the Administrator account and no error messages are displayed.


Besides these 2 isssues everything went fine.

Do you have an idea why adding the cert to the SMTP service is failing?

@Julian12 Hello Julian, you mean nothing happens when you run this 'Enable-ExchangeCertificate <thumbprint> -services SMTP'?


I was going to suggest the solution described here but as you cant add smtp it's a problem.


Have you had a look at this as well?

@ChristianBergstromyes, nothing happens when I safe the menu in the gui or send the command in the shell.


Yes, I used the site you mentioned at the end.

@Julian12 Can you use the Get-ExchangeCertificate cmdlet? How does it look? Did you check all prerequisites and proper permission?


As nothing happens when you're trying to Enable-ExchangeCertificate <Thumbprint> -Services SMTP it's quite difficult to figure out, but I believe this is as close as it gets from what you been experiencing.


If that doesn't help you either, I have to ask you to reach out to the Exchange experts.


Good luck!

@ChristianBergstromYes, I can use the get-exchangecertificate cmdlet, output should be fine besides the missing SMTP entry in the services field.


Permissions should also be fine, I can do everything else with my admin account.


The problem mentioned in your link is similar but they won't show any resolution to it, so in the end not helpful unfortunately.


Maybe I need to open or move this topic to the exchange community thread to get the attention of exchange experts.


Thanks and Regards


I would appreciate if letting me know when you find out! Cheers

@ChristianBergstromI will ;)


Anyone further suggestions?


@Julian12 Thanks for that! I actually reached out to another member and he suggested that you should raise a ticket with Microsoft support. I was about to send you a message regarding that.

@ChristianBergstromI already did that but they are sending only links to articles (Oauth, configure modern auth) which didn't help until now.

@ChristianBergstromPer chance do ou know how I can move this thread to the exchange community?
I figured out that the exchagne server is simply not syncing the calender objects to office 365, exchange activesync service should do this instantly but nothing happens.

Hello again, EAS? Now you’re making me even more confused. As the cert service failed and you’re experiencing several issues I highly recommend support from Microsoft senior engineers. Ask the support agent to escalate your ticket for proper assistance. Hope it gets sorted!


I finally solved the main problem, the issue was caused by O365 E3 Test licenses which setup a korrupt mailbox it seems. After desyncing and deleting the affected user accounts, sync was working normally.

Unfortunately all private chat is gone too with the user deletion and so I'm currently searching for a Teams chat history restore but will open a new thread for this issue.


Kind Regards