Teams Button on new Microsoft Modern Speaker and Modern Bluetooth Headset Stopped Working

Brass Contributor

I have the new Microsoft Modern Speaker and Modern Bluetooth headset for Teams. Recently the "Teams" button stopped working on both. If I understand how it's supposed to work when I press it while Teams isn't running it should start Teams, if Teams is running it should bring the application into focus (bring it into the foreground) and if it's running and a meeting starts it should flash and when pressed should join the meeting.


Pressing it now just causes it to blink and do nothing. Is anyone else having this issue? I am running Windows 10 and 11 (has the same issue whether it is on either OS version).

67 Replies
could you please provide more info regarding this? is there an ETA, could you provide the ticket number?
@charlie2323 I don't have any news unfortunately. Maybe @oll_ster has something to share.

PS: I just opened a ticket with Poly to ask them about it. They might have some updates. Happy new year!
Having the same issue with the Modern USB-C Speaker from Microsoft. Teams button does nothing. Just flashes and then goes dark. Same on Windows 10 and 11.

I just got a reply from Poly:


"We have checked internally Teams button will not work. Because the authentication part initiated by the Teams on physical connection is not happening as it was disabled by Microsoft recently. Microsoft will bring a team’s update which is supposed to be coming by the last week of January. And after that they will fix this behavior. We also have a ticket logged with Microsoft to check the progress of this issue. For time being use the screen icons to manage calls."


So we just need to wait for the end of this month to have it fixed (hopefully).

Hi guys,

the ASP service which is what it is used for the Teams button functionality, was disabled, it should be working by Monday, Friday at the latest I believe. Please update Teams client next week and give it a try.
It works again, finally! I actually didn't have to update anything. Suddently it works again.



Same! I just had to quit and start Teams and the light came on.


Its been bugging me for too long, glad its back! :)

For those that it's working again:

What device are you using?
What version of Teams are you on?

I am using a Microsoft Modern USB-C Speaker with Teams version and it is NOT working.
I'm using a Poly Sync 20, and Teams version (64-bit), and it's working fine.

Maybe it's a gradual release?
I have and it's still not working.
I am using exact the same as you and this morning the teams-button is working on the speaker. I did nothing like update or so, just wait :)
The button now always lights up.
Just wanted to report mine is now working this morning! Same version so this must be something gradually released server side.
Mine is working as of this morning (just had to restart Teams). Version is the same, so it definitely appears to be a server side update by Microsoft. Thanks to all who helped troubleshoot the problem. Any people still having the issue should restart Teams once or twice as day until it works as it seems to also be rolling out gradually.
Mine is still working so I guess this issue is resolved with the Commercial version of Teams. It does not however work with the Teams Personal / Home version, and quite frankly I don't know if it ever did. Just happened to try it on my personal Surface Laptop 3 and same behavior as the Commercial version was demonstrating until this week. Does anyone know if the Teams button functionality ever worked on Personal / Home Teams (and maybe we're just waiting on a backend fix) or whether it was designed just for business?

@Icebugz it was working on my home computer with Teams personal using the Microsoft Modern USB-C Speaker.

Hey thanks for the quick reply. That's good to know. Since the behavior I am seeing on Teams Home is consistent with what we were experiencing on Teams Commercial (Button doesn't light up and pressing it just causes the light to blink a couple times and does nothing) I'm guessing they just haven't restored the functionality to the Home version yet. I'll try it once or twice a day and report back if mine starts working.
Still not working for the Teams Home version (the version for commercial works though) . Anyone else having better luck?