Teams are not loading

New Contributor



I downloaded Teams desktop app from ( and install it on my MAC system, But its continue showing "Loading Microsoft Teams...".
Access via browser works fine, but the app will not load.

I tried many option 


- Remove from application folder and re-install

- Upgrade my MAC 10.15.3 to 11.1and tried.

- Force Quit App and remove it and re-install again but not worked 

- Reboot system after install app but still it was not worked

My MAC details are 
Model Name: MacBook Pro


  Model Identifier: MacBookPro11,4

  Processor Name: Quad-Core Intel Core i7

  Processor Speed: 2.2 GHz

  Number of Processors: 1

  Total Number of Cores: 4

  L2 Cache (per Core): 256 KB

  L3 Cache: 6 MB

  Hyper-Threading Technology: Enabled

  Memory: 16 GB

  System Firmware Version: 425.

  SMC Version (system): 2.29f24

Firewall Settings:


  Mode: Allow all incoming connections

  Firewall Logging: Yes

  Stealth Mode: No


Screenshot 2021-01-18 at 3.04.51 PM.pngScreenshot 2021-01-18 at 3.11.09 PM.pngScreenshot 2021-01-18 at 3.11.24 PM.pngScreenshot 2021-01-18 at 3.11.30 PM.png

1 Reply

 It is resolve by join external link, When click on to join team link its loaded, but when I tried to open direct its not load.