Teams appends garbage to downloaded file names

%3CLINGO-SUB%20id%3D%22lingo-sub-202382%22%20slang%3D%22en-US%22%3ETeams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-202382%22%20slang%3D%22en-US%22%3E%3CP%3EIs%20anyone%20else%20seeing%20this%3F%20If%20I%20click%20on%20the%20ellipses%20menu%20for%20a%20file%20and%20select%20Download%2C%20Teams%20appends%20a%20bunch%20of%20garbage%20to%20the%20file%20name.%20So%3A%3C%2FP%3E%3CUL%3E%3CLI%3EForecast.xlsx%26nbsp%3B%3CUL%3E%3CLI%3Ebecomes%3C%2FLI%3E%3C%2FUL%3E%3C%2FLI%3E%3CLI%3EForecast034806db10df5f5f77f925d8e28493110810755ddd7ddaf8c1a79146b3fb387e.xlsx%3C%2FLI%3E%3C%2FUL%3E%3CP%3EIs%20anyone%20else%20seeing%20this%3F%20Is%20this%20by%20design%20for%20some%20reason%2C%20or%20a%20bug%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-202382%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFiles%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-203412%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-203412%22%20slang%3D%22en-US%22%3EDone.%20Ticket%20%2310492474%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-202538%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-202538%22%20slang%3D%22en-US%22%3EYour%20tenant%20being%20provided%20by%20a%20MS%20Reseller%20should%20not%20be%20the%20problem.%20Please%20report%20this%20problem%20to%20Microsoft%20support%20and%20I%20will%20also%20try%20to%20help%20you%20here%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-202393%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-202393%22%20slang%3D%22en-US%22%3E%3CP%3EThanks.%20It%20isn't%20that%20though.%20This%20has%20been%20happening%20for%20at%20least%20a%20month%20or%20so%2C%20and%20I%20got%20a%20brand%20new%20PC%202%20weeks%20ago%20freshly%20formatted%2C%20and%20it%20happens%20on%20this%20one%20too%2C%20so%20I%20know%20it%20isn't%20a%20temp%20sign%20in%20issue%2C%20or%20a%20cache%20issue.%3CBR%20%2F%3E%3CBR%20%2F%3EMy%20tenant%20is%20through%20a%20MS%20reseller%20though%2C%20not%20directly%20with%20MS%2C%20so%20that%20might%20be%20a%20diff%20between%20what%20I%20have%20and%20what%20you%20have.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-202391%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-202391%22%20slang%3D%22en-US%22%3EOdd%2C%20not%20getting%20same%20issue.%20Sign%20out%20%2F%20out%20the%20client%20and%20try%20again%20only%20thing%20I%20can%20think%20of.%20I'm%20running%201.1.00.13555%20of%20Teams%20client.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-202389%22%20slang%3D%22en-US%22%3ERE%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-202389%22%20slang%3D%22en-US%22%3EThe%20Windows%2010%2064%20bit%20client.%20This%20was%20from%20the%20Files%20tab%20in%20a%20channel.%20It%20works%20fine%20in%20the%20browser.%20The%20browser%20asks%20where%20to%20put%20it%20first%20and%20it%20has%20the%20right%20file%20name%20in%20the%20Save%20As%20dialog%20box.%20The%20PC%20client%20though%20just%20downloads%20straight%20to%20my%20ODfB%20location%2C%20but%20every%20time%20adds%20that%20garbage%20text%20to%20it.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-202385%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-202385%22%20slang%3D%22en-US%22%3Eworking%20normal%20for%20me.%20Are%20you%20using%20client%2F%20web%3F%20Mac%2FPC%3F%20Which%20exact%20drop%20down%20are%20you%20using.%20Doing%20it%20via%20channel%20post%2C%20and%20files%20tab%20work%20fine%20on%20PC%20client.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-818342%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-818342%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F527%22%20target%3D%22_blank%22%3E%40Ed%20Hansberry%3C%2FA%3E%26nbsp%3B%20Would%20you%20please%20update%20me%20about%20your%20issue%3F%20I%20have%20the%20exact%20same%20problem%20with%20a%20User%20on%20mac.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-820880%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-820880%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F396956%22%20target%3D%22_blank%22%3E%40Reza_Radman%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20me%20it%20never%20got%20fixed%20until%20I%20got%20a%20new%20computer%20about%206%20months%20ago.%20Even%20though%20we%20replicated%20it%20on%20two%20different%20PCs%20(most%20did%20NOT%20have%20the%20issue)%20MS%20never%20really%20went%20anywhere%20with%20our%20ticket%20other%20than%20to%20say%20%22they%20couldn't%20replicate%20to%20on%20their%20side%22%20so%20the%20ticket%20kinda%20died.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20don't%20recall%20where%20one%20of%20those%20PCs%20is%2C%20but%20other%20one%20that%20was%20having%20it%20was%20reformatted%20and%20put%20on%20Windows%2010.%20But%20we%20replicated%20the%20issue%20on%20both%20Windows%207%20and%2010%20at%20the%20time.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1136410%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1136410%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20team%20member%20who%20experiences%20this%20also.%20Only%20one%20of%20about%2030%20odd%20that%20I%20know%20of.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWould%20be%20great%20is%20Microsoft%20could%20offer%20any%20solution!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1444057%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20appends%20garbage%20to%20downloaded%20file%20names%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1444057%22%20slang%3D%22en-US%22%3E%3CP%3EHas%20been%20happening%20to%20me%20for%20a%20long%20time%20now%20at%20two%20different%20organizations%20so%20either%20I'm%20really%20lucky%20or%20this%20is%20fairly%20common.%20I%20could%20easily%20mistake%20it%20for%20intended%20behavior%20so%20it%20is%20likely%20under-reported%2C%20I%20just%20happen%20to%20find%20it%20annoying%20enough%20to%20go%20looking%20for%20a%20solution%20and%20ended%20up%20here.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Regular Contributor

Is anyone else seeing this? If I click on the ellipses menu for a file and select Download, Teams appends a bunch of garbage to the file name. So:

  • Forecast.xlsx 
    • becomes
  • Forecast034806db10df5f5f77f925d8e28493110810755ddd7ddaf8c1a79146b3fb387e.xlsx

Is anyone else seeing this? Is this by design for some reason, or a bug?

12 Replies
working normal for me. Are you using client/ web? Mac/PC? Which exact drop down are you using. Doing it via channel post, and files tab work fine on PC client.
The Windows 10 64 bit client. This was from the Files tab in a channel. It works fine in the browser. The browser asks where to put it first and it has the right file name in the Save As dialog box. The PC client though just downloads straight to my ODfB location, but every time adds that garbage text to it.
Odd, not getting same issue. Sign out / out the client and try again only thing I can think of. I'm running 1.1.00.13555 of Teams client.

Thanks. It isn't that though. This has been happening for at least a month or so, and I got a brand new PC 2 weeks ago freshly formatted, and it happens on this one too, so I know it isn't a temp sign in issue, or a cache issue.

My tenant is through a MS reseller though, not directly with MS, so that might be a diff between what I have and what you have.

Your tenant being provided by a MS Reseller should not be the problem. Please report this problem to Microsoft support and I will also try to help you here
Done. Ticket #10492474

@Ed Hansberry  Would you please update me about your issue? I have the exact same problem with a User on mac. 

 

Thanks

@Reza_Radman 

For me it never got fixed until I got a new computer about 6 months ago. Even though we replicated it on two different PCs (most did NOT have the issue) MS never really went anywhere with our ticket other than to say "they couldn't replicate to on their side" so the ticket kinda died.

 

I don't recall where one of those PCs is, but other one that was having it was reformatted and put on Windows 10. But we replicated the issue on both Windows 7 and 10 at the time.

I have a team member who experiences this also. Only one of about 30 odd that I know of.

 

Would be great is Microsoft could offer any solution!

Has been happening to me for a long time now at two different organizations so either I'm really lucky or this is fairly common. I could easily mistake it for intended behavior so it is likely under-reported, I just happen to find it annoying enough to go looking for a solution and ended up here.

@Ed Hansberry : I do have the same problem. Is there any fix for this?

@Ed Hansberry 

 

I've been troubleshooting this issue for one of my Mac users the last couple days. From what I've found elsewhere online it seems to be a profile specific issue. At least the issue won't occur for someone else logged on to the same machine. I tried deleting Teams' local files in the user's Library:

 

  • ~/Library/Application Support/Microsoft/Teams
  • ~/Library/Caches/com.microsoft.teams

They were prompted to log in afterward but it did not resolve the issue. The issue started on the user's previous computer so I'm assuming the issue got transferred to their new computer via the Migration Assistant. I'm still looking for the problem settings though. Just FYI.