Teams app on android won't login

Occasional Contributor

I just setup Office 365 for my managing account and other users. Now I installed the teams app on my Android phone (Huawei P10), but I can't login through the app. I get the error: Sorry, but we having trouble signing you in. Please try again.


Now I already search for it, and I saw topics with the same problem. I tried some of the solutions, but that didn't work.

I tried:

- Uninstalling and installing teams app

- Uninstalled outlook app

- Tried on both WiFi as 4G networks

- Uninstalled Office Mobile app

- Tried multiple Office 365 accounts

- Tried to enable 'Android System WebView' in the Android Play Store, but it doesn't do anything I choose for 'Enable'


I like to know how I can solve this problem, so I can use the Teams app on my phone.

40 Replies

Anyone been able to find a solution for phones using older Androids?




It's 2020, June, and this issue still brand new Android 10 Samsung S20 ULTRA stopped working over the weekend. Nothing worked, install, uninstall of Teams...could sign in into another (personal) account, but not in my AD protected work Teams account.

In the end, I found this thread...uninstalled Authenticator app and then Teams prompted me again with all the right prompts...everything worked after that.

Thank you again to whom found the fix. We all OWE you.

Microsoft, fix the bloody's been too long....


I'm having the same issue on my Huawei P10+ phone. I uninstalled Authenticator app and all other MS apps (teams\skype\excel) on my phone were able to login with rederiction to our corporate ADFS. If I reinstall the Authenticator app, it stops working again. 

@neneaaglaia Thank you, uninstalling Authenticator app worked.

@Alexander Bontenbal 

I had the same problem for my Samsung A51. 


The solution that worked for me:

- Clearing Cache & Data of "MS authenticator app" and Teams.
- Uninstall both apps.
- Reinstall teams and VPN to my company.  
- Then I was able to successfully logged in to corporate Teams.


Just to note that in the authenticator their was my corporate email grey out, and I wasn't able to remove it from the app. I haven't enabled MFA for this account.


After that I reinstalled the MS authenticator and everything works fine. 



Thanks Alberto authenticator was the issue!! You rock I been struggling with this for almost 2 months


Our company has had several Android mobile devices that as of yesterday July 16th 2020 have been having trouble even opening the app. The cellular phones are Samsung A10e and the Note 8. We've gone through this as recommended on previous threads:  


- Clearing Cache & Data of "MS authenticator app" and Teams.
- Uninstall both apps.
- Reinstall teams and VPN to my company.  
- Then I was able to successfully logged in to corporate Teams.


NO SUCCESS. We are currently able to access Microsoft Outlook, yet the Teams app won't open and if it does it only opens once. The app needs to stay open and the second you close it or restart your phone you have to do the exact same process as listed in the thread above^^.  Please any advice would be crucial.

I was able to fix this issue by installing Microsoft authenticator app then go settings and click register device then open Microsoft Microsoft teams and logon
Actually, I don't know what is the relation between them I am still trying to understand

To better know about your situation, you may try the following steps for troubleshooting:


1. Try to use a different network connection to check if issue exists.


2. Try to clear device default browser caches (please be kindly noted that this method will removed all related history records and caches).


3. Completely exit all Office 365 related applications on device and only start Teams app to test this issue. Temporarily exit any mobile device manager or antivirus.


Meanwhile, if you’ve tried above methods and issue still exists, may I confirm the following information from you?


1. Whether your account is pure Office 365 online? If so, you may try to use the default domain ( to see if you can login in Teams.


2. Please confirm whether other user in same organization have the same issue.


3. Issue happened after you entered username and password? When error message prompts, is there any error code next to it?


4. Try to check updates for Teams, if there are no available updates, could you please share the current full version number of it with us?

@Alexander BontenbalI had the same issue, then I downloaded the Intune Company portal App and then was able to sign into Teams 

@David Snodgrass Thank you so much for the solution for installing the Intune Company Portal App, it works!


I have had this problem ever since I replaced my Android phone with a new one. Work-around of removing the Microsoft Authenticator works, but is not desired as I do need some 2FA tool (preferably Microsoft's). Work-around only works for a couple of days until some kind of certificate expires.


This makes the following Android apps not working once setup:

  • Excel / Word: I can browse and open files on OneDrive or OneDrive for Business, however, I cannot edit them. Its in a read-only state.
  • OneNote: it can't seem to sync any notes. I get a yellow banner on top that I need to sign-in again. This obviously fails. Without any details on the error.
  • Teams: I can't see any latest updates or receive requests or calls.

I installed the Intune Company Portal App but did not configure it. Went back to any Microsoft App where the sign-in didn't work, and no issues at all. All apps were working immediately. Hope it stays that way.

I had the same problem and i resolved it using the following workaround.


  1. Installed word
  2. Added my account
  3. ADFS form based authentication and otp provided
  4. Open the teams
  5. Added my email
  6. Teams opens without showing any authentication.

it seem that Teams authentication is buggy and needs to be handled.

word authentication went through and while the authentication token is cached in the android webview (built in), every other application will work using the cached token from word.

some people argue that there can be a conflict between android webview and chrome as it has it's own webview so if the above doesn't work remove or disable chrome app.

additionally if the above doesn't work remove any other Microsoft apps and start fresh. The known apps with this issue are all office apps like word, Excel,.... , One drive, Teams and Microsoft Authenticator .

This issue is mainly happen when you have ADFS as authentication provider not azure AD that's why Microsoft is not investing more effort on it because they are willing to depreciate ADFS.

i have an open case with Microsoft and i'll not close it until i get this fixed without workarounds.




Hello Guys,


I found the solution, please follow the following steps:

1. Open your Microsoft Authenticator App

2. Click on the 3 vertical dots on the top right corner, then click on Settings

3. Scroll down to "Work or school accounts" section and click on Device registration

4. if you already registered your devices then skip to step 6

5. start registering your device and follow the instructions using your login information

6. -- The MOST IMPORTANT step -- Click "Enable browser access", this will install the required certificate on your device.

7. open you MS Teams app and E N J O Y !


I hope it will work with you :)


BR, Alaa

@Alexander Bontenbal 

Been there, and it's already solved on my end.
What I did, I install the "Outlook" app first and set-up my emails once the emails successfully set-up you can proceed the "Teams" app. The emails will appear and you don't need to sign-in it again.

Hope it works! Keep safe everyone.

@Alexander Bontenbal 


Goto Mobile Settings -> Click on Accounts -> remove Work Account -> Close Setting and open MS Teams App -> Enter Credentials -> Done.

@Alaa_Elmahdy This was exactly our situation, thank you!  ADFS + Duo, Pixel 3 with latest security updates.  Teams did not let me login.  I installed Word and logged in over ADFS.  The Word app squawked at me about InTune but I did -not- install it.  I had also tried Edge (which was already installed) and that did not work; I do not have MS Authenticator or any of the other MS apps installed.

Once I was logged in I was able to delete the Word app, and Teams seems to have survived rebooting.  I do not see the authentication in the Android account screen.


I tried everything and this is the only thing that worked with me.


Thank you. 

Many thanks Alberto, my M$ Authenticator App was out of date on Android. After updating that to the latest version, because I need it for work logins (and apparently Teams for Android uses it, too, internally), I was able to log into Teams successfully.