Teams add-in missing

Frequent Contributor

We are running Teams in Islands Mode and are unable to see "Teams Add-in" for scheduling Meetings

is this a known issue or some other setting is required

10 Replies

Hi@Maheshwar Tayal 


So your Team is in Island mode and Skype for business in Home mode? Is that true? You have bot clients available for users?


Or are you explaining about Outlook Add-in?


Thank you



Couple things, mac or pc?

Is modern authentication used and configured for exchange? Also see Troubleshooting section in the article. 


Authentication requirements
The Teams Meeting add-in requires users to sign in to Teams using Modern Authentication. If users do not use this method to sign in, they’ll still be able to use the Teams client, but will be unable to schedule Teams online meetings using the Outlook add-in. You can fix this by doing one of the following:

If Modern Authentication is not configured for your organization, you should configure Modern Authentication.
If Modern Authentication is configured, but they canceled out on the dialog box, you should instruct users to sign in again using multi-factor authentication.
To learn more about how to configure authentication, see Identity models and authentication in Microsoft Teams.

@Chris Webb 


Modern Authentication is enabled for Teams and is working fine

Its windows PC and is not working; we have tried all combinations


Have you checked if the “allow teams add-in” is checked in the meeting policy ?

@adam deltinger 

yes it is

Make sure the same or email account is the one loaded in outlook and is highlighted. I’ve had folks try using the add in locally while using a different mail profile and or additional mailbox not clicked on their primary org that is the one logged into Teams which will cause it not to show up.

If you only have the one profile then do the whole quit outlook. Check processes make sure it’s closed. Quit Teams. Start Teams. Start outlook.

Does same account have outlook mobile? See what meeting option is there. I’ve recently had an issue where mine only shows Skype and even thou I’m set to org wide teams only it’s not working since it appears Microsoft has removed some legacy policies on the back end that has messed up my personal account but no one else’s.
My user had 2 profiles loaded in MS Teams, changed it to the same profile that was loaded in Outlook - restarted both Teams and Outlook and it worked.
hope this helps

@Maheshwar Tayal one of my users had this issue. I found that logging into teams was deleting the 

TeamsAddin.FastConnect key from Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\ in the registry
So i exported the key to teams.reg file from a working system and then made a batch to file to run an import of the reg keys
reg import c:\teams_fix\teams.reg 
then restart outlook
It worked for me. Thank you!
Welcome - unfortunately it is only a hack as it is not a permanent solution. I don't know why Teams is delete my the registry entries. The only thing difference with this user of mine is the fact he has access to more than one tenancy. That may just be coincidental.