Home

Team provisioning issues - Owners not seeing Team

%3CLINGO-SUB%20id%3D%22lingo-sub-1153358%22%20slang%3D%22en-US%22%3ETeam%20provisioning%20issues%20-%20Owners%20not%20seeing%20Team%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1153358%22%20slang%3D%22en-US%22%3E%3CP%3EWe%E2%80%99re%20using%20the%20Teams%20PS%20Module%20version%201.0.1%20to%20provision%20Teams.%26nbsp%3B%20A%20script%20creates%20a%20Unified%20Group%20using%20a%20Global%20Tenant%20account%2C%20then%20adds%20a%20user%20as%20a%20member%20to%20the%20UG%2C%20then%20promotes%20the%20user%20to%20an%20Owner%2C%20and%20again%20adds%20another%20Member%20and%20promotes%20them%20to%20Owner%2C%20finally%20a%20Team%20is%20created%20off%20this%20UG%20and%20the%20Global%20Tenant%20account%20is%20removed.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3EFrom%20a%20process%20perspective%20this%20is%20working%20most%20of%20the%20time%2C%20however%20we%E2%80%99ve%20found%20that%20since%20fall%202019%2C%20occasionally%2C%20one%20or%20both%20Owners%20are%20not%20able%20to%20see%20the%20Team%20in%20the%20client%20or%20web.%26nbsp%3B%20From%20the%20tenant%2C%20everything%20seems%20to%20be%20provisioned%20correctly%2C%20however%20the%20only%20way%20to%20resolve%20the%20issue%20is%20by%20removing%20the%20Owner%20(demoting%20to%20Member%2C%20deleting%20from%20Team%20and%20adding%20back).%26nbsp%3B%20We%20had%20a%20ticket%20open%20with%20MSFT%2C%20however%20they%20are%20reporting%20it%E2%80%99s%20a%20timing%20issue%20and%20we%20need%20longer%20delays%20in%20the%20process%20to%20ensure%20that%20the%20ownership%20changes%20are%20completing%20in%20time.%26nbsp%3B%20However%20if%20this%20was%20the%20case%2C%20I%20wouldn%E2%80%99t%20expect%20to%20see%20the%20correct%20owners%20in%20management.%26nbsp%3B%20Also%2C%20I%20would%20expect%20that%20after%20a%20few%20hours%2C%20the%20Owner%20would%20eventually%20see%20the%20Team.%26nbsp%3B%20This%20is%20not%20the%20case%2C%20even%20after%202%20weeks%20in%20some%20cases.%26nbsp%3B%20Is%20anyone%20else%20experiencing%20this%20issue%20or%20have%20a%20workaround%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1153358%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPowerShell%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Eprovisioning%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1154792%22%20slang%3D%22en-US%22%3ERe%3A%20Team%20provisioning%20issues%20-%20Owners%20not%20seeing%20Team%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1154792%22%20slang%3D%22en-US%22%3E%3CP%3EThat%20is%20indeed%20the%20case%2C%20and%20the%20root%20cause%20is%20the%20%22loosely%20coupled%22%20nature%20of%20Groups%2FTeams.%20Because%20they%20package%20together%20multiple%20workloads%2C%20and%20sometimes%20the%20synchronous%20%22notifications%22%20between%20those%20workloads%20fail%2C%20it's%20not%20that%20uncommon%20to%20have%20to%20wait%20for%20the%20background%20async%20process%20to%20pick%20up%20the%20changes.%20Thus%20the%20delays.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1155367%22%20slang%3D%22en-US%22%3ERe%3A%20Team%20provisioning%20issues%20-%20Owners%20not%20seeing%20Team%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1155367%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%26nbsp%3B-%20thanks%20for%20the%20response.%26nbsp%3B%20I%20understand%20that%20there%20may%20be%20a%20delay%2C%20however%20I%20would%20assume%20that%20eventually%20the%20Owners%20would%20be%20able%20to%20see%20the%20Team%2C%20especially%20when%20from%20the%20Admin%20side%2C%20everything%20looks%20correct.%26nbsp%3B%20The%20issue%20is%20that%20we've%20found%20that%20we%20need%20to%20remove%20the%20user%20completely%20from%20the%20Team%20and%20add%20them%20back%20before%20they're%20able%20to%20see%20the%20Team.%26nbsp%3B%20We're%20looking%20for%20a%20resolution%20to%20this%20since%20it's%20causing%20end%20user%20frustration.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1155999%22%20slang%3D%22en-US%22%3ERe%3A%20Team%20provisioning%20issues%20-%20Owners%20not%20seeing%20Team%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1155999%22%20slang%3D%22en-US%22%3E%3CP%3EWell%2C%20I%20guess%20you%20might%20have%20the%20wrong%20expectations%20about%20the%20length%20of%20the%20%22eventually%22%20window%20%3A)%3C%2Fimg%3E%20If%20you%20repeatedly%20see%20the%20process%20taking%20over%2024h%2C%20best%20work%20with%20support.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

We’re using the Teams PS Module version 1.0.1 to provision Teams.  A script creates a Unified Group using a Global Tenant account, then adds a user as a member to the UG, then promotes the user to an Owner, and again adds another Member and promotes them to Owner, finally a Team is created off this UG and the Global Tenant account is removed. 

From a process perspective this is working most of the time, however we’ve found that since fall 2019, occasionally, one or both Owners are not able to see the Team in the client or web.  From the tenant, everything seems to be provisioned correctly, however the only way to resolve the issue is by removing the Owner (demoting to Member, deleting from Team and adding back).  We had a ticket open with MSFT, however they are reporting it’s a timing issue and we need longer delays in the process to ensure that the ownership changes are completing in time.  However if this was the case, I wouldn’t expect to see the correct owners in management.  Also, I would expect that after a few hours, the Owner would eventually see the Team.  This is not the case, even after 2 weeks in some cases.  Is anyone else experiencing this issue or have a workaround?

3 Replies
Highlighted

That is indeed the case, and the root cause is the "loosely coupled" nature of Groups/Teams. Because they package together multiple workloads, and sometimes the synchronous "notifications" between those workloads fail, it's not that uncommon to have to wait for the background async process to pick up the changes. Thus the delays.

Highlighted

@Vasil Michev - thanks for the response.  I understand that there may be a delay, however I would assume that eventually the Owners would be able to see the Team, especially when from the Admin side, everything looks correct.  The issue is that we've found that we need to remove the user completely from the Team and add them back before they're able to see the Team.  We're looking for a resolution to this since it's causing end user frustration.

Highlighted

Well, I guess you might have the wrong expectations about the length of the "eventually" window :) If you repeatedly see the process taking over 24h, best work with support.