Stuck in Live Event sign in page

Copper Contributor

I'm supporting client virtual events here in PH and have been encountering this glitch, I might say. The Live Event is on Public and many of the attendees are using personal accounts registered for Microsoft Teams Free. If attendees try to join the live event without signing in previously, then they are given the option to SIGN IN or JOIN ANONYMOUSLY. This is where the problem starts, when they sign in with their accounts, they are always redirected back to the SIGN IN or JOIN ANONYMOUSLY page and are unable to join the live event. I tested it myself and encountered it as well. 


However, I tried logging in first prior to attempting to join the live event, works fine.

I hope someone can help me on this. This is something that holds back users, especially users of old age who are trying to adapt to the new normal, from sticking with Teams.

5 Replies

Hi @natpascual1330 ,


Out of interest are the ones with accounts associated with Microsoft Teams already choosing the Sign In option as opposed to anonymous or do we not know? Or does it always look and work on a second time regardless?


What were your repro steps as I would like to do the same also.





Hi @HenryPhillipsNimbitech,


They are choosing the Sign in option. Tried it firsthand and experienced the same, its a loop going back to the sign in page, then if you click on Sign in again, the page will just load back to the sign in page.


Steps are:

1. Click on Join Live Event (without logging into Teams prior)

2. Choose Sign in option and sign in with registered account

3. At this point the page will load back to the Sign in page. Clicking again on Sign in will just loop me back to the sign in page.


Thanks for your response. I tried it on the desktop app, desktop browser, and mobile app. To no avail.



Hello @natpascual1330   FYI: Microsoft just released its virtual event playbook - you might find it useful.

@natpascual1330 I'm having the same issue, did you find a solution? I'm thinking it might have to do with access on organisational level or something...

I have a similar problem but it’s even worse - if people are signed into their Microsoft account, but not part of our organization, they get a message saying they need permission from the organizer to attend. Everything is set to public and our tech people cannot get to the bottom of this. Does anyone have a solution? Our event is in 2 days. The only solution I’ve managed is to tell people to join anonymously. I’m seriously going to give up on Microsoft if we can’t figure this out.