Stuck in a Sign-in loop after changing my password

Super Contributor

I'm having this problem right now. Just changed my password and now Teams is telling me:
We need you to sign in! Either your password changed or the server needs your sign-in info again.


I click the Sign in button and Teams goes away. A few seconds later it opens up again and I'm at the same error/prompt window.  It's done this multiple times.


I searched online and found there's a UserVoice reporting the same issue from over a year ago but there doesn't seem to be any Admin comment on it.  Does anyone know if this is a known bug and if it's being worked on?


56 Replies
best response confirmed by Mike Boehm (Super Contributor)

For now if you still having issues:


 Close Teams
Go to credential manager
Delete all ms teams related entries in credential manager


I'll try figure out the facts about this, if no one here has better input


/ Adam 

Yeah.  I saw that mentioned in the Uservoice post so I tried that and it worked.  Just wanted to see if anyone know if this was actually on the bug list or not.  :)



Clearing out msteams entries from Credential Manager never worked for me.


What did work for me is closing the app, and deleting the contents of the MS Teams cache folder:

  • %AppData%\Microsoft\teams\application cache\cache

After successful sign-in, I had to reselect the Dark theme.

8/19/19 - this issue still appears to exist, got stuck in this scenario this morning

I'm also experiencing this problem as of today on my work computer. Neither clearing credentials manager Teams entries or deleting contents of the Teams cache folder helped. I was also having problems with Windows Updates and a tech came and fixed that (not sure exactly what he did). After rebooting and trying Teams again I got a pop-up that said:

Work or school account problem
We need to fix your work or school account (most likely your password changed). Select here to fix it in Shared experiences settings.


After clicking "here" I was taken to a page and prompted to enter my password. After that Teams worked fine. I'm honestly not sure where "here" took me to, but it was some kind of settings panel. I'm experiencing the same problem on a work laptop (including the problem with Windows Updates) so I am going to see if I also get prompted to fix the account on that machine once updates are installed and I sign back in.


@Mike BoehmRight click on Teams in the taskbar and select Sign Out to then be presented with a log in prompt.

I have the same issue after changing password on Windows 10.



I restarted my PC.

I shutdown MS Teams, then deleted all cache, windows credential for it and still have this issue.

You deleted the files in "AppData\Roaming\Microsoft\Teams\Application Cache"? That did the trick for me.

We have determined in our higher ed environment that the culprit is "Seamless Single Sign On" for Office 365 client applications. We enabled this shortly before the problem started. When we disabled it, the problem went away. We are working with MS engineers to figure out why this breaks Teams sign in. Not sure if this would be applicable to anyone else here.




None of the above mentioned troubleshooting worked for me. I had to uninstall and reinstall Microsoft Teams-- that did the trick.


Right click on Teams in the taskbar and select Sign Out to then be presented with a log in prompt.

This worked for me. This solution makes sense after changing the password. This is simplest and safest of all the options I saw in this posting. Thanks for sharing.

@adam deltinger 


Credential manager fix worked like a charm. Thanks:cool:

@Mike Boehm 


Tried both options - didn't work. We use Seamless Single Sign On

Got it working by
- used the 'sign out' option from the Teams icon in the notification area
- when presented with my username to login - I changed this to a random email address at my domain, e.g. qwerty123@domain and click 'Sign in'
- when prompted for password, I hit the 'back' option to get back to username
- this time, entered in the correct login and password

Teams loaded up no probs!

Amazing ! Did the trick.
Thank you !

@Ramesh2019You would think this would work, but you would be mistaken. It may be the solution that makes sense upon changing a password; however, the programing in Microsoft Teams would tend to disagree with you. Per the comments from the others users, what happens is the user selects Sign-Out, the a window pops up asking them to sign-in because their password has changed. When the user clicks on the sign-in button, the loop continues. It is an annoying cycle. Going online to change their password for Teams does not work. Nothing works. Maybe what another user suggested by removing and re-installing the program will work. I would not use Teams if I did not have to, but someone at my work prefers it, and there we go.

@adam deltinger Is there any news on this. I'm just wondering if there is a permanent fix. Seems a lot of people are having this issue and everyone has several work-arounds, but no solution.




What I did that eventually worked, and I am not sure what part actually worked, was that I went change my password My Teams online; then I continually hit the Sign-in and just continued the loop randomly and it seemed to eventually reset itself. I right-clicked sign off, close, and whatever other possibilities there are from the taskbar multiple times, and continually clicked the the stupid sign-in button, while getting the notification that I had indeed changed my password (as if I had no idea). And it just somehow changed. So, it changed but I honestly do not know how I did it.


I know this is not helpful, but if you have the time to angrily click punches repeated, try that? I only did the online changing of password once.

@paula26 Thanks for the suggestion. Your suggestion worked. We've been uninstalling the deployment for the user and reinstalling seems to work. My concern is that for 1000 users, we've been having to do it on all of them, and this much manual process for that many users is ridiculous. Thanks for the input though. Hope Microsoft gets a permanent fix.

10/31/19 I also met same problem. Clearing cache and Credentials didn't help. Deleting Cookies and Cookies-journal in \AppData\Roaming\Microsoft\Teams helped. I face same broblem almost every time I change password. It seems that the problem exists since 2017, but Microsoft still didn't fix it. Do you really care about your users?