(SOVLED) Team image reverts to some default image in Windows 10 app

Occasional Contributor

Hi there,


I have a problem where all the team images in the Microsoft Teams Windows 10 app are a default grey image (I've uploaded a screenshot as an attachment).


The proper images do show for other members and on my mobile app. I've tried reinstalling Teams and clearing the cach by deleting the Teams appdata folder.


I've also tried logging in with another account from the same organisation. For that account in the same Windows 10 app, the team images do show properly.


We are not an educative organisation and I have an admin account.


Any suggestions? Your help would be greatly appreciated.


Jelmer M.



12 Replies

@JelmerDavid Is it literally just Teams as at first I was thinking if you had enabled some sort of greyscale setting within Windows 10, such as 



But if that was the case you would see it everywhere.


Also with you saying a different account on the same Windows 10 device, in fact that is a point do you get the same if logging onto another device or is it any device?


Back to my other point, what if you refresh your Windows 10 profile.


Another thing you could try would be to uninstall the current Teams app and ensure you are downloading and installing the latest one available by going to say


In fact when going to, how does it look in the web version.








Hi Henry thanks for your response.

On the web version everything is fine. The pictures show.

I called someone up to login on their laptop. The same problem. No pictures only the image I attached in the original message.


So it is not something specific to my device/Windows 10 installation but it only happens on the Windows 10 app and on my account.


I noticed that the image is the same image that briefly appears on the mobile app when the team images are loading. Perhaps it has something to do with a mistake while loading the images from the web? I've checked the firewall settings and no problem there (but I guess that makes sense, as the problem is still there on another desktop device).


It is specificly Teams. No other problems anywhere else as far as I've noticed


I'm running the latest Teams version.


Thanks again for your time, it's greatly appreciated.




Yeah the issue certainly seems to be account specific, which is even more bizarre, but then not as web is fine. So seems to be settings applied to windows for your account.

Could you give me a better screenshot that shows the icon in situ, obviously know that is easier said than done needing to avoid showing anything unwanted. Is it these icons we are talking about:


So in the Teams/Channels list?







Hi Henry,


I've attached the images (I made two new teams as an example). It's only the bottom of the screen but I think you get the idea. It is indeed the Teams list.


I just noticed that the profile pictures of members in the teams also do not show. I've uploaded a second picture for that. My own profile picture does show, but non of the others do (the names are blacked out, just to be sure).


Thanks again.







Without wanting to state the obvious there is something weird going on here. If you could just humour with the below, as I know you did login via another machine and faced the same issue but if you could ensure that you right click the teams icon > sign out > sign back in and see if any better?




If that fails, would you be happy to right click the icon again > get logs and send me them. Feel free to blank out any older stuff or anything that you believe to be of a sensitive nature.








Hi Henry,


I've logged out and logged in once more, just to be sure (it was ofcourse one of the first things I tried) but no change.


I've send you the logs in a private message. Thank you for taking the time to look at them!


The logs are from the last two days, I believe they were reset when I cleared the cache by removing the content in the appdata folder.








Unfortunately nothing stood out or at least not as far as correlating any error, failed or crash entries against my log where I do not see anything. So I did see errors but nothing out of the ordinary compared to my logs.


I know there are other more extensive logs available but would need someone at Microsoft to really make sense of those.


I thought I had stumbled upon something in this post:


But looking at the answer, it seemed to just be a fluke. But I mean it wouldn't make it any worse to try and update one of the images of a Team and see if it sticks or then after a restart gives something a kick.


You could also see if there are any failed calls using something like fiddler whilst launching Teams.


I want to say have you tried a fresh install but the fact that it doesn't work on another users machine and another user can get it to work on your machine means that is probably a pointless exercise.


Just thinking out loud, when you tested on another users machine, was that fully logged on as yourself and then launching Teams? If so, what happens if the other user still stays logged in as them Windows wise but then sign out of Teams only and sign in as yourself. Just trying to rule out if it is some sort of policy being applied to your account compared to others.


Do you know if you get policies by way of GPO or Intune or perhaps you don't? So if Intune I was thinking you could get someone to check policies applied to yourself compared to a user that is not experiencing this issue.


You could also loosely cross reference this yourself by going into accounts > work or school and if registered for device management, click on info:


And you will then see any policy areas in effect as shown below:










Hi Henry, sorry for responding late! It's been a busy day.


Positive aspect of responding late is that Teams has had the time to settle down as in the post you send. But searching for updates and waiting a day sadly did not solve anything.


I was not fully logged in as myself while testing on another device, but, that did get me thinking about something that should have been more obvious to me.


I tried logging in with another account om my device and as you remember, that account did not have any problem with showing the team images.


I finally realized that that specific account was an account created with another domain, not the one I use myself. The other users I've asked to confirm if they could indeed see the images coincidently turn out to also be either a guest or created from another domain.


This gave me the idea that it might have something to do with that, so I created a new account using the same domain as myself and that account also can not see the team images.


So it seem to be a problem related to that. The domain I'm specificly talking about are accounts created with


I've checked the DNS settings and those seem to be quite messed up at the moment.


I've got to commune with a few people before I can change those settings. But once I do, I'll post my finding again (hopefully saying that the problem is solved..).


Do you think the problem might lay there?


Thanks again for your time.




Hi @JelmerDavid ,


Interesting indeed. I mean it stands to reason that is the problem area, but I cannot immediately think how or why? As when another users logs onto your machine, not knowing how the device is joined to a domain, is it using different DNS servers to when you logon as if not then I wouldn't specifically gun for DNS. I would imagine the IP configuration stays the same.


However is that domain showing as healthy in terms of domains within your M365 tenant do you know.


I would also be thinking if the domain that is fine, where does that live in comparison to yourself. Are they both custom domains within the same M365 tenant and users are assigned a relevant UPN based on where they sit in the company?


Or is for example the users that are fine, those that have the domain assigned to them that is native so to speak to the M365 Tenant where Teams is homed and you are by way of a B2B account within there tenant and facing the issue but as you mention other guest accounts against different domains are fine.


Either way I think we should take this as a small victory as you have found some sort of consistency or method in the madness. So it will be interesting to see what you come back with.


In the meantime I will see if anything springs to mind.







Hi Henry,


The domain does not show as healthy. Fixing that will be my first priority now. I have to wait on a collegue before I can do so, but I want it done this weekend.


As for the domains: You are right with your first guess, we have three actually at the moment, each with their own original function, within one tenant. However, we are planning to use to summer months to clean that up and end with only one domain (the one giving issues sadly..).


I'll use the spare time while waiting on my collegue to ask around and get more data on who can and cannot see the images. Just to be sure that it can be narrowed down to a domain problem.


Once I've got the domain cleared up and healthy I'll post another message (hopefully this weekend).


Once again, thank you for your time.



best response confirmed by JelmerDavid (Occasional Contributor)





Hi Henry! It has been a while.


I've tried a million and one things and it finally paid off.

It turns out that there are a couple settings with regards to user roles that clashed (at least on our tenant).


I found out because I made a new account with no roles given. When I logged in there was no problem with Teams (all the images showed), but as soon as I assigned the necessary roles, the team images/icons disappeared.


I have narrowed it down to the roles "Teams communication admin", "Teams communication support engineer" and "Teams communication support specialist" under "Collaboration".


When all those were turned on the team images disappeared and when I turned all of them off the team images reappeared. I haven't done any more testing yet, so I might be that just two (or even one) of those roles cause the problem. Turning them all off might a quite fix for anyone else who is having this problem.


Thanks again voor all your help.


With kind regards,






How bizarre and that makes no sense but I suppose when does a lot of things ever make sense.


As those roles should only dictate the Admin capabilities to do with Voice, certainly the communication roles anyway. And then you have the Daddy Teams role that gives access to Teams totally admin wise, including associated technologies such as M365 groups. But I would never expect them to impact the users client experience.


But your testing does not lie, so thanks for coming back and updating.


I will have to give it a go myself.