Set-CsInboundBlockedNumberPattern

%3CLINGO-SUB%20id%3D%22lingo-sub-1901166%22%20slang%3D%22en-US%22%3ESet-CsInboundBlockedNumberPattern%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1901166%22%20slang%3D%22en-US%22%3E%3CP%3EAfter%20trying%20many%20patterns%2F%20regular%20expressions%20I%20am%20unable%20to%20get%20any%20inbound%20calls%20blocked%20from%20a%20number.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20seems%20that%20the%20regular%20expressions%20arnt%20being%20registered%20in%20to%20Teams.%3C%2FP%3E%3CP%3Eset-CsInboundBlockedNumberPattern%20-Name%20test%20-Enabled%20%24True%20-Description%20%22%3CDESCRIPTION%3E%22%20-Pattern%20%22%5E%5C%2B15554441234%22%3C%2FDESCRIPTION%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEven%20if%20I%20test%20with%20the%201%20or%20without%20the%201%20it%20still%20comes%20back%20false.%3C%2FP%3E%3CP%3EAnyone%20had%20any%20luck%20making%20this%20work%20in%20teams%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethanks%2C%3CBR%20%2F%3EBrett%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1901166%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1902274%22%20slang%3D%22en-US%22%3ERe%3A%20Set-CsInboundBlockedNumberPattern%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1902274%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F179343%22%20target%3D%22_blank%22%3E%40Brett%20Janzen%3C%2FA%3E%26nbsp%3B%20%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F178440%22%20target%3D%22_blank%22%3E%40Steven%20Collier%3C%2FA%3E%2C%20can%20you%20assist%20here%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

After trying many patterns/ regular expressions I am unable to get any inbound calls blocked from a number.

 

It seems that the regular expressions arnt being registered in to Teams.

set-CsInboundBlockedNumberPattern -Name test -Enabled $True -Description "<description>" -Pattern "^\+15554441234"

 

Even if I test with the 1 or without the 1 it still comes back false.

Anyone had any luck making this work in teams?

 

thanks,
Brett

1 Reply
Highlighted

@Brett Janzen   @Steven Collier, can you assist here?