Right-Clicking Chat Field & Spell Checking Not Working

Copper Contributor

We are encountering an issue with the last few revisions of Teams.  When right-clicking a chat field to receive a spell-checking suggestion or right-clicking to paste, no right-click menu appears.

If you close and clear the Teams cache in %appdata%\Microsoft\Teams and restart the client, it will work fine.  However, if you close the client again, right-click functions no longer work.  What is interesting is that this only happens on the Chats with groups or individuals.  You can right-click fine if chatting within a Teams channel or if you pop-out the individual chat.  You can right-click a chat that is occurring within the window showing all of the avatars during a live meeting, however if you navigate to the same chat within the Chat listings, the right-click does not work.


Upon troubleshooting, I found that the SETTINGS.JSON file is being changed after the initial closing of the client.  The paths within the file are totally different with extra slashes than from the initial file.  Not sure if this is causing the problem, however deleting the SETTINGS.JSON file and restarting the client will work for that session until of course you close it again, where the file is changed again upon closing.


Can someone at Microsoft look further into this?  This seems like a bug that is now occurring in the last few releases.  While there are workarounds, it is something that is causing issues with staff.  I have been able to duplicate this on other clients as well.  I am currently running Microsoft Teams Version (64-bit).  We are also in the GCC if that helps so not sure if it is isolated to only GCC users.


Thank you!



47 Replies
Hi, for proper attention from the Teams PG you should post this from the "Give feedback" within Teams (bottom left corner -> Help).

@ChristianJBergstrom there is no such option, instead there is a "suggest a feature" option.

Still an issue for you? We are seeing this as of 07.06.2022

@StephenWM Hi, probably turned off by your admin with policy then. Try with an official support ticket to Microsoft, the admins can create one for you from the M365 admin center.


Manage feedback policies in Microsoft Teams - Microsoft Teams | Microsoft Docs

Have you had any luck in getting a solution to this?
That link clarified things: "Feedback policies aren't available in GCC, GCC High, or DOD deployments."

We are a GCC tenant. Thanks!

Seeing this issue on ver and also a GCC tenet

MS now has a service health advisory out for this issue - TM390278.

Title: Users' right-click context menu isn't working as expected in the Microsoft Teams desktop client

User Impact: Users' right-click context menu isn't working as expected in the Microsoft Teams desktop client.

Current status: We've received reports from affected users that users' right click context menu isn't working as expected within the Microsoft Teams desktop client. Our analysis thus far indicates that a recent feature update may be responsible for impact. We're disabling this update in our test environment to validate that impact is remediated before proceeding with our broader revert plan. In parallel, we're gathering additional logs and data from users who can reproduce the issue so we can determine what exactly is occurring. We're also requesting that users attempt to access the context menu through the web app to see if the issue is isolated to the desktop client only, which should narrow our investigative path.

Scope of impact: This issue could potentially affect any user who's attempting to access the context menu within the Microsoft Teams desktop client.

Next update by: Friday, June 10, 2022, 1:00 PM (5:00 PM UTC)

@StephenWM I appreciate the response. I did find out these features still work in the following chat options:

  • Pop out chat
  • Live call/meeting chat
  • Team group chat
  • Web version of Teams chat

I also found if you delete the settings. json file before you start TEAMS that it works as expected. If Teams is already started just quit Teams, delete the file and start Teams. Of course you will need to do this each time you log on. I  hope this help others. 



Can you share a direct link to this advisory? I'm having trouble locating it for whatever reason. Thanks!


EDIT: Actually, nevermind. I didn't realize this was checked from our own portal. Thanks!


URL for 365 admins:  "https://portal.office.com/adminportal/home?ref=/servicehealth"

Thanks for the reply!


We are on GCC as well.  I will say that the Teams Machine-Wide client is the culprit for us.  If we remove the Machine-Wide client and reinstall the client from the Teams site, it will correct the issue.  This is a workaround for now as we would like to continue using the Teams Machine-Wide client.

I just eresed all the content of teams in the path %appdata%\Microsoft\Teams.
Relaunched the app and it worked.
The personalisations where erased to but at least i got the spelling check available to select the suggestions.

Version (64 bits)

I had the same issue for the last 2-3 days.

To fix it I have:
- disabled spell check in settings
- restarted Teams
- enabled the spell check
- restarted Teams.

Version (64-bit). Last updated on 09/03/2023

@AGMTC This fixed my issue that spell check di not work at all. 
Cleaning cache did nothing for me . As well as removing preferred obscure languages from Windows Language setting.

@AGMTC Thank you for the details. This trick helped me out. Spell checking is working now.



Yes and Now this issue started.


I deleted setting.json file then it work but after some time started same issue again



Deleting settings.json worked for me as well.  Thanks.


This post has been very helpful. I am on MacBook. Also had a look at settings.json, located in '~/

/Library/Application Support/Microsoft/Teams' folder. We are using Microsoft Teams Version On deleting settings.json, Teams generates a new one that is 171K in size. When you open Teams again, this goes up to 188K in size.


cat settings.json | jq '.settings | keys'



cat settings.json | jq '.initializedSettings | keys' | wc -l


cat settings.json.working | jq '.initializedSettings | keys' | wc -l



One of the areas that is changing is the initializedSettings key.


Not got to the bottom of which setting is causing the issue, but seems looking at the JSON via jq can provide some interesting insights - for the technically oriented.