Requesting Control Not Working (Can't Click Anything)


I requested control and I was granted access but sporadically it stops working.  I still see my mouse on the other person's machine and it moves around but I can't click anything.


This is not a one-time occurrence.  It happened numerous times.

38 Replies
Please make sure the setting in the new teams admin to control the request control is enabled in the meeting policies. It’s a drop down that has 3 options. Check that.

Also make 100% sure you are using the screen share on the far left when sharing that is the only option that will allow screen sharing.

Please refer the below thread.
I belive the option is set and it seems like it’s started, but the issue I about the feature not working as expected! Could it possibly be a bandwidth issue? Tried from other network? Everyone having this?

Thanks for the reply Thuyavan but I'm able to request control.


I'm saying it is flaky.  In a session where I have control my clicks just stop.  I can still move my mouse on the other persons machine but I can't click anything.  Then, a few minutes later it starts working again.


I belive the option is set and it seems like it’s started, but the issue I about the feature not working as expected!

That is correct Adam!


Could it possibly be a bandwidth issue?

Doubt it as I can still see the other persons screen and any actions they take.  Also, I can still see my mouse move on their screen so it doesn't seem like a bandwidth issue.  And I can see their video/webcam.


There's a way to access Team "debug" logs on the client, right?  I wonder if the log file would be useful?  Mine, the sharers or both?


Tried from other network?



Everyone having this?

Not sure, I'm the early adopter... :smiling_face_with_smiling_eyes:


Thanks for your response!


@Michael T. DePouw Spottedmahn   Are you still having this problem? I've noticed a few times that it happens to me. I'll have screen control and everything will be working fine until all of the sudden I can't click. The other user can still see my mouse moving but clicks are not registered.


@Kevin Ruschman: we have the exact same problem. First it is working, then all of a sudden I cannot click anymore.


Exactly the same problem described above by @Michael T. DePouw Spottedmahn. Same behaviour, same frequency. This renders the control feature quite unusable.


It seems to happen when the controller opens an application that was not running when the control was granted.


@Michael T. DePouw Spottedmahn 

I am experiencing the same issue.  I am the early tester for TEAMS to evaluate for the SfB migration and this isn't a good sign of things to come.

Been doing some more screen sharing lately, like 20hrs +, and this hasn't been happening :thumbs_up:.

BUT, we have to frequently turn off my remote control because that person's mouse doesn't work :crying_face:.

Feels like a different problem, a related problem but still different. Thoughts?

@Michael T. DePouw Spottedmahn 

Same issue happening to me, any idea?? My colleague has the same issue. 

It seems like a Teams application problem...


@Michael T. DePouw Spottedmahn 

I experienced this issue when the sharing person uses a RDP on a server or a VM.
Clicking works on the other person's computer but not in the remote on.






>Same issue happening to me, any idea??


It's just buggy.  Sometimes turning off/on my control fixes it.  Sometimes leaving the call and re-joining fixes it.  Sometimes the controlee leaving the call and re-joining fixes it. 🤷‍:male_sign:


I've been using remote control a lot the past few weeks and it is very flaky.  It is working one sec and then stops.  Sometimes I can click on some apps but not others.  Today I could left click but not right click.


@Michael T. DePouw Spottedmahn 

We had a similiar complaint from one of our devs. Could it be that you all are opening a administrative window in those cases? 

e.g. Windows Command with elevated rights

In those cases the whole input is not possible until the window is closed. 

In our case the dev had opened Visio in administrative mode and his colleague was not able to control anything from that moment on. As the window is closed, the control is back. 

Maybe this will help some of the users with complaints here... 



At this moment we are facing this same issue on more than one user.


What would it be necessary for this issue to be reviewed by Microsoft? This seems to be an ongoing problem.


@TRMOE Thank you very much for this tip! This solved a major issue for us when using Microsoft Teams with a specific application which we were running as administrator.


Hi @TRMOE :waving_hand:


>We had a similiar complaint from one of our devs. Could it be that you all are opening a administrative window in those cases? 


Nope but thanks for your input :thumbs_up:.  That doesn't work at all.  Learned that from my Skype for Business days.  Seems to have carried over to Teams.  Wonder if it is more of a OS level thing? :thinking_face: 


@Michael T. DePouw Spottedmahn In our case we had a number of issues including the app running as administrator. However, the intermittent clicking issue might be related to firewall ports. We had to open all required outgoing ports from our network as defined in the Microsoft doc below.


"TCP ports 80 and 443 from the clients to the internet, and UDP ports 3478 through 3481 from the clients to the internet."


We also opened TCP and UDP ports 50000 - 50059. I don't know if this was required, but I did see these ports defined in out Teams settings (attached) so I opened them as well to ensure we would not have issues.


@TRMOE This is exactly the issue we are having.

As a Systems Admin that sometimes has to do a little bit of the more in-depth tech support requests, most of the time we are connecting to assist a user is going to require something being run as Admin.

For example: I had to fix an issue with SoundForge 10.0/11.0 where it creates an erroneous registry entry that prompts for elevated privileges even though the software is already registered it becomes nonfunctional. It is an ongoing issue that Magix does not intend to patch in an older piece of software that we own.

In order to remedy the issue, I need to open Regedit, and delete a registry folder/key for the software. This is not possible through Teams, as I lose my ability to click anything once invoking the program. It's very frustating because editing the registry is something that we do not want users doing on their own.

I believe Microsoft should patch Teams to allow clicks when something is required that needs to be run as Admin. This is critical for assisting users.




I have been having the same issue, it does not seem to be just an admin issue because I have the exact same symptoms when remote controlling a Mac. In the middle of a session clicking just stops, not opening anything, not changing any preferences, just browsing. I have to tell the person what to click on until it starts working again and I can click.


Having the same issue. Pure Windows. It start with working and than suddenly your clicks don´t work anymore. Is Microsoft working on this issue? I see this problem is already a year old and the problem still exists.


@johanjacobs I don't see it being an issue with Windows as much as it is a security measure they must have taken in Teams to disable click running something as Administrator.

For now I have mostly stopped using Teams for remote assistance, and instead obtain the users password and connect via RDP. It's far less convenient, but until it starts working, Teams is not that useful to me at the moment. The other workaround is I enable audio and talk the user through the steps needed if it's simple enough, but again, I would rather not direct them to do such things.


@Tantor_Admin I even don´t do it as an Admin. I just take control of the other screen, which is a build in function. At first it works fine and than suddenly you can´t click on anything anymore. I know there are other solutions for this as RDP or TeamViewer but as everybody is working from home and is communicating via Teams it would be handy if this function works as it is supposed to. As we also give trainings we would also like to use Teams to train people in the use of our tools. So you can let the trainee do some things, point out points of interest and show him how to do things while in the mean time talking to him. So we would like to invest further if Microsoft is aware of the problem and planning to do something about it.


@TRMOE For the win! You've saved my ability to interview while remote. Kudos to you sir. Note to self, avoid checking the "Run this program as an administrator" box under the "Compatibility" tab of shortcut icon properties.


@Michael T. DePouw Spottedmahn 


When I use Teams I frequently lose control of my cursor - it hovers over the X in the far upper right of the screen, with a circle around it! Sometimes it gradually calms down, but this is very unnerving when working. Does anyone else have this problem or any thoughts about what to do about it?


@johanjacobs I don't mean running Teams as Admin, I mean after you've already connected to a screen share and requested control, if you invoke any built-in windows functions that require local admin credentials, such as Computer Management or RegEdit, you lose your ability to click. Often when troubleshooting I will need to get in device manager, or make registry adjustments for a piece of software we implore, and this will bring on the issue for us.


@Tantor_Admin Indeed I am having the same problems. As soon as I open Control Panel or Device Manager I loose the control, having to ask the user to click for me. As soon as the tools which need local admin are closed I get the control back. We also have this for a tool we make ourself. We found that running this tool on another computer and then controlling it via RDP does not give problems but it is cumbersome, however because we need this for training purposes it is a workaround. Anybody from Microsoft with some clues how to make this work? Does it help if your Team apps is running as admin?


@johanjacobs I have the same problem using Visual Studio. Visual Studio running as Admin I can't do anything, only move the mouse and not click.


But the same happens with Zoom, not only Teams.




Odd question, but what colour is your cursor on the remote desktop, I mean the little one that lags behind yours. I find there is a correlation between that and who has control. 


If it is white, you should have interactive control, if it switches to black at any point you will loose interactive control but your remote user will still see it. Based on this behaviour it seems like this is a feature of Teams and not a bug. 

White I believe - but with weird pulsing red circle - and cursor gets jittery and freaky - thanks -

@Michael T. DePouw SpottedmahnThis is a big issue in Teams and I cannot support my users remotely without use of a mouse. The other issue is supporting them while using a VPN which Teams Chat and calling crashes if using a VPN. Forced to use TeamViewer to support my remote users. MS lame excuse to check hardware acceleration is BS and made no difference. May have to return to Slack.


I ad the same issue today with a Guest User.

Guest user shared a Window (aka: Application) and then gave control.

Initially remote control was working and mouse action/click was working fine, but when the Guest user changed to another application (Outlook) on the remote desktop the mouse cursor still was moving, but unable to click anything. Once the user changed back to the Application he shared in Teams, remote control and mouse clicks started working again.

Tested this with the Guest user 3 times, and it was reproducible all 3 times.


In my case it seems as if remote control is only working as long as the user on the remote desktop keeps the shared application as active window.


One of the use case of sharing Window/Application is that the user who shares the Window/application and giving control is able to use other applications on his machine while sharing 1 application including giving control of this 1 application and the local user using other applications without interfering with the sharing/giving control.


Is the fact that the control of a shared Window/application is only working while this window is active on the machine from which it was shared the intended functionality or is this a malfunction?


Thanks in advance for your valued  response.



Yes the same problem with my Teams application too.  Is there any solution to use and operate other's computer without any problems?


I also have the same problem: The "give control" button at the top of the screen during a screen share in a Teams meeting does nothing at all. It is clickable, but that's it.


I have also tried the different settings in Teams Admin Center, and I've also checked out this MS article claiming it's a GPU issue: Here's what I've found:


  1. If you do open chrome://gpu in Google Chrome, it will tell you under "Graphics Feature Status" that acceleration is turned on, but if you scroll down to the section "GpuMemoryBuffers Status" it will mostly show "Software only", which is, at least according to this MS article, the reason why giving control doesn't work.
    And this is although I'm using a MS Surface Pro 6!!!!! So TeamViewer, Slack, Google Meet/Hangouts all run smoothly but Teams can't handle the Surface Pro's GPU???? :facepalm:

  2. CORRECTED: The first MS article mentioned the folder %appdata%\Microsoft\Teams\media-stack\. This is actually incorrect. The actual log file that contains info about hardware acceleration is directly %appdata%\Microsoft\Teams\logs.txt. In my case, it did NOT contain "AppSharingToolbar created with hardware acceleration: false", so according to the log, at least, hardware acceleration doesn't seem to be an issue.

I'm not running anything as admin, I'm using the app, not the web version, I made sure to allow users to share the full screen and that also works. Only giving control doesn't. If anyone has any new ideas, please let me know. :smile:



I finally managed to find the issue.

It happens when you have an app opened with admin privilege, Actually Teams for some security reasons doesn't let the user to click or keyboard input when the active app is opened as soon as you switch to a none admin opened app, it starts working.

I still don't know how to fix it.


Hope it can help you.:smile:

@Michael T. DePouw Spottedmahn 


@Bijavar @Michael T. DePouw Spottedmahn I have exact the same experience.

I did not find any workaround than showing with the mouse where the person whose PC you are controlling must click on. This problem makes Teams not usable for technical assistance or for teaching purposes. I also hope that Microsoft is coming with a solution for this.





@Tantor_Admin   I have read this thread with interest.  As a teacher i am using MS teams to run lessons.  When i am doing 1-1 interventions i use online games.  I then need to give control to the student so they can interact with the exercise.  Some students manage it.  Others cannot.  The issue i have is they can see their cursor and move it, but they cannot click on anything.   So as it works for some and not for others it cannot be my laptop.  So is there a reason this happens?  Is it because the system i am sharing with is older ?  it makes life very difficult for us who just want to teach and have a programme do what it is expected to do. 



@Sarah_OB I have only found the no-click issue to occur when a system prompt, or dialogue requiring administrator credentials is run. An example of this would be anything that dims the screen and requires the "Yes" to proceed.

I run into it when I try to open the registry editor remotely on someone's machine or receive a User Account Control prompt when uninstalling a program. I imagine it is a security feature, however in most scenarios it works ok. It's possible the students are not hitting "approve" at the top of the screen to gain control. Even if your system is older, it should work fine. Make sure you have all the latest Windows updates, and check for updates in Teams by clicking your username in the top right of Teams, and choose "Check for Updates".

This is the same problem I have as well. In many cases I need that admin privilege app to assist our users who are working from home, so I end up having to use other methods than Teams for support.