Request timeout Failed to connect to settings endpoint

%3CLINGO-SUB%20id%3D%22lingo-sub-498932%22%20slang%3D%22en-US%22%3ERequest%20timeout%20Failed%20to%20connect%20to%20settings%20endpoint%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-498932%22%20slang%3D%22en-US%22%3E%3CP%3EI%20currently%20have%20two%20users%20trying%20to%20connect%20from%20India%20to%20Microsoft%20Teams.%20For%20both%20the%20desktop%20application%20of%20Teams%20works%20when%20installed%20(and%20reinstalled)%20but%20stops%20when%20opening%20again%20forcing%20the%20user%20to%20reinstall%20the%20application%20every%20time%20they%20open%20it.%3C%2FP%3E%3CP%3EBoth%20users%20are%20on%20different%20networks.%20I%20checked%20their%20connection%20settings%20and%20they%20don't%20block%20anything.%20Both%20get%20the%20same%20error%20message%3A%3C%2FP%3E%3CP%3E%22Error%20code%20-%20Request%20timeout%22%3C%2FP%3E%3CP%3E%22Failed%20to%20connect%20to%20settings%20endpoint%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20going%20on%20for%20quite%20some%20time%20now%2C%20please%20advise%20and%20help.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-498932%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-499105%22%20slang%3D%22en-US%22%3ERe%3A%20Request%20timeout%20Failed%20to%20connect%20to%20settings%20endpoint%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-499105%22%20slang%3D%22en-US%22%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F329623%22%20target%3D%22_blank%22%3E%40kmoser%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EDoes%20it%20work%20for%20the%20users%20if%20they%20log%20into%20the%20web%20client%20at%20teams.microsoft.com%3F%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-499308%22%20slang%3D%22en-US%22%3ERe%3A%20Request%20timeout%20Failed%20to%20connect%20to%20settings%20endpoint%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-499308%22%20slang%3D%22en-US%22%3EHi%20Christopher%20Hoard%2C%3CBR%20%2F%3Eyes%2C%20the%20web-version%20does%20not%20have%20these%20connectivity%20issues.%3CBR%20%2F%3EBest%2C%20Kilian%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-499465%22%20slang%3D%22en-US%22%3ERe%3A%20Request%20timeout%20Failed%20to%20connect%20to%20settings%20endpoint%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-499465%22%20slang%3D%22en-US%22%3EOk%2C%20if%20it%20works%20on%20the%20web%20then%20it's%20likely%20something%20localised%3CBR%20%2F%3E%3CBR%20%2F%3E1.)%20Are%20the%20desktop%20clients%20on%20the%20latest%20versions%3F%3CBR%20%2F%3E2.)%20Is%20there%20anything%20on%20the%20machine%20which%20may%20be%20prohibiting%20it%20after%20a%20period%20of%20time%20(antivirus%2Ffirewall)%3CBR%20%2F%3E3.)%20Do%20you%20use%20a%20proxy%3F%3CBR%20%2F%3E%3CBR%20%2F%3EHave%20you%20tried%20using%20other%20machines%20at%20their%20locations%20for%20them%20to%20log%20into%20to%20see%20if%20its%20their%20machines%20which%20are%20likely%20at%20issue.%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-499531%22%20slang%3D%22en-US%22%3ERe%3A%20Request%20timeout%20Failed%20to%20connect%20to%20settings%20endpoint%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-499531%22%20slang%3D%22en-US%22%3E%3CP%3E1)%20Version%201.2.00.8864%20(64-bit).%3CBR%20%2F%3E2)%20No.%26nbsp%3B%3CBR%20%2F%3E3)%20No.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20one%20user%20we%20also%20tested%20it%20with%20a%20clean%20install%20of%20windows.%20Same%20issue.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3ECould%20this%20have%20to%20do%20something%20with%20modern%20vs.%20non-modern%20authentication%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3CBR%20%2F%3EKilian%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-499597%22%20slang%3D%22en-US%22%3ERe%3A%20Request%20timeout%20Failed%20to%20connect%20to%20settings%20endpoint%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-499597%22%20slang%3D%22en-US%22%3EHi%20Killian%2C%3CBR%20%2F%3E%3CBR%20%2F%3EHmm%2C%20the%20article%20here%20suggests%20that%20timeout%20is%20caused%20by%20something%20local%20blocking%20Teams%20from%20working%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2Fwhy-am-i-having-trouble-signing-in-to-microsoft-teams-a02f683b-61a3-4008-9447-ee60c5593b0f%3Fui%3Den-US%26amp%3Brs%3Den-US%26amp%3Bad%3DUS%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2Fwhy-am-i-having-trouble-signing-in-to-microsoft-teams-a02f683b-61a3-4008-9447-ee60c5593b0f%3Fui%3Den-US%26amp%3Brs%3Den-US%26amp%3Bad%3DUS%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3ECan%20you%20see%20anything%20in%20the%20logs%20by%20right%20clicking%20on%20the%20Teams%20tray%20icon%20and%20Get%20Logs%3F%20This%20could%20show%20something.%20I%20would%20consider%20raising%20this%20one%20to%20Microsoft%20in%20a%20ticket%20with%20the%20logs%20considering%20there%20should%20be%20nothing%20blocking%20Teams%20from%20working.%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1639536%22%20slang%3D%22en-US%22%3ERe%3A%20Request%20timeout%20Failed%20to%20connect%20to%20settings%20endpoint%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1639536%22%20slang%3D%22en-US%22%3E%3CP%3Esir%2C%20kindly%20reply%20my%20request.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I currently have two users trying to connect from India to Microsoft Teams. For both the desktop application of Teams works when installed (and reinstalled) but stops when opening again forcing the user to reinstall the application every time they open it.

Both users are on different networks. I checked their connection settings and they don't block anything. Both get the same error message:

"Error code - Request timeout"

"Failed to connect to settings endpoint"

 

This is going on for quite some time now, please advise and help. 

6 Replies
Hi @kmoser

Does it work for the users if they log into the web client at teams.microsoft.com?

Best, Chris
Hi Christopher Hoard,
yes, the web-version does not have these connectivity issues.
Best, Kilian
Ok, if it works on the web then it's likely something localised

1.) Are the desktop clients on the latest versions?
2.) Is there anything on the machine which may be prohibiting it after a period of time (antivirus/firewall)
3.) Do you use a proxy?

Have you tried using other machines at their locations for them to log into to see if its their machines which are likely at issue.

Best, Chris

1) Version 1.2.00.8864 (64-bit).
2) No. 
3) No.

 

For one user we also tested it with a clean install of windows. Same issue.


Could this have to do something with modern vs. non-modern authentication?

 

Thanks,
Kilian

 

Hi Killian,

Hmm, the article here suggests that timeout is caused by something local blocking Teams from working

https://support.office.com/en-us/article/why-am-i-having-trouble-signing-in-to-microsoft-teams-a02f6...

Can you see anything in the logs by right clicking on the Teams tray icon and Get Logs? This could show something. I would consider raising this one to Microsoft in a ticket with the logs considering there should be nothing blocking Teams from working.

Best, Chris

sir, kindly reply my request.