Recording failed to upload [November 2021]

New Contributor

A colleague recently created a meeting and recorded it. However, when they stopped the recording, we got the following:




The recording seems to have been lost. It is not there on the colleague's OneDrive and neither on the SharePoint of the channel where this meeting was started.


This is how the meeting looks like in the channel:


The error message in the previous screenshot appears when I expand this.

11 Replies

Me too having the same problem. It is showing exactly the same error msg. Need help here


I had the same issue today. In a 4-hour session (with breaks every 45-50 minutes), the first 3 videos didn't upload to onedrive, only the last one did...


Some time ago I analyzed what happens when you force an error at the time the recording is being saved, it is here on my blog

The recording "should" be in AMS.

Do you know how to find it in AMS? I wasn't able to find any link for that.

Same problem in a scheduled meeting. Exact same error message. The video is nowhere to be found on neither OneDrive nor Sharepoint
In my case, (slightly different error message), the download link (I think it was from AMS) was available.
I see on these screenshots that the download link is not there, so maybe asking Support would be good to see if the recording wasn't lost and it could be uploaded to AMS

We had the same problem today, raised a support ticket. I have no idea how you download files from AMS. It talks about it half way down this pages
I only could find AMS within the azure portal under Media Services however nothing obvious in there.

Hello, when they say it's being stored in AMS you don't actually go and download it from there but rather it's supposed to be downloadable just like any other recording. You did the right thing opening a support ticket if no option to download was present and it seems to be missing from the intended storage location. On the topic I actually heard in here about people using the "auto-record" feature and that put the recording in the supposed deprecated Stream storage..
FYI all our meetings are started manually. We use this feature a lot everyday, and this is the first time we have seen this. I can see from the logs we have had successfully recorded meetings today. So I am presuming this was a glitch on the back end.
Same issue for me today, keen to find a solution to retrieve my important recoding.
best response confirmed by hb200007 (New Contributor)

As already mentioned, there was an incident yesterday affecting Teams meeting recordings. You need to open an official support ticket with Microsoft for assistance, the community cannot do anything about it. If you're not an Teams admin / IT admin reach out to your organizations admin and ask that person to create a support ticket from the M365 admin center.


Let me add to this that some users have been able to access their recordings by having their admin using the support tool "meeting diagnostics" from within the M365 admin center.


Self-help diagnostics for Teams administrators - Microsoft Teams | Microsoft Docs