Recent issue with IOS Teams app for Guests

Brass Contributor

I manage the ICT for a non-profit. We have a project team who have guest users and have been using it for a rota for some time successfully. Guest users get access via Teams and can see the rota just fine. The underlying sharepoint is set to Read only for Guests/Visitors so they cannot edit the files.


This week several users got in touch to say they could no longer see the files and hence the rota on Teams. I was able to recreate this issue using my own guest account. No issues with full users. Have tried all the usual logging off/on, uninstalls. The only thing I would note is that when you enter files, Microsoft Authenticator briefly flashes up and then disappears which makes me think it may have some part in it. We do have Conditional Access in play, but Guests are excluded from most policies which limit access, and I can see no policies applying on the logon, except MFA for guests.


The interesting thing is that this is only affecting IOS Teams. Android and web works just fine and all files are still visible.


Any ideas? Maybe a bug?

15 Replies

Just to add to this. When I add a link to the sharepoint address I can access that link just fine. Its only in IOS Teams itself I cannot access the File tab. The link works fine, so its not access. 


I have the same issue: my account does show files in our own teams environment. The teams i can access as guest in other companies under my same account show chats etc but no files.

I can upload however files. So it behaves as if a filter is active.
This only happens in the ios app (newest version ios 16). In android desktop and browser the files do show up.

This is a big issues for me as I have a lot of meetings on the road and cannot access the files on my phone..

I resintalled ervything on my iphone XR (clean install) and this did not help.
I also did a test on an older iphone 6, ios 12: no problems at all!!

Yeah, I still haven't got to the bottom of it, but I agree it seems to be since an update to IOS. I worked around it for this particular team by attaching the xlsx sheet they needed as a tab in the team as a work around and that worked. For others you could link to the sharepoint document library possibly to help them with a tab? Its only affecting guests, and MS seem to have been having all sorts of issues recently with them, so it might be related to that?



Same problem here. For a few weeks now O365 Guests see nothing in Teams iOS app under the file tab. Direct links to the sharepoint library work fine. Also using a MacOS or Windows computer with the Teams app: no problem.


This is a real issue. I have customers who rely on their subcontractors (guests in O365) to open blueprints and designs on the building site on their mobile device.

We are having this same issue. The files can be viewed when on a desktop but not when on an iOS device app for external guest members.

@EOwens27 I’ve openend a ticket at Microsoft support. Response: They are pointing to Apple because the bug started after an iOS Update.

@he-groep “Nice” they are pointing at apple. However Microsoft is the app software supplier and is thus responsible for pre-testing iOS updates and keeping the app up to standards. Clearly they are not. 
maybe we should start a legal action against Microsoft.?

@mariusp10 I would suggest the best action would be for everyone to start their own support ticket with Microsoft. The more attention the issue gets, the more action maybe expected.

Will do this, although my workaround is working for us, as they only need access to one worksheet and the link is working, so its not such a big deal for my users. Its good to know this is not an issue with our conditional access which is what I was slightly concerned about. The fact it only happens on ios for guests made that unlikely. I will open a ticket though, as MS shouldn't be palming this off on Apple. As @mariusp10 said MS are responsible for making sure their own app runs on Apple's platform, updates or no

@he-groep: good suggestion to make a support ticket, will do.

OK, just off the phone with MS who have acknowledged this is an issue they were able to re-create in their test environment. Its now escalated with the Teams tech team but there is no known date for it to be fixed. It is complicated by Apple and MS needing to work together to figure out what broke what. This doesn't help us at all, but keep logging the fault and providing feedback and that should help push it forward. Not the best response from MS for a clearly broken app, but apparently the 'feature' required to make it work again needs to be developed.... so I guess we're stuck until that happens. Its making me re-evaluate how we currently use Teams with Guests
best response confirmed by alig69 (Brass Contributor)

I see Microsoft are finally realising this is a big issue and are doing something about it. Estimated start time just about a month off :unamused:




It looks like this may have been patched. I am able to access files now from the Teams iOS app as a guest.
Yes, this now has been fixed by MS and seems to work for us too TM677773 was the incident number. Once that was closed everything started working again

Exploring innovative solutions and platforms like enhances our digital experience on iOS, offering unique and valuable tools that go beyond what's available in the standard App Store. It's a testament to the vibrant ecosystem around iOS, connecting users and developers in new and exciting ways.

1 best response

Accepted Solutions
best response confirmed by alig69 (Brass Contributor)

I see Microsoft are finally realising this is a big issue and are doing something about it. Estimated start time just about a month off :unamused:




View solution in original post