"You're not on Teams yet, but you can set it up for your organization" login error

New Contributor


I have problem with signing in to Microsoft Teams. Every time I try do sign in, it shows error "You're not on Teams yet, but you can set it up for your organization". I tried 4 different accounts and Web app,  Android app, Windows app and MacOS app. It always shows the same error. I've even created new Microsoft account but there is still the same problem. Is it some kind of issue or am I doing something wrong?

18 Replies



I went through this process myself to see what is happening, to say the user journey is pants is an understatement. 


1. Sign up for an account - which you seem to have done.

2. You are told "our not on teams yet, set it up for your organisation"

2. Click Sign up for Teams.

3. Scroll to the bottom of that page

4. Click Sign up for Free. 


Follow the prompts and that should do it. 


That worked for me. 

@Andrew Hodges 

I've also tried that, but it prompts for school e-mail. I want to use Microsoft Teams Free on my personal gmail or outlook account. When I do it this way, it shows an error that I have to pass school e-mail address. 



Open an incognito(Chrome) or In Private Brower(Edge) window and go here - 


Create an account with your own personal email. Then follow the steps above. 

@Andrew Hodges 


What option should I select when it asks if I want to create business, school or family and friends account? I need it for school, so I select school option but it prompts for school email address which I don't have. 



This option is about who created the account. As its you creating the account then its a personal account, so don't select the School option. 



@Andrew Hodges  I still can't sign in. When I select personal it only shows me Skype.

Same situation for me. Then goes back to the begining to "your're not on teams yet" and sign up for teams so it starts all over again.

Hey, Try this out. Use "Chrome" and go for, follow the steps. Once you have created an account using your personal Microsoft email address (Ex. hotmail, live etc.,), then launch the teams app from your desktop or mobile. It works. Cheers. 

Hey @artur8889 (And for all others having this same issue)

I found success in using my Microsoft account to sign-in to the Teams Desktop App after using the "Sign-up for free" offer


  1. Choose the Business\Company option. (Obviously Education is not correct, and Personal won't work, as it only redirects to Skype...)
  2. Create the "Company" (I just used my initials).
  3. Now I was able to use the Web App, but the Desktop program was still not working... (We're closer, but still not there yet...)
  4. I uninstalled the Teams Desktop App.
  5. Re-Installed the Desktop App using the installer that is available in the lower left corner of the Teams Web App. (see image)image.png
  6. Once that was installed, it signed me in to my "Company" account I had created....


Hope that helps others.


Sequence of Events :-

  1. I got a temp password from school
  2. I signed in the teams
  3. had to "Sign up" for teams
  4. In browser when I logged in, i had to change the password. So I did
  5. In browser, outlook / teams started working, In Teams Application, I was still getting the same screen 
  6. After realising step 4, i Signed out from teams app, and signed in again with new password
  7. Wrote this answer
Best Response confirmed by ThereseSolimeno (Microsoft)

@yashu2015 A search of the community has yielded other posts with a similar theme.  This one should answer the question:

@Andrew Hodges 


Thanks for tip of setting up company 

and using on Incognito Window to finish setting Teams.  


After an hour or so, and checking this community.  




I'm sorry to break this down to you like this, but to successfully sign up on Teams, you will require a PhD in Rocket Science with 30 years of proven experience. A Nobel Prize in Rocket Science is highly recommended. 

These requirements are listed in the minimum requirements for signing up on Teams.



Sorry for the sarcasm, but serious MSFT, please get your act together and hire some good engineers to thoroughly develop a good solution that... "just works!". 


Same issue for me as well, is it solved yet for anyone?

Observing this issue since like 4 months in my linux laptop. For some reason, it just works in android phone and windows OS. Does developers didnt test same for linux app? Why its forcing to signup to join someones else meeting in linux machines?

@sauraahu I signed up for another account online (with same email address) so I had another (free) company teams account. This allowed me to login to teams on the Mac app. Annoyingly it asked me which account I would like to use - so they new I already had an account all the time!! Must be a bug / missing flag set in the cloud somewhere and signing up for a second account ensured that the flag was now set properly so I could sign in.