SOLVED

"invalid user" error when trying to add a member to a private channel

%3CLINGO-SUB%20id%3D%22lingo-sub-1476858%22%20slang%3D%22en-US%22%3E%22invalid%20user%22%20error%20when%20trying%20to%20add%20a%20member%20to%20a%20private%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1476858%22%20slang%3D%22en-US%22%3E%3CP%3EDear%20Team%20Community%20Members%2C%3C%2FP%3E%3CP%3EI%20am%20using%20Teams%20for%20my%20personal%20project%20and%20I'm%20having%20some%20issues%20with%20adding%20a%20member%20to%20a%20private%20channel.%20There%20is%20no%20problem%20adding%20him%20to%20a%20standard%20channel%2C%20but%20when%20I%20try%20adding%20him%20to%20a%20private%20one%2C%20it%20says%20invalid%20user-%20even%20though%20in%20standard%20channels%20the%20user%20is%20valid.%20Please%20see%20the%20screenshots%20attached.%20When%20I%20add%20him%2C%20it%20looks%20like%20he's%20been%20added%2C%20but%20he%20does%20not%20show%20up%20in%20the%20private%20channel%20members%20group%20nor%20does%20he%20get%20access%20to%20the%20channel.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20tips%2Fguidance%20would%20be%20extremely%20helpful.%20Please%20note%2C%20this%20is%20for%20a%20free%20version%20of%20teams%20for%20my%20personal%20project.%20There%20is%20no%20problem%20adding%20other%20members%20to%20a%20private%20channel%2C%20it's%20just%20his%20account.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1476858%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1478004%22%20slang%3D%22en-US%22%3ERe%3A%20%22invalid%20user%22%20error%20when%20trying%20to%20add%20a%20member%20to%20a%20private%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1478004%22%20slang%3D%22en-US%22%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F704622%22%20target%3D%22_blank%22%3E%40GvantsaTura%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3ETry%20adding%20them%20through%20the%20mobile%20app%3CBR%20%2F%3E%3CBR%20%2F%3EThis%20has%20been%20a%20persistent%20issue%20for%20some%20time.%20Microsoft%20are%20looking%20into%20the%20issue%20and%20it%20has%20been%20better%20of%20late%2C%20but%20it%20still%20happens%20occasionally%20for%20me%20-%20that%20is%20in%20a%20paid%20tenant.%3CBR%20%2F%3E%3CBR%20%2F%3ELet%20me%20know%20how%20it%20goes%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1478147%22%20slang%3D%22en-US%22%3ERe%3A%20%22invalid%20user%22%20error%20when%20trying%20to%20add%20a%20member%20to%20a%20private%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1478147%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F169605%22%20target%3D%22_blank%22%3E%40Christopher%20Hoard%3C%2FA%3E%26nbsp%3BYes%20it%20worked!!%20thank%20you%20so%20much!!!%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Dear Team Community Members,

I am using Teams for my personal project and I'm having some issues with adding a member to a private channel. There is no problem adding him to a standard channel, but when I try adding him to a private one, it says invalid user- even though in standard channels the user is valid. Please see the screenshots attached. When I add him, it looks like he's been added, but he does not show up in the private channel members group nor does he get access to the channel. 

 

Any tips/guidance would be extremely helpful. Please note, this is for a free version of teams for my personal project. There is no problem adding other members to a private channel, it's just his account. 

 

3 Replies
best response confirmed by ThereseSolimeno (Microsoft)
Solution
Hi @GvantsaTura

Try adding them through the mobile app

This has been a persistent issue for some time. Microsoft are looking into the issue and it has been better of late, but it still happens occasionally for me - that is in a paid tenant.

Let me know how it goes

Best, Chris

@Christopher Hoard Yes it worked!! thank you so much!!!

@GvantsaTura 

I also have this error when wanting to add a member of my team to a private group.
nothing works!!