"Due to org policy, you can't use (Gmail) with Teams on this device. Contact your admin"

Copper Contributor

This error pops up whenever I try to open the Microsoft Teams app with my Gmail accounts. I've tried with both of my Gmail accounts and it still gave me the same error, even changing the privacy settings to see if it works. Tried it on my school account (not Gmail) and the app works fine. Any suggestions? 

Screen Shot 2021-01-26 at 8.08.18 AM.png

22 Replies
I was able to fix it manually. I'm not using a Mac, but I uninstalled Teams and then just went through the registry (regedit) and deleted EVERY SINGLE LINE) that contained the word teams... It was a hell of a job to do but finally i got my account back. I just don't understand how people actually want to use such crap as Teams. It hangs and crashes way too often. Good job Gates, it's just missing the blue screen.
If this is a personal computer, it's most likely that at some point you or someone else signed in to a Microsoft Office product, it could be Teams but it could also be Word, Excel etc. with either a workplace or school account.

During this process, the user is prompted to allow their organisation to manage their device or just allow sign into apps only. This effectively locks the Office product including Teams to this account no matter which option is chosen and policies relating to that workplace or school account get applied leading to this message when you try to use a personal account.

You can try two methods, one which tries to break the link in Teams only or one that completely breaks the link in all office products. Note I only have instructions for Windows.

Method 1:
Quit Teams by right-clicking the icon in the notification area and choosing quit.
Go to %appdata%\Microsoft and delete the Teams folder
Go to 'Credential Manager' -> 'Windows Credentials' and remove any reference to Teams. You may see an entry/entries with 'msteams'. If there are none, continue on.
Relaunch Teams and it may prompt you to sign in again.
If it doesn't, and logs in automatically, you can try using the Sign-out option but I've had the application hang.
If it fails you move to method 2.

Method 2:
Note that this may log you out of Office products including Outlook accounts
Quit Teams by right-clicking the icon in the notification area and choosing quit.
Go to %appdata%\Microsoft and delete the Teams folder
Go to 'Settings' -> 'Accounts' -> 'Email & accounts'
You may see your personal account there but also a 'Work or School account'
If so click 'Access work or school' on the left, click the work or school account and remove it.
Go back to 'Email & accounts' to verify the account is gone.
Relaunch Teams and it should default to using your personal account or prompt for sign in.

Basically despite Microsofts claims, their Office suite of products isn't ready for a multi-account setup. They design them so you have a pc that works best when one account is used be it personal, workplace or school. If you try account switching, the products get confused.

Note that this is (slightly) different to user log ins in Windows. You can have multiple different people using the same pc with their own sign in account, it's just the application accounts under a single login.

So you can Jane Bloggs and Joe Bloggs use the same pc but you can't have Joe Bloggs use a pc with his login and under that login have him use or and with Teams. It works fine initially but then you get this issue.
If all of the given excuses were really the case. Then why can I not sign into Teams on my personal phone using my personal @gmail ID ??? Why would I get the same error ???
A) This is my personal phone
B) This is my personal ID