"Due to org policy, you can't use (Gmail) with Teams on this device. Contact your admin"

Copper Contributor

This error pops up whenever I try to open the Microsoft Teams app with my Gmail accounts. I've tried with both of my Gmail accounts and it still gave me the same error, even changing the privacy settings to see if it works. Tried it on my school account (not Gmail) and the app works fine. Any suggestions? 

Screen Shot 2021-01-26 at 8.08.18 AM.png

22 Replies
Is this a company owned computer! They might have restricted log ins to other tenants:

In this case you can use another device or try use the web client


@adam deltinger It's on my personal laptop. I've tried on Chrome and Safari but they direct me to the desktop app and it still gives me the same error. The Gmail account works perfectly on the phone app though. 

 I'm in the same situation.

I'm not in an organisation, and I'm using a my own email address which is forwarded to Gmail


Frustratingly I get the same message and it tells me to contact the administrator which is me..



I am facing the same issue, exactly the same and i have important meeting tomorrow meeting!!!
best response confirmed by ThereseSolimeno (Microsoft)

@aotaibi001 As Adam said this could be due to a policy set by an admin, this is a direct link to the info 


You can always use the web client and if necessary you don't even have to sign in to participate in a teams meeting 


For the record I heard about this issue from another member yesterday as well and he was sure he hadn't set any restriction as he was the admin. 

@ChristianBergstrom Is there any way to solve this problem other than using teams on the web? I'm trying for a long time, it's showing the same error every day. This is my personal pc.

Hello, you better reach out to your IT admin as even though it's a personal computer it could be Azure AD registered. Meaning the device has been added to your org. and your organizations policies can be applied.

@ChristianBergstrom I have this problem on my private laptop which has never been part of any network other than our own home network our NAS, PC's, smartphones and tablets

Don’t have to be part of another network to be added to your org. Azure AD. If you’ve ever used your work account on your private computer it can very well be part of your org. Not saying it is.

@ChristianBergstrom This is highly unlikely since this machine came from the store like this (out of the box) and the network at my husband's office is only populated with Linux desktops and where everyone has a strong distaste for anything Microsoft... and I'm starting to understand why this is, with nonsense like this.

I can assure you they don't use azure, since they work with AWS and GCC only.

Even if it is hooked up to some azure BS, how do I get rid of that? My daughter had to use teams for school; did that lock this all up like this?!?

If it is it would be here (you'd disconnect). Why don't you use Teams on the web? If it isn't located under the account settings try reinstalling Teams.

Hi there. Same issue, private computer, new desktop with no company-owned software or accounts signed in. 



@YoukaKitano   exactly the same error... I wish TEAMS would get a team of people who actually know what they are doing.  Still waiting on the download folder, although I don't need it anymore.  School is finished but somehow I'm still locked out of my OWN COMPUTER with teams.  it still says I need to contact the admin from our school, which has nothing to do with my computer and can't really do anything about this problem.  


My school account doesn't even exist anymore since we graduated, but even reinstalling teams does not make any difference.  Is reformatting really the only solution to solve TEAMS???? Come on guys, fix your software!  Online with Chrome I can log in with my gmail account, but the software gives this exact same issue.  


How can some institution limit my access on MY computer without ever having admin rights???? They only had rights on their own server when I logged in.


but looking at the amount of people that have this issue and how many MONTHS this has been going on, it seems that the issue is similar to Bill Gates his marriage... can't be fixed.   Guess is back to Zoom...

@DezeureSam I understand the frustration, it's a mess sometimes with mixed credentials on a device.


As previously mentioned this is - usually - happening because of a policy set by an admin. This can also be configured on a personal device if you have ever used your work/school account on that device. In that case you need to disconnect the work/school account as shown in the image above (W10 account settings) to have the device removed from the org. and also clear some cached objects.


Some are certain they have never signed in with a work/school account, they say it's a personal device only and still have this issue. Then I would also suggest to follow the steps detailed here to remove cache and any saved credentials Due to org policy, you can’t use with Teams on - Microsoft Community


This is a really good script to reset the Teams autostart settings, just copy it, start PowerShell and paste it and hit enter PowerShell script sample - Reset the autostart setting in Teams - Microsoft Teams | Microsoft Docs For what it's worth it has helped me several times.