Questions discovered during Skype for Business to Teams migration

Occasional Contributor

Good morning,


We are in the process of moving from Skype for Business (SFB) to Teams.  Currently, we have a handful of users who are "Teams Only" while everybody else is set to "Islands."  


First Question: As a Teams Only person, I can see in my conversation history the users who I have chatted with using S4B.  However, there doesn't seem to be any way for me to initiate a conversation with them using their Teams account.  The only way I was able to resolve this was for the user, from Teams, to initiate a conversation with me.  Now I can see two conversations with them one with the Skype logo on the right and the other without.  My TD;DR question: is there a way for me to specify a Teams account over the Skype account from a Teams Only profile to an Islands profile?


Second Question: Is there any way to add a shared calendar to a Teams site?  

10 Replies
1. Usually I see this mistake usually people try to use the search bar at the top of Teams to initiate chats. Please make sure you are using the New Chat icon to the left of the search bar, this usually will bring up people from the directory. The search bar is only going to bring up recent chats etc.

2. Currently there is no Group calendar support, it's something Microsoft is working on / looking at from uservoice. However alternative solutions can be to use a SharePoint calendar on the underlying SharePoint site of the team, and then use website tab to serve up the calendar. You can use the &dlg=1 at the end of the URL to the calendar list view and it will trim off the excess page and only display the calendar in the tab view.

Hi, Chris.  Thank you for the quick reply.  


I'll look into the suggestion for the calendar on question 2.  


For question 1, there are people in my conversation history that I've previously chatted with only the Skype icon, and when I click the new chat icon, put in that person's name and start the new conversation, it'll show me the "You're starting a new conversation" screen with additional options below the chat prompt (for file uploads, emojis, etc.), but with others it'll resume Skype conversation in my recent list, without an option to put that conversation into Teams.  


On a related note, is there a way to purge conversations from your chat history, or will those live on forever?  Or to start a new conversation that doesn't include the last message with that person.  Sometimes it's nice to have a clean slate, like a new email conversation with that same person. 


I appreciate your help.  Thank you.  

Currently there is not, you pretty much are stuck with the history, there are some user voice entries where some people are asking for ways to remove this, but I'm pretty sure Microsoft just declined the request.

As for the Skype conversation, you might try using their e-mail and seeing if both show up in the list to select? If not another option and the first thing I did was go into admin center and turn off the Skype option via policy so that you can't message anyone in Skype from Teams, that should keep that from happening. You can do this in the settings > notifications tab at the bottom as well.

Also it's been awhile, but you could try clicking the ... next to the skype conversation in your recent list to see if hiding / removing here helps with a new chat, but just a couple things you can try.

UPDATE: Scratch that - it just started a group conversation and required another person to be added before the message could be sent.  


I tried hiding the conversation, and start a new one, but it just pulled the Skype conversation back into play.  HOWEVER, I was able to find a solution.  (Update: it didn't work as I expected) If I start a new chat and click the down arrow on the right of the TO, it'll open an option to add a "Group Name" as well, and that forces the conversation into the richer conversation option, it seems.  Just wanted to pass that long.  Images included:








Hi @Troy Benedict, The coexistence mode only effects the messages that you receive, it generally has no effect on where messages you send to other people end up. If you want a users messages to arrive in Skype from Teams, they need to be set in SfB Only mode.


Islands mode creates much confusion, it basically turns off interop in most scenarios.

Thanks @Steven Collier.  I was wondering if I may disable the Islands for normal users.  Will that still allow them to use Teams, though?  We have been using it for file collaboration on some on some Teams sites.    

That's where Skype for Business with Teams mode comes into play, it essentially turns off the chat tab in Teams, or it's supposed too. Just not sure it's implemented yet. Do you know Steven?

On "Normal Users" do they still use Skype? For now it will work, but at some point having your user set to Skype only will eventually lock Teams out, similar to now when you set someone to Teams Only mode it disables their Skype for Business client.

So what you can do is go in via powershell and set those users to SfBWithTeamsCollab which is basically setting them as Skype Only users for now, and when the switch happens on the backend they will still be able to use Teams for Channels / Collab.

Reference article:

Powershell for setting a user to this mode since you can't via UI:
Grant-CsTeamsUpgradePolicy -PolicyName SfBWithTeamsCollab -Identity


But do note also when the backend update happens, their Teams Chat tab will go away, and at that point you'll have to make a decision on where you want your chat to happen with Teams Only or "SkypewithTeamsCollab". 

Yup, what Chris said. At this point you could set them to SfB only, the Teams client doesn't really do anything only the back end that deals with routing knows. If you switch to SfBWithTeamsCollab now via powershell the experience would be the same today, and would keep working when they introduce the new modes for Teams later.

@Chris Webb @Steven Collier 


I'm going to make some of the suggested changes and see if that helps make it a bit less confusing. :)  I appreciate you both taking time to help me.  Thanks again!