SOLVED

Proximity Join not working anymore with collaboration bars

%3CLINGO-SUB%20id%3D%22lingo-sub-2068281%22%20slang%3D%22de-DE%22%3EProximity%20Join%20not%20working%20anymore%20with%20collaboration%20bars%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2068281%22%20slang%3D%22de-DE%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3EWe%20have%20been%20testing%20%2F%20piloting%20the%20Poly%20Collaboration%20Bars%20X30%20%26amp%3B%2050%20for%20months%20and%20now%20rolled%20out%20the%20devices%20in%20over%2080%20(!)%20meeting%20rooms%20over%20the%20last%202%20weeks.%3CBR%20%2F%3ESince%20last%20week%2C%20all%20of%20a%20sudden%20the%20proximity%20join%20feature%20does%20not%20work%20anymore.%20After%20trouble%20shooting%2C%20we%20observed%20that%20it%20is%20also%20not%20working%20on%20collaboration%20bars%20of%20yealink%2C%20so%20there%20seems%20to%20be%20a%20problem%20with%20the%20teams%20client%20%2F%20cloud...%3CBR%20%2F%3EAny%20ideas%2C%20resp.%20did%20you%20experience%20the%20same%20issue%3F!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2068281%22%20slang%3D%22de-DE%22%3E%3CLINGO-LABEL%3ECommunity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2069868%22%20slang%3D%22en-US%22%3ERe%3A%20Proximity%20Join%20not%20working%20anymore%20with%20collaboration%20bars%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2069868%22%20slang%3D%22en-US%22%3E%3CP%3EI%20guess%20this%20been%20working%20before%20with%20the%20same%20devices%3F%20And%20you%20have%20checked%20that%20you%20have%20bluetooth%20activated%20on%20your%20laptop%20and%20that%20you%20are%20using%2064-bit%20Teams%20client%3F%20Have%20you%20tested%20with%20different%20laptops%20too%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2079969%22%20slang%3D%22en-US%22%3ERe%3A%20Proximity%20Join%20not%20working%20anymore%20with%20collaboration%20bars%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2079969%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F223388%22%20target%3D%22_blank%22%3E%40Ilya%20Bukshteyn%3C%2FA%3E%26nbsp%3BDo%20you%20know%20if%20this%20is%20a%20known%20problem%20that%20proximity%20join%20stopped%20working%20on%20collaboration%20bars%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2093089%22%20slang%3D%22en-US%22%3ERe%3A%20Proximity%20Join%20not%20working%20anymore%20with%20collaboration%20bars%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2093089%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F173714%22%20target%3D%22_blank%22%3E%40Pavel%20Yurevich%3C%2FA%3E%26nbsp%3B%20I'm%20a%20coworker%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F931992%22%20target%3D%22_blank%22%3E%40BroGale%3C%2FA%3E%26nbsp%3Band%20can%20share%20some%20additional%20details%20of%20this%20problem.%20We%20deployed%20around%2060%20collaboration%20bars%20and%2030%20Teams%20Rooms%20of%20different%20vendors%2C%20and%20our%20users%20relying%20heavily%20on%20the%20proximity%20join%20feature%20in%20all%20of%20these%20rooms.%20It%20stopped%20working%20on%20all%20computers%20on%20all%20MTRs%20and%20Collab%20Bars%20at%20the%20same%20time.%20The%20issue%20also%20happens%20if%20i%20use%20a%20non-corporate-pc%20(bring%20your%20own%20laptop)%20and%20on%20the%20mobile%20apps%20on%20android%20and%20iphone.%20Bluetooth%20is%20clearly%20working%20because%20it%20detects%20the%20room%20if%20you%20search%20manually%20a%20room%20device%3A%3CBR%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22ProximityJoin-Bluetooth.png%22%20style%3D%22width%3A%20568px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F249077i3E076C1053F87481%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22ProximityJoin-Bluetooth.png%22%20alt%3D%22ProximityJoin-Bluetooth.png%22%20%2F%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EHowever%2C%20when%20i%20join%20a%20Live%20Event%20in%20Teams%2C%20proximity%20join%20is%20working!%3C%2FSTRONG%3E%20%3CSTRONG%3EIt%20also%20works%20when%20i%20disable%20this%20setting%20in%20teams%3A%3C%2FSTRONG%3E%20%3CEM%3E%22Turn%20on%20new%20meeting%20experience%20(New%20meetings%20and%20calls%20will%20open%20in%20separate%20windows.%20Requires%20restarting%20Teams.)%22%26nbsp%3B%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22ProximityJoin-LiveEvent.png%22%20style%3D%22width%3A%20816px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F249074i036D2E072EAA515A%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22ProximityJoin-LiveEvent.png%22%20alt%3D%22Live%20Event%20Producer%20Join%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3ELive%20Event%20Producer%20Join%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FEM%3E%3C%2FP%3E%3CP%3EI%20think%20Live%20events%20are%20working%20because%20they%20are%20still%20using%20the%20old%20meeting%20join%20appearance.%3C%2FP%3E%3CP%3EI%20will%20send%20you%20a%20full%20list%20of%20all%20MTRs%20and%20Collaboration%20Bars%20and%20the%20MS%20Case%20number%20of%20our%20open%20Case.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETested%20with%20Teams%20Desktop%20App%20(64bit)%3A%3C%2FP%3E%3CP%3E%3CSPAN%3E1.3.00.30866%20(64-Bit)%20and%201.3.00.33674%20(64-Bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EYealink%20VC210%3A%3CBR%20%2F%3E%3CEM%3ETeams%20Admin%20Agent1.0.0.202006290446.product%3C%2FEM%3E%3CBR%20%2F%3E%3CEM%3EFirmware118.15.0.42%3C%2FEM%3E%3CBR%20%2F%3E%3CEM%3ECompany%20Portal%20App5.0.4927.0%3C%2FEM%3E%3CBR%20%2F%3E%3CEM%3EOEM%20Agent%20App1.15.0.20110309%3C%2FEM%3E%3CBR%20%2F%3E%3CEM%3ETeams%20App1449%2F1.0.96.2020102101%3C%2FEM%3E%3CBR%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPoly%20Studio%20X50%20and%20X30%3A%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CEM%3ETeams%20Admin%20Agent1.0.0.202006290446.product%3CBR%20%2F%3EFirmware3.2.3.280012%3CBR%20%2F%3ECompany%20Portal%20App5.0.4927.0%3CBR%20%2F%3EOEM%20Agent%20App1.0%3CBR%20%2F%3ETeams%20App1449%2F1.0.96.2020102101%3C%2FEM%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2093328%22%20slang%3D%22en-US%22%3ERe%3A%20Proximity%20Join%20not%20working%20anymore%20with%20collaboration%20bars%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2093328%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F44149%22%20target%3D%22_blank%22%3E%40Freddy%20Mulder%3C%2FA%3E%26nbsp%3BNo%2C%20it%20happens%20to%20all%20devices.%20Corporate%20computer%2C%20private%20computers%20and%20mobile%20devices%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hi all,

We have been testing / piloting the Poly Collaboration Bars X30 & 50 for months and now rolled out the devices in over 80 (!) meeting rooms over the last 2 weeks.
Since last week, all of a sudden the proximity join feature does not work anymore. After trouble shooting, we observed that it is also not working on collaboration bars of yealink, thus there seems to be a problem with the teams client / cloud...
Any ideas, resp. did you experience the same issue?!

19 Replies

I guess this been working before with the same devices? And you have checked that you have bluetooth activated on your laptop and that you are using 64-bit Teams client? Have you tested with different laptops too?

@BroGale 
Hi, I have tested it with a Poly Studio X30 and a mobile phone. But I do not experience any problems at this point.

Used versions.
Collaboration bar: 

Teams Version 1449/1.0.96.2020102101


Mobile app:
Microsoft Teams Version 2.2.1

@Ilya Bukshteyn Do you know if this is a known problem that proximity join stopped working on collaboration bars?

@BroGale This is not a known issue and we test proximity join very extensively with each firmware update. Regardless, we are committed to supporting proximity join and I am sure we can remedy this issue very quickly.  Could you provide some more information: model/make of the collaboration bars, the Teams version they are running, firmware version, and what device you are using to test proximity join (mobile/desktop)?  Feel free to message me directly and I'll be able to personally look into this issue. 

Hi @Pavel Yurevich  I'm a coworker of @BroGale and i can share some additional details of this problem. We deployed around 60 collaboration bars and 30 Teams Rooms of different vendors, and our users relying heavily on the proximity join feature in all of these rooms. It stopped working on all computers on all MTRs and Collab Bars at the same time. The issue also happens if i use a non-corporate-pc (bring your own laptop) and on the mobile apps on android and iphone. Bluetooth is clearly working because it detects the room if you search manually a room device:
ProximityJoin-Bluetooth.png

 

However, when i join a Live Event in Teams, proximity join is working! It also works when i disable this setting in teams: "Turn on new meeting experience (New meetings and calls will open in separate windows. Requires restarting Teams.)" 

Live Event Producer JoinLive Event Producer Join

I think Live events are working because they are still using the old meeting join appearance.

I will send you a full list of all MTRs and Collaboration Bars and the MS Case number of our open Case.

 

Tested with Teams Desktop App (64bit):

1.3.00.30866 (64-Bit) and 1.3.00.33674 (64-Bit)

 

Yealink VC210:
Teams Admin Agent1.0.0.202006290446.product
Firmware118.15.0.42
Company Portal App5.0.4927.0
OEM Agent App1.15.0.20110309
Teams App1449/1.0.96.2020102101

 

Poly Studio X50 and X30:

Teams Admin Agent1.0.0.202006290446.product
Firmware3.2.3.280012
Company Portal App5.0.4927.0
OEM Agent App1.0
Teams App1449/1.0.96.2020102101

 

 

@Andreas-N 
If I understand it correctly it only applies to PC's and not mobile devices?

Did not read it well also mobile devices. 

@Freddy Mulder No, it happens to all devices. Corporate computer, private computers and mobile devices

@Andreas-N Thanks for detailing the issue. A few questions:

  1. If I understand correctly, the problem is not the Bluetooth beaconing of meeting room devices, but the discovery through the new pre-join experience, correct? If both Android and Windows devices have been affected, likely the new pre-join experience is not working properly. 
  2. To my knowledge, mobile team has not updated the pre-join experience for a number of quarters. Could you elaborate on what has changed in your experience?

I'll chat with folks who own desktop pre-join and ask them to look into this issue and follow up with the mobile team once I get more details. 

 

 

 

 

Hi @Pavel Yurevich 

1. Yes, correct

2. we made additional test with the mobile client, the automatic nearby room discovery works again on the mobile client! In our last tests, the mobile app was crashing (android and iphone) when you wanted to join a room, this seems to be resolved!

 

However, the problem with the desktop app is still present. Here you can see the different behavior with the old and the new meeting pre-join experience (tested on the same PC with the same meeting):

ProximityJoin-old-and-new-exp.jpg

Picture on the left: old meeting pre-join experience, the room is automatically discovered

Picture on the right: new meeting pre-join experience, the automatic room discovery does not work. But it will find the nearby room with Bluetooth beaconing if you search it manually:

ProximityJoin-Bluetooth.png

 

Tested with these desktop client versions:

1.3.00.19173 (64-Bit)

1.3.00.30866 (64-Bit)

1.3.00.33674 (64-Bit)

 

Hi @Andreas-N and @Pavel Yurevich 


On the mobile devices I do not have any problems also, it seems to work as it should.

It looks that the first picture is after a while when you clicked to join, using the old experience.

This is how it looks at the first time. 


Join.PNG




When I wait a small amount of time the beacon of the room is picked up. And shown as a option.

other join.PNG



When using the new pre-join this is what happens here.
The desktop client was first not able to find the room via its beacon, but after using the mobile (with the same account) it also showed up on the desktop App.
And indeed only when you click on search the room shows up.

Room audio.PNG

 

 

 

 

 

 

 



Also when using the old pre-join and you click on search you get the different Room lists that are present in the Tenant. The Search for a room in the new pre-join gives different option to users where you expect to same options.

@Freddy Mulder thanks for the update! This is a printscreen i took at Friday, Jan 15th 2021 when the proximity join feature worked correctly with the new meeting join experience:

ProximityJoin-Working.jpg

The client detected the room and automatically switched to the suggested room audio option.

It stopped working a few days after this date, around Tuesday, Jan 19th 2021

@Andreas-N and @Freddy Mulder, thanks a lot for even more information. The issue is clear to me now. I am working with folks internally who own this experience and we'll update you soon on the resolution. Hang on! :smile: 

Just a quick update, so you know that we haven't forgotten about you :) We are still trying to find the exact issue. It seems that it only affects some of the Desktop devices because I can reproduce the issue only on a few devices. Will keep you updated.  

@Pavel Yurevich Thanks for the update, good to hear than you can reproduce the error (at least on a few devices). The response from the o365 case support: "this problem will be fixed in the next desktop and collaboration bar app version in approximately 4-5 weeks" :suprised:

@Pavel Yurevich I think I'm having the same issue with a Logitech Tap MTR. Proximity Join works on mobile app(iPhone) but not on my laptop(Surface Book 2). If I look for the room, I see the indicator that its finding it but no prompt to join. Teams Version is 1.4.00.2781 64bit

Jared_Langendorfer_0-1612452718122.png

 

@Jared_Langendorfer @Andreas-N, quick update here. There is no need for collaboration bar or MTR to update the apps, this is purely a desktop app issue. Based on our testing and conversations with the desktop team, the issue has been identified and deployed into the internal rings (I tested it and it works). I am trying to get more concrete ETA when it will hit production. 

@Pavel Yurevich  Its good to hear that is is identified and that the issue is addressed.

Best Response confirmed by Pavel Yurevich (Microsoft)
Solution

@Pavel Yurevich Just received the latest teams client update today, problem solved! Thanks alot Pavel!
Desktop App Update: Microsoft Teams Version 1.4.00.2879 (64-bit). It was last updated on 2/15/21.

@Andreas-N @Pavel Yurevich
The Collaboration bar in Proximity is directly shown in the Room Audio (suggested).
This indicate that the problem should be solved now.