Production Capabilities no longer supported (NDI) on Apple Silicon?

Copper Contributor



Have Production Capabilities (and NDI support in particular) been removed from the latest version of Teams when running on Apple Silicon?


Teams just updated itself to version and on my Apple Silicon machines I get the error "Production Capabilities is not supported" when I attempt to enable NDI support (see screen cap).  This used to work fine (presumably via Rosetta).

Screenshot 2022-08-05 at 17.41.42.png

Intel Macs have also upgraded to version, do not seem to have the problem, and can enable NDI as normal.


Anyone else seeing this, does anyone have any ideas?

16 Replies

Hey, we had this same issue and found the solution that worked for now was to uninstall Teams, clear the cache on the Mac and reinstall.


Unfortunately that appears to reinstall (the intel build), as soon as it auto-updates (to then Production Capabilities becomes unavailable once more.


I've found a work around, I've opened Teams in Rosetta and it worked again. But it's probably not the best solution because it will will probably be less efficient .



If I downgrade to version 1.4 I can toggle NDI without issue... If I use version 1.5 then the only way I can toggle NDI is to launch it using Rosetta.
I've been seeing this for a while as well. Tried resetting the cache, and uninstalling/reinstalling as was mentioned and that didn't work for me either. Would love some additional insight as well as to if I have something wrong on my end or if this is currently broken in Teams for mac.
Hi all,
Any news on this? The suddenly missing NDI support for M1 sure did not make my day recently. What a mess. Hopefully Microsoft will adress this shortly. Our studio is built with NDI , Mac´s and tricaster - and not beeing able to no longer use NDI within teams is a gamestopper.

@Pernille-Eskebo - please let us know what your time scoop is, if any!

@Ben_sync, no unfortunately not - besides using a Pc doe....



@samuelhaugum2023 thanks for your answer, I opened a ticket at the support teams... I'll let you updated ;)

@Ben_sync any updates. It seems I have the same issue on a M1 Mac mini. I can't activate the NDI features. All is working fine on a PC.  


Logs says: 

Tue Mar 28 2023 22:31:13 GMT+0300 (Eastern European Summer Time) <878> -- info -- NdiBundleInstaller::download - starting 

Tue Mar 28 2023 22:31:13 GMT+0300 (Eastern European Summer Time) <878> -- info -- NdiBundleInstaller::setState - Idle -> Busy 

Tue Mar 28 2023 22:31:13 GMT+0300 (Eastern European Summer Time) <878> -- error -- NdiBundleInstaller::executeStep - Failed Error: FILE_DOWNLOAD_FAILURE 

Tue Mar 28 2023 22:31:13 GMT+0300 (Eastern European Summer Time) <878> -- info -- NdiBundleInstaller::setState - Busy -> Faulted 

Tue Mar 28 2023 22:31:13 GMT+0300 (Eastern European Summer Time) <878> -- error -- PluginDownloader::downloadAsync - Failed to download and install ndi bundle due to reason=FILE_DOWNLOAD_FAILURE, details=Message: net request failed with status - 404 

Tue Mar 28 2023 22:31:13 GMT+0300 (Eastern European Summer Time) <878> -- event -- eventpdclevel: 2, bundleInstaller: ndi, slimcoreVersion: 2023.05.01.18, reason: FILE_DOWNLOAD_FAILURE, reasonCMD: FILE_DOWNLOAD_FAILURE, details: Message: net request failed with status - 404, status: failure, scenario: ee542f70-b729-48e9-8c8e-f63ec90b3e07, scenarioName: desktop_ndi_download, name: desktop_ndi_download, step: stop, sequence: 1, delta: 217, scenarioDelta: 217, elapsed: 47028, stepDelta: 217, Scenario.Mode: 1, AppInfo.Language: en-gb, complianceEnvironmentType: 0, isDataCategorizationEnabled: true, userpdclevel: 0, processMemory: 24003520, freeMemory: 3354787840, clientType: desktop, AppInfo.ClientType: desktop, batterylevel: 1, pluggedin: true, Window.Focus: foreground, windowIsVisible: true, Window.Status: maximized, UserInfo.TimeZone: +03:00, vdiMode: 0, previousVDIOptimizationValue: none, Scenario.Name: desktop_ndi_download, Scenario.Step: stop, Scenario.Status: failure,  


Error Message in Teams

There was a problem downloading the file
Try turning Production Capabilities on again.

Anything? Is this even addressed, nothing on the roadmap for ages, experimental builds or even nightlies - Nothing.

Also having this issue, but only on an M1 Mac Studio. M2 MacBook Pro working fine...
...because my M2 was running the Intel version. NDI is still broken in the Apple Silicon version
Has there been any progress on this, its been almost a year now and still having to use rosetta to run intel version of teams to get production capabilities for NDI. This is not ideal considering it runs so slow!

@Luke_Geach I’m working through it with Microsoft support currently. The least we can do is raise this as an issue since it’s not documented anywhere. The broadcasting feature page on the Teams site states Hardware-out doesn’t work on M1-based Macs, but nothing stating NDI-out is no longer supported. 

@spencerkm Great! We need to be pushing from all sides as this is just not acceptable.