Problems Joining meetings, keeps asking for phone permission on android tablet

Brass Contributor

Hello, i've got a Galaxy tab A 8" (2019) and was using it with teams for my kid, now it doesn't let my kid to join his school clases asking for a phone permission and the permision is already granted, ive already cleared cache, cleared all data an re-login, i've even reset to factory setings the tablet with no luck.


I don't know what else to try to make it work, i've tried with other device (amazon fire tablet, and other samsung tab A6 2016) and works ok.


Any idea what else to do?


Kind Regards

61 Replies

I exited the beta program, waited a couple of hours (2) and I installed the "stable" version. Which works. I believe you need to wait a little more to be removed from beta than what Play Store says...

Pixel 4xl, same issue. Exiting the beta program did not fix the issue either

Same issue on Samsung S20, was on beta, after leaving no solution.

This has worked for me:

--> left Beta

--> uninstall 

--> waited for 2 hours

--> installed the non beta verson

Working again 



No dice. Still having rhe same problem. Microsoft really messed something up. 

I downgraded to the teams that came out in early September. It works now. Microsoft needs to fix this.
I'm having the same issue on my Google pixel 6 pro, very frustrating that Microsoft is not acknowledging this.
Happening also to a bunch of my coworkers with android

Now it is November 7, can someone from Microsoft please confirm that you work to solve this problem? For me it still doesnt work on my Samsung Android mobile and that is very frustrating...

Having the same problem on version: 1416/ on MIUI 13.0.6 (Android version:12 SKQ1.211006.001


I have tried clear cache and all data, same issue :sad:

Same problem on my S20 Ultra it worked fine in beta as well as non-beta till the end of october. Since then no audio conversation is possible. Very annoying...
I did similar and it worked for me:

1. Clear cache AND storage (probably unnecessary)
2. Uninstall
3. Leave beta
4. I waited roughly 12hrs
5. Reinstalled latest standard release from Play Store
6. Fixed (Phone permission not even needed when working normally)

Clearly this was a beta issue and leaving a beta program doesn't take immediate effect. Lesson learnt.

Upon receiving the request for permission - press cancel. the call should work for you. simple bug. it'll work for pre scheduled meetings only (in some cases). I wish i could help you more :)

Sorry, doesnt help me... :( It is not just about answer a call. Its about Joining a scheduled meeting or use Meet Now. Every interaction like this still bring up the question about Permissions...

@levisnet Cancel does not work. It goes into a new screen and hangs there.

@kurzs  go to playstore and remove urself from beta testers. this issue is in Beta version sent you ur playstore and installed. Once you will remove urself and then uninstall the downloaded version. In next 5-10 min after in playstore u will get older version - public version and the issue will be resolved. 

@Xperia_Five4  ok, let me wait for tomorrow, hopefully your right :crossed_fingers:

When will the next BETA version of the Teams App come and actually fix the issue? Soon I hope...

@Rupesh2210  Did not fix teh issue completely. Still there however I was able to pick up a transferred call. Still can not imitate a new call. 

It worked. As suggested, I removed myself from beta program at the Google Play Store application but reinstalled "just too fast", it didn't worked.

But I read about waiting 12h, so i've waited just 1h or 2h, reinstalled and I've recovered again the ability to connect to a Microsoft Teams Meeting again from my Android device. I confirm symptoms on my side (Always asks for phone permission with that beta version, unable to join to any meetings).