Problems Joining meetings, keeps asking for phone permission on android tablet

Brass Contributor

Hello, i've got a Galaxy tab A 8" (2019) and was using it with teams for my kid, now it doesn't let my kid to join his school clases asking for a phone permission and the permision is already granted, ive already cleared cache, cleared all data an re-login, i've even reset to factory setings the tablet with no luck.


I don't know what else to try to make it work, i've tried with other device (amazon fire tablet, and other samsung tab A6 2016) and works ok.


Any idea what else to do?


Kind Regards

61 Replies
I had success following the same path but only waited one or two. Thanks for sharing your thoughts, back on track now.

This resolved the issue for me! Thank you for the suggestion!! 

Started to face this issue on 7th November followed steps but still facing issue any other workarounds?

Good morning @saafee,


I have the same problem with my Google Pixel 7 Pro.

I ran the same solution but no change.


Mobile phone: Google Pixel 7 Pro with Android 13

Installed Version: 1416/

@kurzs , same issue with me as well. I use Google pixel 6 and using teams on it i am able to chat/receive a chat but not make/receive a call even though the phone permission is enabled.
Kindly look into this.


uninstall Teams.

leave the beta program.

wait 6 hrs. 

reinstall teams android 


good luck

It's just incredible how Microsoft is not doing anything to fix this making his communication tool reliability getting heavily damaged.


We've 6 users with this issue, just getting them out of the Beta and we'll try reinstalling the app in a few hours

@kurzs @Simoska @Supriya950 @sb_hog @Rcb21 @saafee @ChrisSummers92 @CraigSalazar @LP4sys @aswinrj @ElectroSkrill @GarrettOliveros @BjaOlsen @smiller2421 @narendrn @Xperia_Five4 @ThoVer @Geryy @BeziDebela @mtanenhaus 

Solution : Problems Joining meetings, keeps asking for phone permission on android


step 1 : Clear all data and cache from teams storage usage (from settings)

step 2 : Then Uninstall teams from ur phone

step 3 : Reinstall teams from Microsoft official website ( 




many thanks. Your solultion works for me! Now Teams have no problems.

I had the same issue. I just unenrolled out of beta and uninstalled beta. Waited 10min and then installed the public normal version. Now it's working again :D

Really MS. Been over a week and not resolved Beta release yet????? At least remove the problem one so it stops updating when we roll back to a stable version.


This doesnt help anyone using Teams through a work profile, many of whom are.

Root cause is the beta release. Uninstall, leave the beta and allow the app to update to current stable version after allowing the servers time to log exiting the beta program.

The lesson here is dont use beta releases for work app that you rely on. I've now left the beta programs for all my work profile apps.

Don't expect MS to act quickly on a beta issue when the risks are made clear and joining a beta program is a choice. If you're upset over the issue, uninstall the beta app.

I have the same problem as @kurzs since November 1st (or something like that).

I have reset all the data, I have reinstalled the application.

All permissions are granted and it still won't work on a MOTOROLA G7 PLUS or a LENOVO YOGA SMART TAB.

It's very important to me, I use the app with my work account everyday and I need to connect from differents devices in differents scenarios of my activities.

Do you know if this is an officially acknowledged bug? I've reported this in app, but it doesn't seem to be any other place to report.
My Teams is managed by company, installed from a work profile on Android. There is no way to workaround, but wait for official fix and update

Hi @AriochKain I've reported the incident in then same way as you.

I use same type of account.

There are other mates at the company that haven't installed the last version and it´s working properly.

I'm wating for a response from Microsoft.

If the they receive a lot of complains I think that they will fix the bug SOON (I hope) in a new version.


This issue is with latest app version.

Use earlier app version. 

Microsoft have published a new version of Teams app that should solve this, version 1416/ MS have sent the updated app to Google app store so it will be available in the next few days.

Beta app might already been fixed, have not tested it.

@kurzs I just downloaded new beta version from October 15th and it works normally now. So MS fix is in affect.