Problems Joining meetings, keeps asking for phone permission on android tablet

Brass Contributor

Hello, i've got a Galaxy tab A 8" (2019) and was using it with teams for my kid, now it doesn't let my kid to join his school clases asking for a phone permission and the permision is already granted, ive already cleared cache, cleared all data an re-login, i've even reset to factory setings the tablet with no luck.


I don't know what else to try to make it work, i've tried with other device (amazon fire tablet, and other samsung tab A6 2016) and works ok.


Any idea what else to do?


Kind Regards

61 Replies

[UPDATE: for me it was because I was using the beta version....which has this bug...]

Yeah, I see this too on my S21Ultra phone, but not on my Android tablet.

Quite annoying as phone access shouldn't be required at all!


For what it's worth, here's the version that's working for me


Version: 1416/

Calling Version: 2022.34.01.8


Just got an update. This version also is working


Version: 1416/

Calling Version: 2022.38.01.3



I have this same problem on my Google Pixel 6. Started a few days ago with my work email account and providing Phone permission (which shouldn't be required) does not fix the issue. I was part of the developer program (beta program) for the Teams App so I left that program, uninstalled and reinstalled with no success. I have cleared all storage and reinstalled with no success. I am running Android OS 13 with October security update. Worked with my IT guy who has a Pixel 6 Pro running same OS version and he doesn't have the issue and does NOT have Phone Permission allowed. Very frustrating. Suggestions welcome and appreciated.

Same problem on my Xiaomi POCO F3. Not a member of beta program anymore so I really don't know what's going on

I am also facing the same problem in android phone - Google pixel 6a. Could not able to join meetings using teams. It asks for phone permission and nearby devices which is completely unecessary for the app to use that set of permissions. But i gave that, still no luck. It not allowing to join the call in teams app in android even the permissions are provided. Kindly look into this. @kurzs 

Same problem on galaxy s20+
Had beta . Left it before redownloading but still having the same issue
Same problem for me. Pixel 7 Pro. Was in the beta, left program, cleared cache and storage, uninstalled, reinstalled. Issue still occurs.

Also getting reports of this, user is not in beta / developer - version is 1416/

Same issue on S20 FE, very inconvenient.


Working fine until yesterday.

Managed to get it to work again by installing an older version (Oct. 30th)




I'm having the same problem. Teams worked fine yesterday. You mentioned you downgraded to an older version of Teams. How did you do that?  Thank you. 

I downgraded too and it's working again. I downloaded from a third-party (although well known) website, I'm not sure if it's allowed to post the full link here but it was this one version that worked again:


(of course, replace the dot. Or just search for "teams apk" and it will probably show as the first result, and get the version from before 30-Oct)

Thank you for the reply. I'll give Microsoft a day to resolve this. If not I'll follow your instructions to downgrade.

Thanks again.

@LP4sys Thanks for the tip. I downgraded and my Pixel 6 is now working! Guess we will have to wait for the fix from MS.

Does Microsoft have a solution for this. I tried uninstalling, removing work profile and so many things....Just a waste of time.
I cannot downgrade as I have this app in my "work profile". What are the options?

Same issue here.


Brand new Xperia 5 IV on Android 12.


Can't make or receive calls or join a meeting - Teams prompts for Phone permissions which are already enabled.


Using Teams on work profile, so don't have the option to side load an older version.

I also have this exact same problem since the November 1st update (my current version is 1416/ with Calling version being 2022.40.01.7) on a Samsung Galaxy S20 FE 5G.


I just used the Send feedback option which can be found in Settings > Help and feedback > Send feedback to inform Microsoft of this problem. I think we should all do this in addition to this forum post.


In addition to the fact it's not working, it would be good for Microsoft to explain the reasons behind these extra permissions:

  • Nearby devices for use with a Bluetooth headset => it worked perfectly fine without this permission before, why is this now necessary?
  • Phone permission for joining an "over IP" meeting => why would it need permission to make direct phone calls?

Same here. Pixel 7 Pro. Only solution was manually downgrade the version.


I am also having the same issue. Tried leaving beta and installing older version, nothing works. Google Pixel 7 Pro. Used to work just fine.

@kurzs Tried beta and non-beta reinstalls to no avail. Then I did the beta install BUT before I opened it the first time I went in application settings and gave it all the permissions its suppose to have. Then I opened the app and it worked again. 

1 best response

Accepted Solutions
best response confirmed by StaceeFrane (Microsoft)
I've installed the version released on November 17 and it worked properly fortunately.
It's a good news after almost 15 days

View solution in original post