PowerApp launched from MS Teams - submit button "Clicks" but doesn't submit on some mobile devices

Occasional Visitor

Hello World, we have produced a PowerApps application that uses SharePoint, Power Automate and PowerApps to collect a record from the end user.

The goal with this app was to launch from within the MS Teams app, and have users tap the tab to launch the app, enter their information, and then tap a submit button, sending their form data via Power Automate to the SharePoint List.

The app works fine in desktop browsers. The app works variably in mobile device browsers seemingly version and hardware dependent.

The app’s most critical function does not seem to work on most of the mobile (iOS and Android) devices tested from when launched from Microsoft Teams.

Through many Advisory, Support and Power Platform support tickets, the PowerApps team is confident the app works, and the issue is within the MS Teams application. When working with Support, they seem to indicate this is an issue within the MS Teams app. There seems to be no way to reach the “Teams” team at Microsoft via support methods we’ve used.

We were told to submit feedback via the end user device, which we did 7+ times with no responses from the MS Teams team.

 

Here’s the exact problem:

When a user launches the app from the MS Teams channel tab, the app launches successfully. Some users are prompted to install “PowerApps” app. Some are not. When they enter their name on the first screen, they are brought to the 2nd screen, the data collection screen. There are 4 fields to enter data, Last 4 of SSN, the “Reporting week” end date, the “Cash tip” amount earned that week and today’s date.

each field has validation error messages if the user enters a data point incorrectly. Each field has some validation or formatting applied, that when all conditions are met, the “Disabled” submit button becomes “Enabled” and the user can tap to submit the form, ensuring complete data is collected from each report.

The issue comes up when the user (Not all, but most) taps the illuminated, enabled submit button. You can see the button change shade, acknowledging the user’s input, however, nothing happens.

When the app is working, the screen shows a thank you for your submission screen and a notification also pops up at top in green that the report was submitted successfully.

 

So, the app works from many devices (All desktop browsers tested, some mobile), however, very few at the clients actual site of operation are successful. We’ve tried removing and reinstalling teams

We’ve tried Wi-Fi/cellular

We’ve tried different models of iPhone and Android.

Anyone out there experience anything similar or can offer things to try?

The client requirement for this app is that it works from within teams for a unified end user experience that is easy to use.

0 Replies