Posting files show as insecure and can't open

Iron Contributor

When attaching files to a Teams post, the files get uploaded, but show as "insecure".  We cannot open/view them from the post.  However, we can see them normally under the "files" tab.  This is not consistent across teams.  Some Teams the attachments work fine, some Teams do not.  I've verified it does not matter if I'm owner or member of the group.  It does not seem to matter the file type (tried pdf, doc, jpg, etc), or if I've uploaded from the app or web portal.  


I have not seen any other posts about this, nor have I found any documentation on why a file would display as "insecure".....   

12 Replies


Seeing the same thing at my company recently.  Yellow triangle icon that says insecure next to the correct file name and extension.  Yet it's visible and accessible in the files tab.  Also seeing it in chats.  All file types including office docs.  No apparent pattern observed on when / why.

best response confirmed by Eric_H (Iron Contributor)

@BrettHafer I had an open ticket with Microsoft for over a week and they finally replied that it is a known issue.  They are a working on a back end fix but do not have an ETA.  Not the greatest reply, I know, but it's nice to know I'm not the only one, and that they are already working on resolving.  

We're seeing this issue too. Our workaround until it's fixed is to post a link to the file in the conversation. That works, even though the original attachement shows as "Insecure"

Did you get any information/solution from Microsoft?
We are having the same issue.

@Eric_H  At update on your case?

@BrettHafer  Seeing more and more of this here - not a lot of information as to the why/when.


@DaveS99 - sorry, no, I let them close the case.  I've dealt with them enough to know that an issue that "development" is working on, means it will be a while, and I'm not going to get any personalized updates.  I actually haven't seen the issue for about a month now.  Maybe open a ticket yourself - they might somehow prioritize fixing your tenant.  

@Eric_HI found that if I edit the posting when the attachments shows insecure, then click on the check mark to save the edit, the insecure status goes away.

@EMS-KIN1970 that's a great workaround, thank you!

I faced same problem and figured out what i did wrong.

When bot receives user consent to upload file its response has replyToId. 

 It is the activity id that needs to be used  to send the file info card ie. https://smba-traff....../conversation/<conversationId>/activities/<replyToId>

After making this change it worked . I have used buttons in teams card and there also to update the card once button is clicked replyToId is used.

"replyToId": "1:1_lchIqmYZbPTi2xph1pGR-4BGAjaduRNThQZ6GTWEh4",
"value": {
"type": "fileUpload",
"action": "accept",
"context": {},
"uploadInfo": {
"contentUrl": "https:///contosco....Documents/Applications/Athakur_laptop/text_file1.doc",
"name": "text_file1.doc",
"uploadUrl": "",
"uniqueId": "E4F8E72D-7D61-403C-9D6B-31E595EDC5B5",
"fileType": "doc"

We just experienced this today with a .pdf in a Teams Chat that would not allow us to click on it and it displayed the "insecure" and alert triangle icon. I tried a link, as suggested in this thread, (from my OneDrive) and that gave us the same "insecure". I renamed the pdf (and made the name about 20 characters shorter) and that allowed us to attach the file in the same Chat with no issues. I don't know if it was the renaming or the shorter name, but it may help somebody.

@Steve Maze So it's a known problem in 2020 and it still is happening?! Yikes Microsoft.

Same problem here within Teams and jpg files attached to a Teams posting using the Android Teams smartphone app. Interesting: Attached jpgs are visible in the smartphone app but – as "insecure" – not in the posting in the current Windows 11 Teams client but in it's the files section.