Poly X50 and TC8 with Teams

Occasional Visitor

Hi,

I have an X50 running firmware 3.3.2-286154 paired with a TC8 running 3.3.2-210446 which I am attempting to use with Teams. I am able to log into my Teams account on the TC8 however the screen on the X50 doesn't change from the prompt to log in. Simultaneously the TC8 which is now logged in shows "Couldn't find any devices"  "Make sure the device you want to pair is signed into the same Teams account"  

 

How do I sign in the X50 given that I have no way to control it? Should signing in on the TC8 not sign in the X50 also?

12 Replies
Similar situation here. Poly X30 + X50 with TC8... (not sure of the versions right now though).

It seems that each of the devices do seem to be recognized as "standalone" device rather than the TC being a controller for something else.

I have not been able to dig further into that as the devices are in a remote location and would need to rely on the local technician there, but to me this seems like a bug in the Poly (TC8?) firmware.

In my mind, the (Teams) information should be 'synced' between the 2 devices, which does not seem to be the case. You however still can control camera, volume etc from the TC8.

Sorry for not having a better answer right now. Still trying to understand more and working my way through...

Same problem for me too.  I was able to boot, pair, and login in with the TC8 while the X50 just sat there waiting for me to log it into teams.  I solved this by connecting a USB keyboard into the back of the X50 and entering the username / password.  Not very practical for enterprises that are going to deploy these in large quantities.

Also have the same issue. Thank you for sharing a USB keyboard gets round this bug. Still needs a fix but at least it is now usable.

Same here with X30 and X50s on version 3.4 ...
That bug was also present on 3.3.2 which for us, meant that either the TC8 or the Studio (Or both) got disconnected from Teams after the upgrade to 3.3.2

What changed now, the TC8 is -sometimes- classified as a "Touch Console" when you look for collab bars which wasn't present in January 2021.

Did any of you manage to make the remote device sign in provisioning work on the Poly collab bar (Or any other bar) ?

There is an article describing how the TC8 interacts with Teams over on Jeff Schertz's blog. This describes how the new MTRoA interface does its magic to work like an MTRoW interface without having a direct USB connection like the MTRoW variant. It is essentially a separate device and though the hardware is Bluetooth paired, the Teams application layer does not directly pair over the LAN or Bluetooth but via the device's registration with Teams cloud services. Image below from Jeff Schertz:

image-2

 

Jeff mentions that an administrator will facilitate a one-time connection between devices during deployment. 

 

Unfortunately, this does not appear to be true. It seems to be occurring with every update. I hope this isn't the permanent state of things.

@MarkDunne  We had the same issue, we were blocking some ports and that was the cause.

 

We connect both devices in a different network with no restrictions and they synced in MicrosoftTeams and no problem.

 

When we brought them back to our network and check which ports were needed they seem to find each other with no problems and no need to open any specific ports in our own network.

 

Has been working since then

@MarkDunne 

 

I was having this exact problem and tried signing out, signing back in to both devices multiple times. 

 

What finally worked for me is once I was logged into both and seeing the "Cant find any devices" message, I went into settings and into the Debug window. Then clicked Restart - Restart both devices.

 

Once they both rebooted (weird that it said it cant see any devices but its able to reboot the device!!) it then gave me the option to connect to the Polycom X50!

 

Hope this solves the issue for anyone!

@JohnC0404 

 

You are my hero! Hours of struggling with the X50/TC8 pairing after a Teams Update was applied to it. Neither Microsoft nor Poly could provide any sort of meaningful support, just blamed the other party. But Restart - Restart Both Devices was a winner! Working great. Upvote this in Google so anyone else having X50 TC8 Not Pairing will get to this forum post!!

hi, anyone have any information regarding remote sign/sign out on Teams Room on Android devices?
We deployed several x50s ( without using the MAC option to provision the devices) and was hoping that Microsoft would release the option to sign/out of the device from Tams admiin center but no such luck. I think if I totally signout of the devices, delete the device from Teams admin center and use the MAC address to provision the device, I think it will have the option to signout/in going forward. ( I think, have not tried ) but... how about devices already provisioned?
I see that Teams Room on Windows has the option to signout/in be default.
Anyone can give any details or experience?
Me again, regarding X50 and TC8 panel pairing and firmware update. In January, we deployed the latest updates via Teams admin center. All of our X50s received the updates no problem but I noticed that severa dozens of our TC8s did not update to the latest Teams app update '1449/1.0.96.2021122201'. They are stuck in previous version '1449/1.0.96.2021120201' (see the last 4 digits ) and what is weird is that the Update Software button in admin center is grayed out and the device shows as healthy. No matter what I do, I can get admin center to give me option to update the TC8. Anyone experienced this issue? Look closely at your admin center since it shows healthy and you might miss it. thanks

This worked for me as well.  Thank you for posting.  @JohnC0404 

@JohnC0404 - Thanks for this, but i just wanted to clarify your process since, I too, an experiencing this nonsense.  When you say logged into both, are you hooking up a USB keyboard to the X50 to verify it is both logged into its Teams account, in addition to manually logging into the touch console of the TC8, and after both criterias are met - hitting Debug > Restart > Restart Both Devices from only the TC8 console?  TIA!