Persistent error message when attempting to manage tags

Occasional Visitor

I seem to get the same "We had trouble applying your changes. Please try again later." whenever I attempt to manage, create, or adjust tag settings within Microsoft Teams. All other Team settings are fully functional and I am the owner of the Organisation. 


Really confused as to what is occurring. I've tested this across multiple devices and platforms to no avail. Any advice or guidance would be very much appreciated. Screenshots of error message attached.




9 Replies
Same consistent experience within the web client? ( Try logging out and clearing the cache Let me know how it goes Best, Chris

@James_Parr I'm having the same issue. I noticed the users I'm unable to tag all also do not show up in the Member list for my org-wide group. When I go into "manage team" they show up, but they are not in the "people pane" for the team.

@James_Parr- Did you get to the bottom of this? I'm also seeing this problem but with just a single Team.


Tags are set to owners only, I am an owner but I see the exact issue you posted. If I try and change the tags settings to allow members to add tags, I see '* An error occurred while changing the permissions. Please try again.'

Wanted to come back on this - I managed to fix it by using a different (unfederated) account as a team owner. 

That allowed me to change the settings, and add tags, and now the Team is behaving as expected for everyone.

@Christopher Hoard 

We are facing the same error. Another team owner is able to manage tags (who is owner of the team since e few months already). I receive the same error message in Teams client for Windows, Teams web app and the app on my Android phone.

The attempt to change the permissions of who can manage tags in a team fails as well.

Any other hints about how I can make it working with my account?

@James_Parr I figured it out! For some reason the members of the Teams get corrupted. You need to remove everyone from the MS Teams and re-add them as members/owners and then it works again. Silly but works :)

OK, I just tested it again and it is working now. Adding tags previously failed with at least 3 teams and it is working for the same teams now. I did not remove any members from the team and I was not in touch with Microsoft. I assume this was a general problem for some Teams users and Microsoft figured it out themselves.

Thanks to this forum I was able to fix this.

A colleague had similar issues, I was able to isolate it to his user as I did could not reproduce it. 

Therefore only he had to be removed and re-added to the group (and repromoted to owner) to then work Tags as normally. 

So no need to remove everyone - just those that have the issue and should solve the issue. 

Hey, I still have the error "We had trouble applying your changes. Please try again later."


any help ?