Only people with access to this org can join its meetings

Brass Contributor

We moved to Teams Only mode two weeks ago and now we have problems with Teams meetings with some organizations. Everything is configured using this checklist:
But still for some reason when we try to have a Teams meeting with them the users get this error message:
"Only people with access to this org can join its meetings. If you have an account with access to this org, sign in with that account. Otherwise, contact the meeting organizer."

The meetings were scheduled from Outlook. What could cause this?

31 Replies
best response confirmed by Tomas_S (Brass Contributor)

@Tomas_SI had to ask Premier support and their answer was:
"As you want to communicate with the different organisations who is not a part of your domain that's why we would be require to enable this setting "Anonymous users can join a meeting".  And yes this is secure. And if there is the limitation on guest users tenant then those guest wont be able to join so... Because they have restricted there tenant for the same.


And yes for External access there are 3 options which can be set according to the needs of the organization :

  • Off Completely 
  • On except for blocked Domains: In this you can mentioned the domains which you need to block.
  • On only for allowed domains: And in this you can mentioned those domains for which you want to communicate "

HI  @Tomas_S,


have you fixed your issue? We are facing same and we do not know how to fix it.





@Miroslav Novák 


You have to enable "Anonymous users can join a meeting" setting.

Hi, do you have an information how to block concrete domains for meetings? I know that it is possible in External access but how to do it for meetings?



Anonymous access is something different, MS is giving the possibility to invite users authenticated via MS, google or using an OTP for other random domains.

Can we have a solution to this problem ?

@Tomas_S it takes a few hours to enable, or so it appears, so this change can't be made to allow access to a meeting in progress or about to begin.  

@Tomas_S I am having the same problem with just 1 member of my organisation. All account settings are the same as everyone elses, we have external users on so I really do not know where to go now.

@zandybear Gibt es bereits eine weitere Lösung? Etwas anderes als "Anonyme" zulassen? Haben auch das Gleiche Problem. 

@DG-DE I found our user was signed in in another account. There is a known problem that if you have specified users from ecternal companies, it can cause problems such as this.

@zandybearOk, danke. Habe das geprüft und ist bei uns leider nicht der Fall. Werde jetzt nochmal auf Support von Microsoft warten (habe seit 2 Tagen keinen Anruf erhalten) :(

@Tomas_S even after changing the Anonymous users can join a meeting to yes and waiting 2 days its not working or users are getting same error code. do you have any suggestion. 

@NiladriJJG Hi. I'm facing the same issue now.  Did you resolve your issue here?

@Tomas_S  I have been troubleshooting this for two days. We just started experiencing this error since about January 11th 2021. Then again, we just activated "guest users" for MSTeams in Dec. 2020.

What I noticed in Azure AD, under the user profile, are that accounts with "Identity Issuer" set to all work great, but the accounts set to "mail" do not.  If I delete the user completely and add them back in from that screen as a guest user, they are able to login and get to meetings and other MSTeams features.  It is like the user's original account creation got "stuck" somewhere and never made it to the "External Azure AD".  The users of these accounts had attended a meeting or two prior to this happening, so I am not sure what changed for us.

Again, the only fix was to delete the account, then add it back in from Azure AD, under guests.

I know this is an old thread, but have this same issue that popped up out of nowhere.  All guest access in that article has always been enabled.


The only thing I don't have checked is in the MS Teams Admin panel, Meetings, Meeting Settings, the first option, "Anonymous users can join a meeting" is disabled. Rest looks OK. But, that setting seems to mean anybody with the link can join the meeting.


A guest should be able to join per the article related to joining a meeting without an account: idea what is going on.  MS has thrown so many changes into the Teams environment the past six months, and I recall guest stuff many times being in the articles/updates...but not sure what exactly is going on.


The person does not have a guest account in our ADS, we run a hybrid environment, but in the cloud there is no guest email/user with the name that is having the issue.  Shouldn't even be a thing, any joker that has the link I guess should be able to join, then the person who is the owner should have a notice to allow them in once they connect.


Just wondering if that option I mentioned earlier matters?  I enabled it for now and told the person to test with the user and let me know tomorrow.



@Tech Logik 

I have had exactly the same issue again today! It was all sorted and had been working fine until now. /as with you. anonymous was off. I have had it switched on and asked the user trying to access to try again tomorrow. Please let me know what happens.



User just finished a test and it worked.  So, assume that anonymous setting had something to do with it. Either that, or MS had some intermittent issue causing it??


Only way to know for sure would be to turn it off again...but rather would not.


Good luck and report back please your findings as well.



.@Tech Logik  Excellent. Thanks for letting me know. I will test soon and report back.

We're experiencing that same issue. I have no idea why. I delete the Guest user and add back fresh, no luck. It's a gmail account of which we have many others that work fine. This one in particular keeps showing up with an identity issuer of 'mail' and it's driving us crazy. It breaks the sharing functionality.
Been looking at this issue for the past hour starring at the screen wondering what I was doing wrong.. patience is the key I guess.