OneNote fails to open when using "Open in app" from Teams

Copper Contributor


A first-time poster... be kind :)  I’ve searched the posts and haven’t found a similar complaint, so here it goes…


In Teams (web or app), a OneNote file stored in a Teams channel can be opened successfully using the “Edit in Teams” or “Open in browser” feature of Teams.  However, when attempting to open the same OneNote file with the "Open in app" feature of Teams, the default OneNote app (modern or desktop) pops warning/error messages and fails to open the notebook. 

  • OneNote 2009 (aka OneNote desktop) first shows a Security Notice message indicating the “location may be unsafe”.  Clicking Yes to continue then shows an error stating “We can’t open that location”.

Teams and OneNote failure - OneNote Desktop.jpg



  • OneNote for Windows 10 (aka OneNote modern) shows an error stating “Sorry, we can’t open the notes that you were looking for”.

Teams and OneNote failure - OneNote Modern.jpg



We’ve reproduced the issue…

  • across Windows 10 PC's
  • across M365 Tenants
  • with both versions of OneNote (modern and desktop)
  • with various M365 users (licensed, unlicensed, and guests) 
  • and across Teams clients (web and app)

I’m pretty sure this has worked fine in the past, but I can’t provide a specific date when I think it last worked correctly.


Works from SharePoint

When using "Open in app" from SharePoint, the same OneNote file opens successfully with either OneNote app as the default in Windows.  OneNote desktop still warns “the location may be unsafe” but clicking Yes to continue opens the notebook successfully.  OneNote modern opens the notebook successfully, showing no error or warning.


Works with other Office files

Word, Excel, and PowerPoint files all open successfully in their respective apps using the “Open in app” feature of Teams (web and app).


A “Tail” of Two URLs

If OneNote desktop is the default app in Windows for the "onenote:" URL, the Security Notice warning message provides the actual URL passed to OneNote.  

Teams and OneNote failure - Security Notice.jpg

The Security Notice shows that the onenote: URLs used by the "Open in app" feature in SharePoint versus Teams are identical except that Teams adds additional "junk" to the end of the URL.  This “junk” seems to cause the failure. 


The example above shows an attempt to “Open in app” the “test beta notebook” OneNote file from the General channel of the Beta Team.  The extra “junk” is shown below in red at the end of the Teams URL (second bullet).

  • SharePoint = onenote:https://<tenant> Documents/General/test beta notebook
  • Teams = onenote:https://<tenant> Documents/General/test beta notebook|f|tdd7c600f-a1ed-4df3-bb90-eb4ae1258079


Post-Failure, OneNote lists the notebook

Interestingly, after failing, the OneNote file is listed in both versions of OneNote as an additional notebook to open – and will open successfully if you try to open it directly from OneNote’s list of additional notebooks.


7 Replies

@nduncan I can confirm the same issue, I would suggest getting you admin to open a support ticket.


I've never actually tried that with OneNote, I typically add a tab to my Teams for the notebook, and the 'Open in App' option there seems to work fine.

@StevenC365  - thanks for confirming its not just me. :)


I do have an open ticket with support, but nothing conclusive so far.


And yes, using the tab approach in Teams for a OneNote is a workaround we're implementing, thanks.



@nduncan did you ever hear back from support? I'm having the same issue but can't find any solutions for it. I'm able to open in app from everywhere except from Files in Teams app. Curious if anyone was able to provide an answer.

Still an issue as of 6th Sept 2021.


Can open everywhere except on desktop. I'm even logged in with OneNote on my Organizational Account.

@josephmcg16  hi! i have exact the same problem. any solutions found?

with us it is a problem with the firewall, unfortunately I do not know which URL one must release here exactly. outside of my organization (without firewall) it works.

@majani hello!


I think I managed to get a workaround by opening the notebook from the OneNote Windows 10 app.


I don't remember for sure though, sorry!


ps. MS support for OneNote isn't the best, unfortunately. They essentially ditched OneNote 2016 and moved to OneNote Windows 10, I have heard they are ditching this version again and making a completely new app! :xd:

thank you for your answer. i was able to solve the problem this morning. i had to create a proxy exception in my firewall with the URL after that it works fine. it can be that simple sometimes. :)