One user can't move/pin apps on left bar

Copper Contributor


We have a small problem in the deployment of Teams inside our organisation. Perhaps someone can guide us : one of our user can't customize its left bar (pin apps like Planer, OneNote, ... reorder apps, ...) whereas all other can in our organisation.


As Teams Admin, I've taken care to setup app policies the same way for all users (in fact we only have one global policy), especially I've well activated the "Allow user pinning" button in it (cf And if I add pined apps in the app setup policy, the user well see them appear but stil can't move/pin apps ... like "Allow user pinning" button has no effect for him. We really don't understand why.


Additional tests we have done :

- uninstall/clear local Teams cache/reboot/reinstall >> still the same problem

- Remove Teams for this user in Office365 admin center and reauthorize >> still the same problem

- another user logs in Teams Desktop on the PC of the user who has the problem >> other user can pin apps (so it seems that Teams desktop client is not the problem)

- user who has the problem logs in Teams Desktop on the PC of another user who hasn't the problem >>user still can't pin apps (same conclusion)

- Use the Teams web client >> Same problem

- Create a new app setup policy (with Allow user pinning" button activated) and affect it to user >> Same problem


We are running out of ideas ... if anyone has some, it would be useful, thanks !

Last point : user who has the problem was a very early beta user of teams in our organisation (since end 2018) ... perhaps something specific of the Teams very first versions is still activated for him !?!?


7 Replies

Captures of Teams Admin center. It has been kept simple and all users have the same Global policy.



Hi @jlongchamp

As it's an issue on the web client as well as the desktop client could be something on the back end. Could try forcing the policy with Powershell

Grant-CsTeamsAppSetupPolicy -identity "Ken Myer" -PolicyName StudentAppSetupPolicy

Let me know how it goes

Best, Chris
It could be a rollout issue, sometimes some users don't get updates when others do. Could be whats going on here that that user for whatever reason still doesn't have the update or it's stuck in cache on the back end for them etc. This is a pretty new feature that just started rolling out so it could be that as well.

Hi @jlongchamp ,


I encounter same issue. Do you have the resolution? 

I have the exact same issue at work and am trying to resolve.
Has anyone resolved this issue? I have a customer with similar problem and nothing seems to be fixing the pin issue.

I was experiencing this issue in both the desktop clients and online client of Microsoft Teams. I was able to resolve it by unpinning all but one of my pinned apps, adding the pin I desired to be my first, removing the last of the previous pins, and repinning the rest of the desired apps. 


After doing this song and dance, I was able to reorder my pins normally where previously, I was not getting the white line indicating where the pinned app would be moved to.