Obsolete Organization not being removed in Teams desktop client

%3CLINGO-SUB%20id%3D%22lingo-sub-1425545%22%20slang%3D%22en-US%22%3EObsolete%20Organization%20not%20being%20removed%20in%20Teams%20desktop%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1425545%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20experiencing%20an%20issue%20that%20I%20thought%20the%20community%20may%20be%20able%20to%20help%20address.%20I%20have%20an%20Office%20365%20Subscription%20and%20have%20Teams%20setup%20for%20my%20Company.%20Using%20Teams%20I%20joined%20another%20Organization%20(via%20email%20invite)%20to%20collaborate%20on%20a%20project.%20After%20the%20project%20had%20completed%20I%20went%20into%20%3CA%20href%3D%22https%3A%2F%2Fmyapps.microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmyapps.microsoft.com%3C%2FA%3E%20and%20selected%20the%20%22Leave%20organization%22%20link%20beside%20the%20company.%20Issue%20is%20that%20within%20both%20the%20web%20and%20thick%20client%20for%20Teams%20the%20organization%20I%20removed%20myself%20from%20still%20appears%20in%20the%20drop%20down%20list%20as%20an%20option%20to%20switch%20to%20that%20organization%20(of%20course%20it%20fails%20as%20it%20should).%20To%20top%20it%20off%20when%20I%20went%20to%20add%20a%20new%20Organization%20via%20a%20Teams%20invite%2C%20it%20will%20not%20appear%20in%20the%20list.%20This%20is%20definitely%20causing%20issues.%20I%20am%20using%20Windows%2010%20Pro%20(64%20bit)%2C%20Teams%20(64%20bit%2C%20latest%20version%20from%20Microsoft).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-%20Tried%20logging%20out%2Fin%20of%20all%20Microsoft%20services%3CBR%20%2F%3E-%20Tried%20purging%20all%20instances%20of%20the%20Teams%20client%20cache%3CBR%20%2F%3E-%20Tried%20reinstalling%20the%20Teams%20client%3C%2FP%3E%3CP%3E-%20Waiting%20for%204%20hours%20(maybe%20not%20long%20enough%3F)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20for%20any%20ideas!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1425545%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETeams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1425934%22%20slang%3D%22en-US%22%3ERe%3A%20Obsolete%20Organization%20not%20being%20removed%20in%20Teams%20desktop%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1425934%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F682958%22%20target%3D%22_blank%22%3E%40nberendt%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi.%204%20hours%20is%20not%20long%20enough.%20This%20will%20take%20up%20to%202%20days%20(in%20my%20experience).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1426640%22%20slang%3D%22en-US%22%3ERe%3A%20Obsolete%20Organization%20not%20being%20removed%20in%20Teams%20desktop%20client%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1426640%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F533323%22%20target%3D%22_blank%22%3E%40StephanGee%3C%2FA%3E%3C%2FP%3E%3CP%3ECopy.%20Thank%20you%20for%20the%20insight%3B%20appreciated!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I am experiencing an issue that I thought the community may be able to help address. I have an Office 365 Subscription and have Teams setup for my Company. Using Teams I joined another Organization (via email invite) to collaborate on a project. After the project had completed I went into https://myapps.microsoft.com and selected the "Leave organization" link beside the company. Issue is that within both the web and thick client for Teams the organization I removed myself from still appears in the drop down list as an option to switch to that organization (of course it fails as it should). To top it off when I went to add a new Organization via a Teams invite, it will not appear in the list. This is definitely causing issues. I am using Windows 10 Pro (64 bit), Teams (64 bit, latest version from Microsoft).

 

- Tried logging out/in of all Microsoft services
- Tried purging all instances of the Teams client cache
- Tried reinstalling the Teams client

- Waiting for 4 hours (maybe not long enough?)

 

Thank you for any ideas!

2 Replies
Highlighted

@nberendt 

Hi. 4 hours is not long enough. This will take up to 2 days (in my experience).

 

Highlighted

@StephanGee

Copy. Thank you for the insight; appreciated!