Not able to Create MS Teams meeting via Outlook 365 on Mac

Copper Contributor

Dear all,

Few day ago, this feature was worked well. After up to date the latest version of Outlook, 

try to create MS Teams meeting via Outlook 365, it doesn't work anymore.


Anyone met same issue recently.


Outlook version:


MS teams version :



Got error message like this:




Thank you

24 Replies
First, check if you are logged into your own tenant in Teams, and not in another tenant as a guest. This can cause issues when scheduling via outlook.

Can you schedule meetings normally from the Teams client?

@adam deltinger 

Thank you for quick response.


  • No meeting button on my left side menu:


  • I'm not joined as guest,  daily working via MS teams, especially recent days.



Have this been there before? Other users? Do they have the same problem?

Yes with PC. The first meeting I created was successful, however the next meeting I attempted to create immediately after the first, gave me this error message "We couldn't schedule the meeting. Please try again Later". I restarted my computer and cleared the cache however with no success.
Did you have calendar button before?
Are you logged into your own tenant, not guest?
Can you schedule from other client?
Can other people schedule meetings?

Is this free teams?


1. See the Pic


2. No guest, Our company purchase the office 365 familiy meals. :)

3.  I can schedule MS teams meeting  on my Windows client (Outlook)

4. will check later, not all people use Mac in may company.  But this working well on windows.


Not free teams.


@adam deltinger 


for left side menu, never show the meeting button. :(


I'm using MS teams almost 1 year on windows. First met this problem on Mac



@adam deltinger  Thanks Adam, switch to Window 10.



I have the same issue. and nothing worked., Apparently if you remove the license and connect with Exhange server the button comes back, but then the emails are not popping up.@Eugene_Cao 

Hi @adam deltinger ,


we have the same issue like discribed in that post with one Mac client. Poorly the link you've posted refers to the wrong website I guess. Could you repost the link please?

The Mac user is reinstalling Outlook for the second time already, to solve the problem. What I've checked:

  • Teams button is available
  • Teams ist started before Outlook
  • The user is logged into our own tenant
  • He is using the correct licence
  • He's the only user affected, every other Mac/Windows clients work fine


Or shall I open a new thread?




This trick from Microsoft support fixed the issue for me:

If you are unable to create a Teams meeting from Outlook, please perform the below steps and let me know the outcome of it.
1. Quit all Office applications in your Mac device.
2. Open Microsoft Word.
3. Sign out of the account that is logged in.
4. Sign back in.
5. Now re-launch Outlook and try to create the meeting again.

Thank you @Malachite27 this finally works for me.



I notice I am having the same problem with my Outlook for Mac and scheduling of Teams meetings. I did as you suggested and logged back in (I have  365 business account), but still not able to see this in Outlook. 

I logged into my calendar on Outlook for web and I can schedule Teams meeting there, so I am assuming it is something having to do with Outlook for Mac. I am running Outlook for Mac Version 16.41 as part of my 365 subscription.  

I guess the good thing is that I can, when needed, go to webmail and schedule the meeting. We use Zoom and Teams depending on the client. Zoom add-in works great for Outlook for Mac, but would like to be able to do both.  

Thanks for your help.  



I have exactly the same problem.   Were you able to fix it?  How did you do it?

@mlarach it just started working for me on its own. I gave up and then a couple weeks later it just started working as it should.   

Hi everyone. I did a temporary solution while Microsoft fixes the issue. You need to have your same email added as a Office 365 email account even if it is a Gmail account. So go to Accounts then Add under exactly the same address but when it ask you and it says Google click (Not Google).

So, go the Settings/Accounts/New Account